升级到8.04后无法打开文件夹等问题

为当前最终发行版之前的所有版本提供支持
回复
after17
帖子: 71
注册时间: 2007-04-25 10:19
来自: EE,SCUT
送出感谢: 0
接收感谢: 0

升级到8.04后无法打开文件夹等问题

#1

帖子 after17 » 2008-04-02 12:05

开机提示装入主题Human出错

症状:桌面图标全没,nautilus没反应,文件夹打不开

sudo apt-get upgrade
正在读取软件包列表... 完成
正在分析软件包的依赖关系树
Reading state information... 完成
下列的软件包的版本将保持不变:
acpi-support adept-batch adept-installer adept-manager adept-notifier
adept-updater afterstep alsa-tools-gui amarok amarok-xine amor apt apt-utils
aptitude ardour ark artsbuilder at-spi atlantik atlantikdesigner audacious
audacious-plugins audacious-plugins-extra audacity bluez-utils
………………………………

下列的软件包将被升级:
human-theme
共升级了 1 个软件包,新安装了 0 个软件包,要卸载 0 个软件包,有 711 个软件未被升级。
有 1 个软件包没有被完全安装或卸载。
需要下载 0B/28.8kB 的软件包。
解压缩后会消耗掉 61.4kB 的额外空间。
您希望继续执行吗?[Y/n]y
(正在读取数据库 ... 系统当前总共安装有 416745 个文件和目录。)
正预备替换 human-theme 0.9 (使用 .../human-theme_0.14_all.deb) ...
正在解压缩将用于更替的包文件 human-theme ...
dpkg:处理 /var/cache/apt/archives/human-theme_0.14_all.deb (--unpack)时出错:
正试图覆盖“/usr/share/applications/screensavers/ubuntu_theme.desktop”,它属于软件包 gnome-screensaver
在处理时有错误发生:
/var/cache/apt/archives/human-theme_0.14_all.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
nwpu043793
帖子: 39
注册时间: 2007-11-01 14:27
来自: 西北工业大学
送出感谢: 0
接收感谢: 0
联系:

#2

帖子 nwpu043793 » 2008-04-11 23:29

我的问题同上
after17
帖子: 71
注册时间: 2007-04-25 10:19
来自: EE,SCUT
送出感谢: 0
接收感谢: 0

#3

帖子 after17 » 2008-04-12 0:14

我本来还装了kde,所以去到kde环境下面apt-get updata, upgrade之后发现原来还有很多东西没更新,更新安装后就好了。
SeanXue
帖子: 1
注册时间: 2008-05-03 16:32
送出感谢: 0
接收感谢: 0

#4

帖子 SeanXue » 2008-05-03 16:35

在升级发生错误的时候,执行
sudo cp /cdrom/pool/main/h/human-theme/human-theme_0.18_all.deb /var/cache/apt/archives/
sudo dpkg -i --force-depends,overwrite /var/cache/apt/archives/human-theme_0.18_all.deb

sudo apt-get -f install

sudo apt-get update
sudo apt-get dist-upgrade
iliaojie
帖子: 66
注册时间: 2007-10-09 20:40
送出感谢: 0
接收感谢: 0
联系:

#5

帖子 iliaojie » 2008-06-17 22:54

SeanXue 写了:在升级发生错误的时候,执行
sudo cp /cdrom/pool/main/h/human-theme/human-theme_0.18_all.deb /var/cache/apt/archives/
sudo dpkg -i --force-depends,overwrite /var/cache/apt/archives/human-theme_0.18_all.deb

sudo apt-get -f install

sudo apt-get update
sudo apt-get dist-upgrade


无效,,重装第三遍中............
iliaojie
帖子: 66
注册时间: 2007-10-09 20:40
送出感谢: 0
接收感谢: 0
联系:

#6

帖子 iliaojie » 2008-06-18 5:11

解决了,human-theme_0.18_all.deb这个文件下载的ISO文件中没有,
你可以从

http://ftp.otenet.gr/linux/ubuntu/pool/ ... e/?C=N;O=D

下载,,human-theme_0.18_all.deb

将他CP到/var/cache/apt/archives/

再执行:sudo apt-get install -f
即可
ronaldo_4
帖子: 1
注册时间: 2008-06-01 23:42
送出感谢: 0
接收感谢: 0

#7

帖子 ronaldo_4 » 2008-08-03 18:42

iliaojie 写了:解决了,human-theme_0.18_all.deb这个文件下载的ISO文件中没有,
你可以从

http://ftp.otenet.gr/linux/ubuntu/pool/ ... e/?C=N;O=D

下载,,human-theme_0.18_all.deb

将他CP到/var/cache/apt/archives/

再执行:sudo apt-get install -f
即可
我也一样的 问题,困扰好久了。
下载到/var/cache/apt/archives/ 出错,提示。。。because you cannot change the contents of that folder...
回复

回到 “老旧版本支持”