[问题]升级到8.04后,virtualbox不能启动。

为当前最终发行版之前的所有版本提供支持
回复
plasma2006
帖子: 466
注册时间: 2006-10-19 9:17
送出感谢: 0
接收感谢: 0

[问题]升级到8.04后,virtualbox不能启动。

#1

帖子 plasma2006 » 2008-04-08 15:50

VirtualBox kernel driver not installed. The vboxdrv kernel module was either not loaded or /dev/vboxdrv was not created for some reason. Re-setup the kernel module by executing '/etc/init.d/vboxdrv setup' as root.
VBox status code: -1908 (VERR_VM_DRIVER_NOT_INSTALLED).


返回 代码:
0x80004005
组件:
Console
界面:
IConsole {1dea5c4b-0753-4193-b909-22330f64ec45}
按照上面提示在终端输入sudo /etc/init.d/vboxdrv setup
出现:* Stopping VirtualBox kernel module vboxdrv [ OK ]
* Recompiling VirtualBox kernel module vboxdrv
* Look at /var/log/vbox-install.log to find out what went wrong
然后退到终端。这是怎么回事???
plasma2006
帖子: 466
注册时间: 2006-10-19 9:17
送出感谢: 0
接收感谢: 0

#2

帖子 plasma2006 » 2008-04-08 15:51

vbox-install.log如下::
make KBUILD_VERBOSE=1 -C /lib/modules/2.6.24-15-generic/build SUBDIRS=/tmp/vbox.8 SRCROOT=/tmp/vbox.8 modules
make[1]: Entering directory `/usr/src/linux-headers-2.6.24-15-generic'
test -e include/linux/autoconf.h -a -e include/config/auto.conf || ( \
echo; \
echo " ERROR: Kernel configuration is invalid."; \
echo " include/linux/autoconf.h or include/config/auto.conf are missing."; \
echo " Run 'make oldconfig && make prepare' on kernel src to fix it."; \
echo; \
/bin/false)
mkdir -p /tmp/vbox.8/.tmp_versions ; rm -f /tmp/vbox.8/.tmp_versions/*
make -f scripts/Makefile.build obj=/tmp/vbox.8
gcc -m32 -Wp,-MD,/tmp/vbox.8/linux/.SUPDrv-linux.o.d -nostdinc -isystem /usr/lib/gcc/i486-linux-gnu/4.2.3/include -D__KERNEL__ -Iinclude -include include/linux/autoconf.h -Wall -Wundef -Wstrict-prototypes -Wno-trigraphs -fno-strict-aliasing -fno-common -Werror-implicit-function-declaration -O2 -pipe -msoft-float -mregparm=3 -freg-struct-return -mpreferred-stack-boundary=2 -march=i586 -mtune=generic -ffreestanding -maccumulate-outgoing-args -Iinclude/asm-x86/mach-default -fomit-frame-pointer -g -fno-stack-protector -Wdeclaration-after-statement -Wno-pointer-sign -I/lib/modules/2.6.24-15-generic/build/include -I/tmp/vbox.8/ -I/tmp/vbox.8/include -I/tmp/vbox.8/r0drv/linux -D__KERNEL__ -DMODULE -DRT_OS_LINUX -DIN_RING0 -DIN_RT_R0 -DIN_SUP_R0 -DCONFIG_VBOXDRV_AS_MISC -DRT_ARCH_X86 -DVBOX_WITHOUT_IDT_PATCHING -DUSE_NEW_OS_INTERFACE_FOR_MM -DMODULE -D"KBUILD_STR(s)=#s" -D"KBUILD_BASENAME=KBUILD_STR(SUPDrv_linux)" -D"KBUILD_MODNAME=KBUILD_STR(vboxdrv)" -c -o /tmp/vbox.8/linux/.tmp_SUPDrv-linux.o /tmp/vbox.8/linux/SUPDrv-linux.c
In file included from /tmp/vbox.8/include/iprt/types.h:72,
from /tmp/vbox.8/include/VBox/types.h:21,
from /tmp/vbox.8/SUPDRV.h:26,
from /tmp/vbox.8/linux/SUPDrv-linux.c:22:
include/linux/types.h:40: 错误: typedef‘uintptr_t’重定义
/tmp/vbox.8/include/iprt/stdint.h:118: 错误: ‘uintptr_t’的上一个声明在此
在包含自 include/linux/thread_info.h:33 的文件中,
从 include/linux/preempt.h:9,
从 include/linux/spinlock.h:49,
从 /tmp/vbox.8/SUPDRV.h:87,
从 /tmp/vbox.8/linux/SUPDrv-linux.c:22:
include/linux/bitops.h:6:1: 警告: “BIT”重定义
在包含自 /tmp/vbox.8/include/VBox/cdefs.h:20 的文件中,
从 /tmp/vbox.8/SUPDRV.h:25,
从 /tmp/vbox.8/linux/SUPDrv-linux.c:22:
/tmp/vbox.8/include/iprt/cdefs.h:1042:1: 警告: 这是先前定义的位置
make[2]: *** [/tmp/vbox.8/linux/SUPDrv-linux.o] 错误 1
make[1]: *** [_module_/tmp/vbox.8] 错误 2
make[1]: Leaving directory `/usr/src/linux-headers-2.6.24-15-generic'
make: *** [vboxdrv] 错误 2
plasma2006
帖子: 466
注册时间: 2006-10-19 9:17
送出感谢: 0
接收感谢: 0

#3

帖子 plasma2006 » 2008-04-08 15:53

谁能帮我从vbox-install.log中看出端倪??
谢谢
头像
gaint_star
帖子: 413
注册时间: 2008-02-20 0:09
来自: 深圳
送出感谢: 0
接收感谢: 0
联系:

#4

帖子 gaint_star » 2008-04-08 16:22

linux-headers-2.6.24-15-generic安装了?

代码: 全选

sudo apt-get install build-essential
sudo apt-get install linux-headers-`uname -r`
生活就像对待Linux一样,要敢于折腾也要学会折腾。
──────────────────────────────────
@picobird
jarod007
帖子: 148
注册时间: 2006-10-20 5:55
送出感谢: 0
接收感谢: 0

#5

帖子 jarod007 » 2008-04-08 16:42

:lol: 这次15出的很及时
plasma2006
帖子: 466
注册时间: 2006-10-19 9:17
送出感谢: 0
接收感谢: 0

#6

帖子 plasma2006 » 2008-04-08 17:21

sudo apt-get install build-essential
正在读取软件包列表... 完成
正在分析软件包的依赖关系树
读取状态信息... 完成
build-essential 已经是最新的版本了。
共升级了 0 个软件包,新安装了 0 个软件包,要卸载 0 个软件包,有 15 个软件未被升级。


sudo apt-get install linux-headers-`uname -r`
正在读取软件包列表... 完成
正在分析软件包的依赖关系树
读取状态信息... 完成
下列的软件包将被升级:
linux-headers-2.6.24-15-generic
共升级了 1 个软件包,新安装了 0 个软件包,要卸载 0 个软件包,有 14 个软件未被升级。
需要下载 644kB 的软件包。
操作完成后,会消耗掉 0B 的额外磁盘空间。
获取:1 http://archive.ubuntu.com hardy/main linux-headers-2.6.24-15-generic 2.6.24-15.27 [644kB]
下载 644kB,耗时 16s (39.1kB/s)
(正在读取数据库 ... 系统当前总共安装有 307265 个文件和目录。)
正预备替换 linux-headers-2.6.24-15-generic 2.6.24-15.26 (使用 .../linux-headers-2.6.24-15-generic_2.6.24-15.27_i386.deb) ...
正在解压缩将用于更替的包文件 linux-headers-2.6.24-15-generic ...
正在设置 linux-headers-2.6.24-15-generic (2.6.24-15.27) ..

sudo /etc/init.d/vboxdrv setup
* Stopping VirtualBox kernel module vboxdrv [ OK ]
* Recompiling VirtualBox kernel module vboxdrv
* Look at /var/log/vbox-install.log to find out what went wrong

执行这个还是不行。。。。。。。。。
plasma2006
帖子: 466
注册时间: 2006-10-19 9:17
送出感谢: 0
接收感谢: 0

#7

帖子 plasma2006 » 2008-04-08 17:29

sudo apt-get install linux-headers-2.6.24-15-generic
正在读取软件包列表... 完成
正在分析软件包的依赖关系树
读取状态信息... 完成
linux-headsudo apt-get install linux-headers-2.6.24-15-generic
正在读取软件包列表... 完成
正在分析软件包的依赖关系树
读取状态信息... 完成
linux-headers-2.6.24-15-generic 已经是最新的版本了。
linux-headers-2.6.24-15-generic 设定为手动安装。
共升级了 0 个软件包,新安装了 0 个软件包,要卸载 0 个软件包,有 4 个软件未被升级ers-2.6.24-15-generic 已经是最新的版本了。
linux-headers-2.6.24-15-generic 设定为手动安装。
共升级了 0 个软件包,新安装了 0 个软件包,要卸载 0 个软件包,有 4 个软件未被升级
plasma2006
帖子: 466
注册时间: 2006-10-19 9:17
送出感谢: 0
接收感谢: 0

#8

帖子 plasma2006 » 2008-04-08 17:30

郁闷,仍旧不能解决。。。。。。。。。。。。。。。。。。。
头像
gaint_star
帖子: 413
注册时间: 2008-02-20 0:09
来自: 深圳
送出感谢: 0
接收感谢: 0
联系:

#9

帖子 gaint_star » 2008-04-08 18:42

virtualbox几点几版?或者是ose版的?

先将其彻底删除
然后再

在此处下载hardy版VirtualBox_1.5.6-1试试看吧,我今天才重新安装并且编译过的
http://www.virtualbox.org/download/
生活就像对待Linux一样,要敢于折腾也要学会折腾。
──────────────────────────────────
@picobird
头像
hyfyz
帖子: 16
注册时间: 2007-04-30 9:54
来自: 长征路73号
送出感谢: 0
接收感谢: 0

#10

帖子 hyfyz » 2008-04-11 11:54

gaint_star 写了:virtualbox几点几版?或者是ose版的?

先将其彻底删除
然后再

在此处下载hardy版VirtualBox_1.5.6-1试试看吧,我今天才重新安装并且编译过的
http://www.virtualbox.org/download/
多谢了,我下了hardy版的装了就好了!
xuco
帖子: 794
注册时间: 2008-01-30 19:19
送出感谢: 0
接收感谢: 0

#11

帖子 xuco » 2008-04-11 13:45

我都是在新立得里装VB的,
楼主,它说你: "VirtualBox kernel driver not installed",我前两天也碰到了,在新立得里找virtualbox 看到一个和新kernel相关的装上就好了
头像
marsteel
帖子: 555
注册时间: 2005-11-28 12:09
送出感谢: 0
接收感谢: 1 次
联系:

#12

帖子 marsteel » 2008-04-11 13:50

把vbox升级到最新版就可以了
头像
dustin.xu
帖子: 75
注册时间: 2007-10-14 11:51
送出感谢: 0
接收感谢: 0

#13

帖子 dustin.xu » 2008-04-21 21:19

hyfyz 写了:
gaint_star 写了:virtualbox几点几版?或者是ose版的?

先将其彻底删除
然后再

在此处下载hardy版VirtualBox_1.5.6-1试试看吧,我今天才重新安装并且编译过的
http://www.virtualbox.org/download/
多谢了,我下了hardy版的装了就好了!
晕,选项根本没有hardy版的吧?????????
dbzhang800
帖子: 3182
注册时间: 2006-03-10 15:10
来自: xi'an China
送出感谢: 0
接收感谢: 2 次
联系:

#14

帖子 dbzhang800 » 2008-04-21 21:42

hyfyz 写了:
gaint_star 写了:virtualbox几点几版?或者是ose版的?

先将其彻底删除
然后再

在此处下载hardy版VirtualBox_1.5.6-1试试看吧,我今天才重新安装并且编译过的
http://www.virtualbox.org/download/
多谢了,我下了hardy版的装了就好了!
晕,选项根本没有hardy版的吧?????????
virtualbox_1.5.6-28266_Ubuntu_dapper_amd64.deb 20-Feb-2008 18:13 16M
virtualbox_1.5.6-28266_Ubuntu_dapper_i386.deb 20-Feb-2008 18:14 15M
virtualbox_1.5.6-28266_Ubuntu_edgy_i386.deb 20-Feb-2008 18:14 15M
virtualbox_1.5.6-28266_Ubuntu_feisty_amd64.deb 20-Feb-2008 18:15 16M
virtualbox_1.5.6-28266_Ubuntu_feisty_i386.deb 20-Feb-2008 18:15 16M
virtualbox_1.5.6-28266_Ubuntu_gutsy_amd64.deb 20-Feb-2008 18:16 16M
virtualbox_1.5.6-28266_Ubuntu_gutsy_i386.deb 20-Feb-2008 18:17 17M
virtualbox_1.5.6-28266_Ubuntu_hardy_amd64.deb 20-Feb-2008 18:17 16M
virtualbox_1.5.6-28266_Ubuntu_hardy_i386.deb 20-Feb-2008 18:18 17M
回复

回到 “老旧版本支持”