当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 12 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : [问题]我的8.04注销或者重启GDM都会死机
帖子发表于 : 2008-04-11 1:50 

注册: 2007-03-08 9:57
帖子: 85
地址: Rockville MD
送出感谢: 0 次
接收感谢: 0 次
不知道什么原因阿,注销,或者ctrl+alt+backspace,或者使用/etc/init.d/gdm restart都会死机。启动或者关机都是好的。哪里能看到这个死机的信息么?


页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2008-04-11 2:02 
头像

注册: 2007-11-22 10:20
帖子: 3406
地址: 北京
送出感谢: 0 次
接收感谢: 1
欧洲官方源更新,或者正式版出来后更新还是这样的情况,再去解决的好。呵呵哈


_________________
lenovo Thinkpad R60i 0657 LHC
windowsXP……准备换回ubuntu了。

Twitter: @carbont


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2008-04-11 8:00 
头像

注册: 2007-12-09 14:36
帖子: 41
送出感谢: 0 次
接收感谢: 0 次
我装了受限驱动后
Kdm就会这样
用GDM没有遇到过
是不是A卡


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2008-04-11 9:13 
头像

注册: 2005-08-14 21:55
帖子: 58428
地址: 长沙
送出感谢: 4
接收感谢: 272
/var/log/Xorg.0.log看下。不一定能看到。死机难得有完整的记录的。


_________________
● 鸣学


页首
 用户资料  
 
5 楼 
 文章标题 :
帖子发表于 : 2008-04-11 9:43 

注册: 2007-03-08 9:57
帖子: 85
地址: Rockville MD
送出感谢: 0 次
接收感谢: 0 次
我是装了A卡的受限驱动的。等正式版出来再看吧。


页首
 用户资料  
 
6 楼 
 文章标题 :
帖子发表于 : 2008-04-12 4:14 

注册: 2007-11-28 20:42
帖子: 26
送出感谢: 0 次
接收感谢: 0 次
kmeng 写道:
我是装了A卡的受限驱动的。等正式版出来再看吧。


应该是fglrx驱动的问题。只要装了ATI的驱动,使用hardy都会出这样的问题。现在我都不能注销,只能强制重启。没有办法。很多人已经报告了该bug,但不知道如何解决。也许只有等ATI官方驱动更新了


页首
 用户资料  
 
7 楼 
 文章标题 :
帖子发表于 : 2008-04-12 23:21 
头像

注册: 2007-12-09 14:36
帖子: 41
送出感谢: 0 次
接收感谢: 0 次
在控制台里面用命令行重启

或者黑屏的时候用ctrl+alt+delete


页首
 用户资料  
 
8 楼 
 文章标题 : 我的也是啊,新版本了还是这样
帖子发表于 : 2008-04-29 22:37 

注册: 2007-11-28 20:42
帖子: 26
送出感谢: 0 次
接收感谢: 0 次
我的也是啊,新版本了还是这样。
ATI 8.04最新驱动,ubuntu 8.04,T42 Thinkpad
只要注销或者切换终端都会死机,不用受限驱动就没有问题
怎么办啊,很郁闷


页首
 用户资料  
 
9 楼 
 文章标题 :
帖子发表于 : 2008-05-02 0:21 

注册: 2008-05-02 0:14
帖子: 70
送出感谢: 0 次
接收感谢: 1
参考https://bugs.launchpad.net/ubuntu/+source/linux-restricted-modules-2.6.24/+bug/118605/

Stefan Carslöv wrote on 2008-04-13: (permalink)

I had the same problem on my up to date Kubuntu 8.04 Beta. The problem is that /etc/ati/authatieventsd.sh can't locate a file. It's got the wrong path.

In /etc/ati/authatieventsd.sh change this line:
XDM_AUTH_MASK=/var/lib/xdm/authdir/authfiles/A$1*

to:
XDM_AUTH_MASK=/var/run/xauth/A$1*

This solved the black screen hanging on logoff for me.

I'm not quite sure what to change if you're using Gnome, but I suspect it's this line:
GDM_AUTH_FILE=/var/lib/gdm/$1.Xauth

按照这个方法问题应可解决(我就是这样解决的)。另外该页有人做个patch,但没试验过。


页首
 用户资料  
 
10 楼 
 文章标题 :
帖子发表于 : 2008-05-24 22:14 

注册: 2006-10-04 23:16
帖子: 183
送出感谢: 0 次
接收感谢: 0 次
c2 写道:
参考https://bugs.launchpad.net/ubuntu/+source/linux-restricted-modules-2.6.24/+bug/118605/

Stefan Carslöv wrote on 2008-04-13: (permalink)

I had the same problem on my up to date Kubuntu 8.04 Beta. The problem is that /etc/ati/authatieventsd.sh can't locate a file. It's got the wrong path.

In /etc/ati/authatieventsd.sh change this line:
XDM_AUTH_MASK=/var/lib/xdm/authdir/authfiles/A$1*

to:
XDM_AUTH_MASK=/var/run/xauth/A$1*

This solved the black screen hanging on logoff for me.

I'm not quite sure what to change if you're using Gnome, but I suspect it's this line:
GDM_AUTH_FILE=/var/lib/gdm/$1.Xauth

按照这个方法问题应可解决(我就是这样解决的)。另外该页有人做个patch,但没试验过。


没有这个文件啊?
/etc/ati/authatieventsd.sh


页首
 用户资料  
 
11 楼 
 文章标题 :
帖子发表于 : 2008-05-24 23:25 
头像

注册: 2005-08-14 21:55
帖子: 58428
地址: 长沙
送出感谢: 4
接收感谢: 272
如果是关于Xauth的话,是可能。比如不是启动的gdm,导致.Xauth没找到。造成假死。


_________________
● 鸣学


页首
 用户资料  
 
12 楼 
 文章标题 :
帖子发表于 : 2008-07-06 12:47 

注册: 2008-07-06 12:45
帖子: 2
送出感谢: 0 次
接收感谢: 0 次
nvidia的也有问题


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 12 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 4 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译