7.10升级到8.04 编译时出现的问题。libglib2.0-dev libxft-dev

为当前最终发行版之前的所有版本提供支持
回复
头像
Hakkinen98
帖子: 165
注册时间: 2006-09-02 1:26
来自: Team McLaren
送出感谢: 0
接收感谢: 0
联系:

7.10升级到8.04 编译时出现的问题。libglib2.0-dev libxft-dev

#1

帖子 Hakkinen98 » 2008-04-11 18:07

安装7.10后什么都没装,除了ATI驱动
用CN99的源升级完成后
编译SCIM-PYTHON的时候提示安装GTK+-2.0,搞了半天依赖问题,最后到这里过不去了。

这样的问题,茫然:

代码: 全选

 sudo apt-get install libglib2.0-dev libxft-dev

Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
libglib2.0-dev: Depends: libglib2.0-0 (= 2.16.2-1ubuntu1) but 2.16.3-1 is to be installed
libxft-dev: Depends: libxft2 (= 2.1.12-2ubuntu4) but 2.1.12-2ubuntu5 is to be installed

E: Broken packages
头像
princelai
帖子: 920
注册时间: 2007-01-06 21:00
送出感谢: 2 次
接收感谢: 0
联系:

#2

帖子 princelai » 2008-04-11 18:15

你先打开新利得,有一个custom filters,里面有broken,看看有没有坏的包,不行自己下载上面的包,然后sudo dpkg -i
头像
Hakkinen98
帖子: 165
注册时间: 2006-09-02 1:26
来自: Team McLaren
送出感谢: 0
接收感谢: 0
联系:

#3

帖子 Hakkinen98 » 2008-04-11 19:04

似乎行不通哦……
不过还是谢谢你
头像
Hakkinen98
帖子: 165
注册时间: 2006-09-02 1:26
来自: Team McLaren
送出感谢: 0
接收感谢: 0
联系:

#4

帖子 Hakkinen98 » 2008-04-12 10:06

apt-get install python-wxgtk2.6 后解决了……
:lol:
回复

回到 “老旧版本支持”