当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 4 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : The CC version check
帖子发表于 : 2008-04-12 19:35 

注册: 2006-10-23 16:58
帖子: 10
送出感谢: 0 次
接收感谢: 0 次
安装Nvidia官方下载的驱动:NVIDIA-Linux-x86-169.07-pkg1.run时出现下面的错误:
The CC version check failed
The compiler used to compile the kernel (gcc 4.1) does not exactly match
> the
> current compiler (gcc 4.2). The Linux 2.6 kernel module loader rejects
> kern
> el modules built with a version of gcc that does not exactly match that of
> t
> he compiler used to build the running kernel.
>
> If you know what you are doing and want to ignore the gcc version check,
> sel
> ect "No" to continue installation. Otherwise, select "Yes" to abort
> install
> ation, set the CC environment variable to the name of the compiler used to
> c
> ompile your kernel, and restart installation.

本系统有2个内核版本:
2.6.22-14-generic、2.6.24-15-generic
gcc版本也有2个:
gcc-4.1 、gcc-4.2
google了半天都没有找到解决办法,怎么解决?


页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2008-04-12 19:39 
头像

注册: 2006-07-02 11:16
帖子: 12522
地址: 廣州
送出感谢: 0 次
接收感谢: 8
CC=gcc-4.1 ./NVIDIA-Linux-x86-169.07-pkg1.run


_________________
^_^ ~~~
要理解递归,首先要理解递归。

地球人都知道,理论上,理论跟实际是没有差别的,但实际上,理论跟实际的差别是相当大滴。


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2008-04-12 19:59 
头像

注册: 2007-08-11 20:54
帖子: 777
地址: 广州
送出感谢: 0 次
接收感谢: 0 次
我自己编译2.6.24.4内核也能够装装啊,找个对应版本的GCC啊


_________________
人的生命是有限的,但是享受Linux的乐趣是无限的!
http://www.liangsuilong.info


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2008-04-12 20:27 

注册: 2006-10-23 16:58
帖子: 10
送出感谢: 0 次
接收感谢: 0 次
谢谢BigSnake.NET,不知道加上这个参数还真的不知道怎么办,难怪网上查都查不到,原来太简单了,哈哈


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 4 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 4 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译