[问题] 求解:dpkg问题。

为当前最终发行版之前的所有版本提供支持
回复
sslfox
帖子: 6
注册时间: 2008-03-15 16:04
送出感谢: 0
接收感谢: 0

[问题] 求解:dpkg问题。

#1

帖子 sslfox » 2008-04-13 10:49

昨天装了ubuntu8.04,是用wubi在xp下装的。
装好了换源更新时出现99%等待,然后就不动了。
另外用APT install的时候会提示 *****intepreted ,要手工 dpkg --configure -a ?
然后敲了上面的dpkg后又会连接服务器等待,不动。

问下是怎么回事?
谢谢了。。。
bian222
帖子: 78
注册时间: 2006-05-18 21:13
送出感谢: 0
接收感谢: 0

#2

帖子 bian222 » 2008-04-13 10:57

我昨天更新完也出现apt install的错误,不过我按照提示打了 sudo dpkg --configure -a 后就恢复正常了,比较幸运,呵呵。
sslfox
帖子: 6
注册时间: 2008-03-15 16:04
送出感谢: 0
接收感谢: 0

#3

帖子 sslfox » 2008-04-13 11:06

运行sudo dpkg --configure -a 就一直卡住了,等待连接服务器。
真不知道啥原因。
dbzhang800
帖子: 3182
注册时间: 2006-03-10 15:10
来自: xi'an China
送出感谢: 0
接收感谢: 2 次
联系:

#4

帖子 dbzhang800 » 2008-04-13 11:35

sslfox 写了:运行sudo dpkg --configure -a 就一直卡住了,等待连接服务器。
真不知道啥原因。
检查你的源设置的有没有问题。

另:直接贴出错信息比直接说卡住什么的要有效的多。
twg1023
帖子: 33
注册时间: 2008-03-27 22:54
送出感谢: 0
接收感谢: 0
联系:

#5

帖子 twg1023 » 2008-04-13 14:12

我执行sudo dpkg --configure -a 后的情况是
bruce@Bruce:~$ sudo dpkg --configure -a
[sudo] password for bruce:
正在设置 initramfs-tools (0.85eubuntu35) ...
update-initramfs: deferring update (trigger activated)

Processing triggers for initramfs-tools ...
update-initramfs: Generating /boot/initrd.img-2.6.24-15-generic

gzip: stdout: No space left on device
update-initramfs: failed for /boot/initrd.img-2.6.24-15-generic
dpkg: 子进程 post-installation script 返回了错误号 1

不知道怎么解决 我的软件源是 主服务器 我试了一下 中国的服务器源 结果还是一个样子。 郁闷中。。。。。。
sslfox
帖子: 6
注册时间: 2008-03-15 16:04
送出感谢: 0
接收感谢: 0

#6

帖子 sslfox » 2008-04-13 14:36

执行sudo dpkg --configure -a 后:

root@sslfox-laptop:~# sudo dpkg --configure -a
正在设置 flashplugin-nonfree (9.0.124.0ubuntu1) ...
Downloading...
--14:34:48-- http://fpdownload.macromedia.com/get/fl ... nux.tar.gz
=> `./install_flash_player_9_linux.tar.gz'
Resolving jproxy.nju.edu.cn... 202.119.32.27
Connecting to jproxy.nju.edu.cn|202.119.32.27|:8080... connected.
Proxy request sent, awaiting response...
twg1023
帖子: 33
注册时间: 2008-03-27 22:54
送出感谢: 0
接收感谢: 0
联系:

#7

帖子 twg1023 » 2008-04-13 14:42

老兄 我这个怎么弄呀 可以手动下载 current/install_flash_player_9_linux.tar.gz 这个包 然后安装吗?
回复

回到 “老旧版本支持”