当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 10 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : [讨论]8.04的复制慢问题怎么解决??
帖子发表于 : 2008-04-18 23:58 
头像

注册: 2007-01-06 21:00
帖子: 920
送出感谢: 2
接收感谢: 0 次
我觉得升级到8.04后复制速度明显慢了很多,虽然以前我不知道在7.10上速度是多少,
但是在XP下复制的速度大约是24MB/s,现在只有13MB/s,大家是不是这样?

图片


附件:
Screenshot-File operations.png
Screenshot-File operations.png [ 7 KiB | 被浏览 1739 次 ]
页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2008-04-19 0:00 

注册: 2006-11-08 6:16
帖子: 417
地址: Beijing
送出感谢: 0 次
接收感谢: 0 次
比原来好像是有慢的感觉。不过总的感觉还是比Windows XP要快不少。


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2008-04-19 23:30 
头像

注册: 2005-11-10 21:20
帖子: 167
地址: 广西南宁
送出感谢: 0 次
接收感谢: 0 次
hdparm结果 IO_support = 0 (default)
16-bit)
加-c1也打不开32位,该hdparm.conf解开32位的配置也不行,不知道为什么,难道不支持sda??ubuntu把hda都认成sda的。


_________________
其实一直在用gentoo…………


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2008-04-20 10:40 
头像

注册: 2007-10-06 18:40
帖子: 4313
送出感谢: 0 次
接收感谢: 5
flies 写道:
hdparm结果 IO_support = 0 (default)
16-bit)
加-c1也打不开32位,该hdparm.conf解开32位的配置也不行,不知道为什么,难道不支持sda??ubuntu把hda都认成sda的。

同问。


页首
 用户资料  
 
5 楼 
 文章标题 :
帖子发表于 : 2008-04-20 23:29 

注册: 2006-07-28 8:51
帖子: 407
送出感谢: 0 次
接收感谢: 0 次
请教个问题,我的笔记本硬盘SATA在Linux下,速度传输缓慢只有2M/S的速度,不知道应该怎么弄。
我用hdparm 的结果.
代码:
hooxin@arch-firefoxmmx:~$ sudo hdparm  -d  1  -A  1  -m  16  -c  3  -a  1024  /dev/sda

/dev/sda:
 setting fs readahead to 1024
 setting 32-bit IO_support flag to 3
 HDIO_SET_32BIT failed: Invalid argument
 setting multcount to 16
 HDIO_SET_MULTCOUNT failed: Inappropriate ioctl for device
 setting using_dma to 1 (on)
 HDIO_SET_DMA failed: Inappropriate ioctl for device
 setting drive read-lookahead to 1 (on)
 HDIO_GET_MULTCOUNT failed: Inappropriate ioctl for device
 IO_support    =  0 (default)
16-bit)
 HDIO_GET_DMA failed: Inappropriate ioctl for device
 readahead     = 1024 (on)
 look-ahead    =  1 (on)


DMA和32都打不开,不知道是怎么回事?简直慢得不行了,还请大侠帮帮忙


页首
 用户资料  
 
6 楼 
 文章标题 :
帖子发表于 : 2008-04-21 9:21 
头像

注册: 2008-04-11 15:11
帖子: 163
送出感谢: 0 次
接收感谢: 0 次
firefoxmmx 写道:
请教个问题,我的笔记本硬盘SATA在Linux下,速度传输缓慢只有2M/S的速度,不知道应该怎么弄。
我用hdparm 的结果.
代码:
hooxin@arch-firefoxmmx:~$ sudo hdparm  -d  1  -A  1  -m  16  -c  3  -a  1024  /dev/sda

/dev/sda:
 setting fs readahead to 1024
 setting 32-bit IO_support flag to 3
 HDIO_SET_32BIT failed: Invalid argument
 setting multcount to 16
 HDIO_SET_MULTCOUNT failed: Inappropriate ioctl for device
 setting using_dma to 1 (on)
 HDIO_SET_DMA failed: Inappropriate ioctl for device
 setting drive read-lookahead to 1 (on)
 HDIO_GET_MULTCOUNT failed: Inappropriate ioctl for device
 IO_support    =  0 (default)
16-bit)
 HDIO_GET_DMA failed: Inappropriate ioctl for device
 readahead     = 1024 (on)
 look-ahead    =  1 (on)


DMA和32都打不开,不知道是怎么回事?简直慢得不行了,还请大侠帮帮忙



楼上这位。。。你肯定是在bios里面把ide mode 设置成了兼容模式~把它改成ahci的!! sata的dma默认是打开的,32位的那个设置不设置无所谓的~~
参考: http://linux-ata.org/faq.html , 大概就是为了支持新出现的sata,搞出个libata主要去支持sata,为了向后兼容性,也就带了pata的驱动,但到了后面,pata的驱动和libata又不合在一起了,如果都编译到内核里面,会有冲突,造成硬盘性能低下了。里面提供有几个解决的方案:
1.Recommended (where BIOS permits): Change BIOS IDE mode from "legacy" or "combined" mode to "AHCI" (recommended), "RAID" or "native". ---这里说的就是如果你是sata的硬盘的话就要这样~~

2. Boot with the kernel commandline parameter "combined_mode=libata" or "combined_mode=ide" to allow the specified driver to claim all IDE ports. ---这里意思就是如果你是sata的你就libata 如果是pata的就是设置成ide,具体什么命令来设置。。。不清楚~~

下面两行应该都是在内核里面配置,要重新编译内核
3.Disable libata (CONFIG_ATA) entirely, and enable CONFIG_BLK_DEV_IDE_SATA. -
4. (newer choice, with less field testing) Disable CONFIG_IDE, and permit libata to run all your IDE and SATA ports.
可以配置内核里面:ATA/ATAPI/MFM/RLL support (IDE) 和 Serial ATA (prod) and Parallel ATA (experimental) drivers (ATA)这两项
另外我还看到有一种解决方案是说: 通过grub列表添加启动参数,在 boot (hdx,x)那一行之后加上 ide0=noprobe ide1=noprobe根据你硬盘个数来定~~
还有文章里面也提到了怎么设置sata的NCQ,不过按它的方法没搞成功,老说参数非法。。。被搞怒了~~
我的本本是sata的硬盘。。。采用的是第一种方式,速度看图。。。好像似乎比windows下的慢,2003下我考东西用total command速度快啊~


附件:
screenshot2.png
screenshot2.png [ 13.26 KiB | 被浏览 1056 次 ]

页首
 用户资料  
 
7 楼 
 文章标题 :
帖子发表于 : 2008-04-21 11:08 

注册: 2006-07-28 8:51
帖子: 407
送出感谢: 0 次
接收感谢: 0 次
回楼上,我打开ahci就不能进入系统了,他报找不到硬盘


页首
 用户资料  
 
8 楼 
 文章标题 :
帖子发表于 : 2008-04-21 11:45 
头像

注册: 2006-07-13 11:43
帖子: 41
地址: 深圳
送出感谢: 0 次
接收感谢: 0 次
我整个都慢,内存512, 只开终端,top一下,xorg-session占最大,执行 bug report时,竟然提示说内存不够,汗...


页首
 用户资料  
 
9 楼 
 文章标题 :
帖子发表于 : 2008-04-21 19:26 

注册: 2006-07-28 8:51
帖子: 407
送出感谢: 0 次
接收感谢: 0 次
楼主,楼主,我刚刚才发现,我就只有ext3分区慢。我的ntfs to ntfs 速度就是10M/S,ext3 to ext3 就是2m/s。。
应该怎么办呀。排除了内核和驱动的问题了


页首
 用户资料  
 
10 楼 
 文章标题 : Re: [讨论]8.04的复制慢问题怎么解决??
帖子发表于 : 2008-12-21 3:38 
头像

注册: 2008-05-03 23:05
帖子: 383
送出感谢: 0 次
接收感谢: 0 次
楼上的,可以试试xfs~
xfs的大文件速度比较快


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 10 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 4 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译