.run文件是用什么wrap的?

为当前最终发行版之前的所有版本提供支持
回复
头像
spider5
帖子: 351
注册时间: 2005-12-15 21:52
送出感谢: 0
接收感谢: 0

.run文件是用什么wrap的?

#1

帖子 spider5 » 2008-04-26 21:22

原来在7.04下能执行的.run后缀的文件,到8.04下居然不能用了,
一执行就提示No such file or directory,目前正在郁闷中。

可执行权限已经加了。猜测是引用了旧版本的库,现在就想把它解压开了,自己鼓捣。求其wrap工具名称。
头像
BigSnake.NET
帖子: 12522
注册时间: 2006-07-02 11:16
来自: 廣州
送出感谢: 0
接收感谢: 7 次
联系:

#2

帖子 BigSnake.NET » 2008-04-26 21:23

^_^ ~~~
要理解递归,首先要理解递归。

地球人都知道,理论上,理论跟实际是没有差别的,但实际上,理论跟实际的差别是相当大滴。
头像
spider5
帖子: 351
注册时间: 2005-12-15 21:52
送出感谢: 0
接收感谢: 0

#3

帖子 spider5 » 2008-04-27 16:12

嗨,大蛇,问题已经搞定了。
我用的8.04amd64,升级后有4个程序出现问题,都是同时支持x86和amd64两种架构的。
其中一个文件用ldd看同时引用有ia64和ia32的库,我放到另外一台电脑解压出文件后,复制回本机可以使用,仍然用的64位的so。
还有一个是eclipse的workbench,禁用了一些特性后勉强能用,依赖关系懒得去研究,等新版本出了升级估计就好了。
最后两个是关联的,但其执行文件都是脚本,里面用到的库就多了,没法一个个查依赖关系,我先安装了ubuntu的32位支持包,然后从安装包把原来没装的32位运行库复制过来就可以用了,程序提示符也从原来的x86_64变成了m32,真是有够郁闷的。

个人感觉是一些64位库的依赖关系失效了。
头像
spider5
帖子: 351
注册时间: 2005-12-15 21:52
送出感谢: 0
接收感谢: 0

#4

帖子 spider5 » 2008-04-28 10:41

找到依赖什么库了,8.04默认不安装libstdc5
头像
spider5
帖子: 351
注册时间: 2005-12-15 21:52
送出感谢: 0
接收感谢: 0

#5

帖子 spider5 » 2008-04-30 14:31

又发现了一个问题,某程序在选择使用x86还是amd64时使用了/bin/arch命令,但是8.04下没有arch命令,只好修改启动脚本用uname -m代替。
回复

回到 “老旧版本支持”