apt更新出错,求高手指点下

为当前最终发行版之前的所有版本提供支持
回复
littleqiang
帖子: 8
注册时间: 2005-08-03 13:53
送出感谢: 0
接收感谢: 0

apt更新出错,求高手指点下

#1

帖子 littleqiang » 2008-04-27 12:21

ubuntu 7.04 使用的cn99的源,
sudo apt-get update
………………
下载 5B,耗时 1s (3B/s)
正在读取软件包列表... 完成
sudo apt-get dist-upgrade
正在读取软件包列表... 完成
正在分析软件包的依赖关系树
读取状态信息... 完成
正在筹划升级... 完成
下列的软件包将被升级:
firefox firefox-gnome-support gs-esp gs-esp-x libgs-esp8 libnspr4 libnss3 libpoppler1 libpoppler1-glib
poppler-utils rsync
共升级了 11 个软件包,新安装了 0 个软件包,要卸载 0 个软件包,有 0 个软件未被升级。
需要下载 14.6MB 的软件包。
解压缩后会消耗掉 36.9kB 的额外空间。
您希望继续执行吗?[Y/n]y
错误 http://ubuntu.cn99.com feisty-updates/main rsync 2.6.9-3ubuntu1.2
404 Not Found
错误 http://ubuntu.cn99.com feisty-updates/main firefox-gnome-support 2.0.0.14+1nobinonly-0ubuntu0.7.4
404 Not Found
错误 http://ubuntu.cn99.com feisty-updates/main libnspr4 2:1.firefox2.0.0.14+1nobinonly-0ubuntu0.7.4
404 Not Found
错误 http://ubuntu.cn99.com feisty-updates/main libnss3 2:1.firefox2.0.0.14+1nobinonly-0ubuntu0.7.4
404 Not Found
错误 http://ubuntu.cn99.com feisty-updates/main firefox 2.0.0.14+1nobinonly-0ubuntu0.7.4
404 Not Found
错误 http://ubuntu.cn99.com feisty-updates/main libgs-esp8 8.15.4.dfsg.1-0ubuntu1.1
404 Not Found
错误 http://ubuntu.cn99.com feisty-updates/main gs-esp 8.15.4.dfsg.1-0ubuntu1.1
404 Not Found
错误 http://ubuntu.cn99.com feisty-updates/main gs-esp-x 8.15.4.dfsg.1-0ubuntu1.1
404 Not Found
错误 http://ubuntu.cn99.com feisty-updates/main libpoppler1-glib 0.5.4-0ubuntu8.3
404 Not Found
错误 http://ubuntu.cn99.com feisty-updates/main libpoppler1 0.5.4-0ubuntu8.3
404 Not Found
错误 http://ubuntu.cn99.com feisty-updates/main poppler-utils 0.5.4-0ubuntu8.3
404 Not Found
无法下载 http://ubuntu.cn99.com/ubuntu/pool/main ... 2_i386.deb 404 Not Found
无法下载 http://ubuntu.cn99.com/ubuntu/pool/main ... 4_i386.deb 404 Not Found
无法下载 http://ubuntu.cn99.com/ubuntu/pool/main ... 4_i386.deb 404 Not Found
无法下载 http://ubuntu.cn99.com/ubuntu/pool/main ... 4_i386.deb 404 Not Found
无法下载 http://ubuntu.cn99.com/ubuntu/pool/main ... 4_i386.deb 404 Not Found
无法下载 http://ubuntu.cn99.com/ubuntu/pool/main ... 1_i386.deb 404 Not Found
无法下载 http://ubuntu.cn99.com/ubuntu/pool/main ... 1_i386.deb 404 Not Found
无法下载 http://ubuntu.cn99.com/ubuntu/pool/main ... 1_i386.deb 404 Not Found
无法下载 http://ubuntu.cn99.com/ubuntu/pool/main ... 3_i386.deb 404 Not Found
无法下载 http://ubuntu.cn99.com/ubuntu/pool/main ... 3_i386.deb 404 Not Found
无法下载 http://ubuntu.cn99.com/ubuntu/pool/main ... 3_i386.deb 404 Not Found
E: 有几个软件包无法下载,您可以运行 apt-get update 或者加上 --fix-missing 的选项再试试?
dbzhang800
帖子: 3182
注册时间: 2006-03-10 15:10
来自: xi'an China
送出感谢: 0
接收感谢: 2 次
联系:

#2

帖子 dbzhang800 » 2008-04-27 12:39

发帖前能不能看看置顶啊!
头像
xiooli
帖子: 6956
注册时间: 2007-11-19 21:51
来自: 成都
送出感谢: 0
接收感谢: 3 次
联系:

#3

帖子 xiooli » 2008-04-27 12:46

你要升级到7.10当然要用gutsy的源啦,还用7.04的源怎么行?
头像
芬言芬语
帖子: 409
注册时间: 2008-02-27 14:14
来自: Hangzhou
送出感谢: 0
接收感谢: 0

#4

帖子 芬言芬语 » 2008-04-27 13:46

这个是常识额
要好好充电了
http://wiki.ubuntu.org.cn/Navigation
还有太多要学习了!
Linux的世界,我永远是只菜鸟!
littleqiang
帖子: 8
注册时间: 2005-08-03 13:53
送出感谢: 0
接收感谢: 0

#5

帖子 littleqiang » 2008-04-27 17:05

我的系统是7。04的,我没有升级到7.10,也没打算升级系统版本,就是现在用apt一更新软件就出错,上周还好好的
回复

回到 “老旧版本支持”