升级了8.04出现两个开机错误 “Setting kernel variables"和"Mounting loca...

为当前最终发行版之前的所有版本提供支持
回复
头像
biogerm
帖子: 104
注册时间: 2007-10-22 4:40
送出感谢: 0
接收感谢: 0
联系:

升级了8.04出现两个开机错误 “Setting kernel variables"和"Mounting loca...

#1

帖子 biogerm » 2008-04-28 11:59

升级了8.04出现两个开机错误 “Setting kernel variables"和"Mounting local filesystems"都报错。

第一个感觉应该跟升级了8.04有关

第二个感觉可能跟新加了一块硬盘有关?不过我看了etc/fstab文件里面没有在开机的时候mount hda1只mount了sda1。。。hda1是新加的,sda1是原来就有的ubuntu在的地方。


如何把hda1 mount进去?现在有的时候从“计算机”打开hda1的分区的时候会要求输入密码。。而且开机必须一个一个把hda1的分区打开否则/media里面没有显示。。
ubuntu taster =D
头像
biogerm
帖子: 104
注册时间: 2007-10-22 4:40
送出感谢: 0
接收感谢: 0
联系:

#2

帖子 biogerm » 2008-04-28 12:24

顶一下 先去睡觉 睡醒继续关注
ubuntu taster =D
头像
biogerm
帖子: 104
注册时间: 2007-10-22 4:40
送出感谢: 0
接收感谢: 0
联系:

#3

帖子 biogerm » 2008-04-29 0:13

大家有遇到同样问题的吗?
ubuntu taster =D
sxs
帖子: 25
注册时间: 2007-10-09 20:42
送出感谢: 0
接收感谢: 0
联系:

#4

帖子 sxs » 2008-06-09 17:52

我也出现了类似的问题:

从昨天晚上按照一下设置开始升级:
ubuntu如何从旧系统升级到新的系统:例如从ubuntu 7.10升级到ubuntu 8.04
1). 更新现有系统(必须先更新现有系统!否则容易出现依赖关系的问题)
$ sudo apt-get update
$ sudo apt-get upgrade
2). 修改源
$ sudo cp /etc/apt/sources.list /etc/apt/sources.list_gutsy
$ sudo gedit /etc/apt/sources.list
把所有的"gutsy"替换成“hardy”
3). 进行系统升级
$ sudo apt-get dist-upgrade
$ sudo apt-get upgrade

升级完成后,重启电脑,grub显示仍然是7.10版本,等启动进度条过后,就出现一个光标一直闪,进不了系统。
再次重启,进入recovery模式,检测其他项均为OK,只有一项例外:
setting kernel variables [failing]
error: "vm.mmap_min_addr" is an unknown key
soofo
帖子: 7
注册时间: 2008-06-13 17:11
送出感谢: 0
接收感谢: 0

#5

帖子 soofo » 2008-06-27 23:31

sxs 写了:我也出现了类似的问题:

从昨天晚上按照一下设置开始升级:
ubuntu如何从旧系统升级到新的系统:例如从ubuntu 7.10升级到ubuntu 8.04
1). 更新现有系统(必须先更新现有系统!否则容易出现依赖关系的问题)
$ sudo apt-get update
$ sudo apt-get upgrade
2). 修改源
$ sudo cp /etc/apt/sources.list /etc/apt/sources.list_gutsy
$ sudo gedit /etc/apt/sources.list
把所有的"gutsy"替换成“hardy”
3). 进行系统升级
$ sudo apt-get dist-upgrade
$ sudo apt-get upgrade

升级完成后,重启电脑,grub显示仍然是7.10版本,等启动进度条过后,就出现一个光标一直闪,进不了系统。
再次重启,进入recovery模式,检测其他项均为OK,只有一项例外:
setting kernel variables [failing]
error: "vm.mmap_min_addr" is an unknown key
我也是这样的问题
头像
lhw828
帖子: 2798
注册时间: 2007-03-15 16:58
来自: 湖北武汉
送出感谢: 2 次
接收感谢: 3 次
联系:

#6

帖子 lhw828 » 2008-06-28 2:21

继续升级
soofo
帖子: 7
注册时间: 2008-06-13 17:11
送出感谢: 0
接收感谢: 0

#7

帖子 soofo » 2008-06-28 9:54

error: "vm.mmap_min_addr" is an unknown key是内核2.6.23的安全补丁,我的机子从7。10升级到8。04后,用系统监视器查看,内核还是2.6.22-14,故不能执行这条指令,我暂时的先将vm.mmap_min_addr给封了,待以后有升级内核时再打开.
~$ sudo gedit /etc/sysctl.conf
将vm.mmap_min_addr = 65535前加#
即# vm.mmap_min_addr = 65535
把它改为注改文字,若以后有升级到2.623以上内核时再把前面的#号去掉就可以了.
头像
xcxt
帖子: 6
注册时间: 2008-08-15 13:03
来自: china
送出感谢: 0
接收感谢: 0

[建议]投靠

#8

帖子 xcxt » 2008-08-16 9:38

这种问题我也见过,这很有可能是因为源的错误,不是你设置源错误就是他更改了源但是没通知,所以你的源就自动换了版本,更自然的ubuntu就会把其他版本下载到你的电脑上,而因为老版本和新版本并不太兼容,所以就自动造成了这种情况,建议修改源。
当世界陷入到windows的黑暗之中时,上帝说:让Ubunut出来吧,于是世界出现了光明。
回复

回到 “老旧版本支持”