[讨论]移植flash程序到Xubuntu下,失败!

为当前最终发行版之前的所有版本提供支持
回复
qiubite
帖子: 3
注册时间: 2008-04-28 17:14
送出感谢: 0
接收感谢: 0

[讨论]移植flash程序到Xubuntu下,失败!

#1

帖子 qiubite » 2008-04-28 17:30

用flex2编了一个客户端程序,通过webservices与局域网内的主机连接,编译为swf后用flashplayer封装为projector(独立运行的exe文件),运行一切正常。
现在准备把这个程序移植到linux(Xubuntu 8.04)下,下载了最新的flashplayer linux版(9.0.124),swf文件可以正常显示,但将其封装为projector后无法运行,只能显示背景色!
后来用wine运行在Windows下生成的projector,可以正常显示,但无法连接网络!
请问各位有没有遇到这样的问题,应该怎么解决?
dbzhang800
帖子: 3182
注册时间: 2006-03-10 15:10
来自: xi'an China
送出感谢: 0
接收感谢: 2 次
联系:

#2

帖子 dbzhang800 » 2008-04-28 17:49

把swf封装成exe,再用wine来运行?

不封装不行吗?
qiubite
帖子: 3
注册时间: 2008-04-28 17:14
送出感谢: 0
接收感谢: 0

#3

帖子 qiubite » 2008-04-28 18:06

不封装不行。
因为flash的安全机制,不能跨域访问网络。
qiubite
帖子: 3
注册时间: 2008-04-28 17:14
送出感谢: 0
接收感谢: 0

#4

帖子 qiubite » 2008-04-28 23:54

不知是Xubuntu的问题还是flashplayer的问题?
回复

回到 “老旧版本支持”