当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 8 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : [问题]新手求Ubuntu8.04安装jdk1.6 tomcat6,myeclipse6的详细方法
帖子发表于 : 2008-04-28 23:16 

注册: 2008-04-26 21:11
帖子: 23
送出感谢: 0 次
接收感谢: 0 次
前几天下了个ubuntu8.04桌面系统,装好了,感觉不错,现在求教jdk6 tomcat6和myeclipse6的详细安装步骤,希望越详细越好,超级菜鸟在这里先谢谢各位大虾了 :D


页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2008-04-28 23:23 

注册: 2007-11-20 12:45
帖子: 231
地址: Hefei
送出感谢: 0 次
接收感谢: 0 次
jdk6 好装,wiki快速指南有。
eclipse也好装,源里面有。myeclipse和其他不知。


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2008-04-30 1:28 

注册: 2008-04-29 10:47
帖子: 9
送出感谢: 0 次
接收感谢: 0 次
貌似跟其他的linux一样!楼主在搭建J2EE平台?


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2008-04-30 11:51 

注册: 2008-04-30 11:26
帖子: 1
送出感谢: 0 次
接收感谢: 0 次
我也想知道怎么样搭建J2EE的开发平台. 我也是TOMCAT JDK MYECLIPSE


页首
 用户资料  
 
5 楼 
 文章标题 :
帖子发表于 : 2008-04-30 13:11 

注册: 2006-08-29 0:24
帖子: 197
送出感谢: 0 次
接收感谢: 0 次
跟安装普通程序没有什么区别!
晚上踢完球的回去写一篇贴在本论坛的BLOG :D


页首
 用户资料  
 
6 楼 
 文章标题 :
帖子发表于 : 2008-04-30 14:17 
头像

注册: 2007-04-05 17:57
帖子: 869
地址: 吉林──>海南──>大连──>延边──>北京──>德黑兰──>(x,y)
送出感谢: 0 次
接收感谢: 0 次
安装JAVA环境支持

打开终端,执行以下命令,或使用Adept/新立得软件管理器,在其中分别搜索"sun-java6-jre"和"sun-java6-jdk"并标记安装。
代码:
sudo apt-get install sun-java6-jre

如果空间富裕,建议安装一个JDK。
代码:
sudo apt-get install sun-java6-jdk

提示:安装过程中需要你回答是否同意使用协议(终端中红蓝色的提示界面),此时按tab键至OK,再按回车即可正常安装。

设置当前默认的java解释器:
代码:
sudo update-alternatives --config java

执行后会出现类似如下的画面:

代码:
There are 2 alternatives which provide `java'.

Selection Alternative
-----------------------------------------------
1 /usr/bin/gij-wrapper-4.1
*+ 2 /usr/lib/jvm/java-6-sun/jre/bin/java

Press enter to keep the default[*], or type selection number:


输入 有包含 "sun" 的行的前面的数字。如上面显示,则输入2,然后回车确定。
注:如果你是新安装的8.04版本的ubuntu,那么会出现类似"系统只有一个java,不需要设置"的英文提示消息。

配置JAVA环境变量:
代码:
sudo gedit /etc/environment

在其中添加如下两行:
代码:
CLASSPATH=.:/usr/lib/jvm/java-6-sun/lib#中间是以英文的冒号隔开,记得windows中是以英文的分号做为分隔的
JAVA_HOME=/usr/lib/jvm/java-6-sun


然后:
代码:
sudo gedit /etc/jvm

将文件中的
代码:
/usr/lib/jvm/java-6-sun

这一行填入到配置块的顶部

安装浏览器的JAVA Plugin(可选):
代码:
sudo apt-get install sun-java6-plugin


安装tmocat6.X
其实你想用哪个版本都可以,到Tomcat主页http://tomcat.apache.org/选择你要使用的版本,然后再下载以.tar.gz结尾的文件就可以了,解压后就可以直接使用了。
现在最新版本为tomcat6.0.16,地址为:http://apache.mirror.phpchina.com/tomcat/tomcat-6/v6.0.16/bin/apache-tomcat-6.0.16.tar.gz
在终端中进入解压后的bin目录下,./startup.sh启动tomcat,./shutdown.sh关闭tomcat。
当看到类似以下输出时,你已经成功启动tomcat了:
代码:
lym@lym-laptop:~/System/ubuntu/software/apache-tomcat-6.0.14/bin$ ./startup.sh
Using CATALINA_BASE:   /home/lym/System/ubuntu/software/apache-tomcat-6.0.14
Using CATALINA_HOME:   /home/lym/System/ubuntu/software/apache-tomcat-6.0.14
Using CATALINA_TMPDIR: /home/lym/System/ubuntu/software/apache-tomcat-6.0.14/temp
Using JRE_HOME:       /usr/lib/jvm/java-6-sun

前提是你已经按照前面安装JAVA环境的步骤配置了环境变量。
现在就可以访问http://localhost:8080来检测tomcat是否成功启动了。
注:tomcat默认端口是8080,端口号可以在config目录的server.xml中进行更改,但要注意,在Linux中1000以内的端口号必须需要root权限,使用时要加sudo命令,1000以外的OK,所以想要在类似eclipse的IDE中用tomcat的话还是设置在1000以外为宜。

安装eclipse
eclipse的主页:http://www.eclipse.org/
下载eclipse标准版,地址:http://www.eclipse.org/downloads/download.php?file=/eclipse/downloads/drops/R-3.3.2-200802211800/eclipse-SDK-3.3.2-linux-gtk.tar.gz
也是解压后直接运行。

安装MyEclipse插件
MyEclipse相对于eclipse来说,集成了很多进行javaee开发需要的功能,相对于eclipse来说,MyEclipse还是很方便的,现在企业用的也比较多,不过MyEclipse是一个商业软件,只能免费试用30天,30天之后必须提交订阅码才能继续使用。授权费用为标准版是 32美元,专业版是53美元。如果你有兴趣并且也愿意为此掏钱,那么请购买授权,否则想要继续使用,请自行处理,反正我是绝对不会干出告诉你说让你到Google上搜索序列号这种事的

首先下载MyEclipse:
官方网址:http://www.myeclipseide.com
下载地址:http://www.myeclipseide.com/module-htmlpages-display-pid-4.html
需要选择与Eclipse 3.3相匹配的MyEclipse 6.0 GA这个版本,点击后再选择下载Linux版的plug-in,当然,想下All in one也没有啊!

下载完MyEclipse之后,得到的是一个.bin的文件,打开终端,使用cd命令进入MyEclipse安装文件所在目录,输入命令:
$sudo sh MyEclipse_6_0_1GA_E3_3_1_Installer.bin
随后就会启动一个GUI的安装程序。
单击“Next“按钮继续,选择“I accept...“:
在这里选择Eclipse所在目录,单击“Choose“按钮来选择,接下来选择MyEclipse的安装位置,接下来选择Link Folder,可以保持默认选择继续,接下来就可以安装了,单击“Install“按钮,安装好后进入eclipse目录直接双击执行eclipse即可自动识别出MyEclipse,好了,现在你就可以在MyEclipse里面编写你的JavaEE程序了。


_________________
沒有人成全我的今天
亦没有人阻挡我的明天
输掉一个现在
我要赢得一个未来!

如果输了今生那么我也不要来世!

坐而論道,不如起而行動!

海至尽头天是岸 山到高处人为峰!


页首
 用户资料  
 
7 楼 
 文章标题 :
帖子发表于 : 2008-04-30 16:15 
头像

注册: 2006-09-04 10:45
帖子: 765
送出感谢: 0 次
接收感谢: 0 次
LZ的问题,论坛里面已经有好多帖子都写过了,很简单的,自己搜一下就OK了。

拜托,发帖前先搜索一下。


页首
 用户资料  
 
8 楼 
 文章标题 : Re:
帖子发表于 : 2009-02-07 17:13 

注册: 2009-01-22 3:30
帖子: 18
送出感谢: 0 次
接收感谢: 0 次
cocomama 写道:
安装JAVA环境支持

打开终端,执行以下命令,或使用Adept/新立得软件管理器,在其中分别搜索"sun-java6-jre"和"sun-java6-jdk"并标记安装。
代码:
sudo apt-get install sun-java6-jre

如果空间富裕,建议安装一个JDK。
代码:
sudo apt-get install sun-java6-jdk

提示:安装过程中需要你回答是否同意使用协议(终端中红蓝色的提示界面),此时按tab键至OK,再按回车即可正常安装。

设置当前默认的java解释器:
代码:
sudo update-alternatives --config java

执行后会出现类似如下的画面:

代码:
There are 2 alternatives which provide `java'.

Selection Alternative
-----------------------------------------------
1 /usr/bin/gij-wrapper-4.1
*+ 2 /usr/lib/jvm/java-6-sun/jre/bin/java

Press enter to keep the default[*], or type selection number:


输入 有包含 "sun" 的行的前面的数字。如上面显示,则输入2,然后回车确定。
注:如果你是新安装的8.04版本的ubuntu,那么会出现类似"系统只有一个java,不需要设置"的英文提示消息。

配置JAVA环境变量:
代码:
sudo gedit /etc/environment

在其中添加如下两行:
代码:
CLASSPATH=.:/usr/lib/jvm/java-6-sun/lib#中间是以英文的冒号隔开,记得windows中是以英文的分号做为分隔的
JAVA_HOME=/usr/lib/jvm/java-6-sun


然后:
代码:
sudo gedit /etc/jvm

将文件中的
代码:
/usr/lib/jvm/java-6-sun

这一行填入到配置块的顶部

安装浏览器的JAVA Plugin(可选):
代码:
sudo apt-get install sun-java6-plugin


安装tmocat6.X
其实你想用哪个版本都可以,到Tomcat主页http://tomcat.apache.org/选择你要使用的版本,然后再下载以.tar.gz结尾的文件就可以了,解压后就可以直接使用了。
现在最新版本为tomcat6.0.16,地址为:http://apache.mirror.phpchina.com/tomcat/tomcat-6/v6.0.16/bin/apache-tomcat-6.0.16.tar.gz
在终端中进入解压后的bin目录下,./startup.sh启动tomcat,./shutdown.sh关闭tomcat。
当看到类似以下输出时,你已经成功启动tomcat了:
代码:
lym@lym-laptop:~/System/ubuntu/software/apache-tomcat-6.0.14/bin$ ./startup.sh
Using CATALINA_BASE:   /home/lym/System/ubuntu/software/apache-tomcat-6.0.14
Using CATALINA_HOME:   /home/lym/System/ubuntu/software/apache-tomcat-6.0.14
Using CATALINA_TMPDIR: /home/lym/System/ubuntu/software/apache-tomcat-6.0.14/temp
Using JRE_HOME:       /usr/lib/jvm/java-6-sun

前提是你已经按照前面安装JAVA环境的步骤配置了环境变量。
现在就可以访问http://localhost:8080来检测tomcat是否成功启动了。
注:tomcat默认端口是8080,端口号可以在config目录的server.xml中进行更改,但要注意,在Linux中1000以内的端口号必须需要root权限,使用时要加sudo命令,1000以外的OK,所以想要在类似eclipse的IDE中用tomcat的话还是设置在1000以外为宜。

安装eclipse
eclipse的主页:http://www.eclipse.org/
下载eclipse标准版,地址:http://www.eclipse.org/downloads/download.php?file=/eclipse/downloads/drops/R-3.3.2-200802211800/eclipse-SDK-3.3.2-linux-gtk.tar.gz
也是解压后直接运行。

安装MyEclipse插件
MyEclipse相对于eclipse来说,集成了很多进行javaee开发需要的功能,相对于eclipse来说,MyEclipse还是很方便的,现在企业用的也比较多,不过MyEclipse是一个商业软件,只能免费试用30天,30天之后必须提交订阅码才能继续使用。授权费用为标准版是 32美元,专业版是53美元。如果你有兴趣并且也愿意为此掏钱,那么请购买授权,否则想要继续使用,请自行处理,反正我是绝对不会干出告诉你说让你到Google上搜索序列号这种事的

首先下载MyEclipse:
官方网址:http://www.myeclipseide.com
下载地址:http://www.myeclipseide.com/module-htmlpages-display-pid-4.html
需要选择与Eclipse 3.3相匹配的MyEclipse 6.0 GA这个版本,点击后再选择下载Linux版的plug-in,当然,想下All in one也没有啊!

下载完MyEclipse之后,得到的是一个.bin的文件,打开终端,使用cd命令进入MyEclipse安装文件所在目录,输入命令:
$sudo sh MyEclipse_6_0_1GA_E3_3_1_Installer.bin
随后就会启动一个GUI的安装程序。
单击“Next“按钮继续,选择“I accept...“:
在这里选择Eclipse所在目录,单击“Choose“按钮来选择,接下来选择MyEclipse的安装位置,接下来选择Link Folder,可以保持默认选择继续,接下来就可以安装了,单击“Install“按钮,安装好后进入eclipse目录直接双击执行eclipse即可自动识别出MyEclipse,好了,现在你就可以在MyEclipse里面编写你的JavaEE程序了。



字体怎么这么小阿。。。。。。。。。。。。吃力阿。。。。。。。。。。。。。。。。。。


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 8 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:Google [Bot] 和 4 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译