当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 13 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : [问题]播放音乐的时候,flash没声音
帖子发表于 : 2008-04-29 21:53 
头像

注册: 2008-02-15 0:09
帖子: 852
送出感谢: 0 次
接收感谢: 0 次
不知大家有没有这个问题,我用rhythbox或者amarok播放音乐的时候,同时上土豆或者优酷,播放的flash是没声音的,关了音乐播放器也不行,关了网页再开也不行,重启firerox 3b5 同时还要关闭播放器才可以。


_________________
Somebody think they are full of niubility, so they play a zhuangbility, but only reflect their shability.


页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2008-04-29 22:31 
头像

注册: 2008-03-22 12:05
帖子: 170
送出感谢: 0 次
接收感谢: 0 次
我的是怎么整都没声音。。。不是说系统没声音。。。是在线看flash没声音。。。本地看的话是有的。。。从7.10开始就会了。。
rp问题还是硬件问题现在还不确定。。。


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2008-04-29 22:35 
头像

注册: 2007-10-21 18:36
帖子: 3235
地址: 汕头/广东/中国
送出感谢: 2
接收感谢: 3
传说中的声卡独占?不知道是不是
你一边听音乐还一边看视频?……强。


_________________
老子的哲学是“”,庄子的哲学是“
人有一技在身,则逍遥游而无不为


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2008-04-29 22:45 

注册: 2007-04-25 11:49
帖子: 393
送出感谢: 0 次
接收感谢: 0 次
Linux在多媒体方面驱动开发不行,声卡只能独占模式运行


页首
 用户资料  
 
5 楼 
 文章标题 :
帖子发表于 : 2008-05-01 1:56 

注册: 2007-07-21 22:31
帖子: 48
送出感谢: 0 次
接收感谢: 0 次
wiki 上这篇文章对你们有用处 我也是刚把这个同时播放FLASH 和MP3调好
声音故障解决方案
http://wiki.ubuntu.org.cn/%E5%A3%B0%E9% ... 9%E6%A1%88

简单的说如果你们的声卡驱动能识别
aplay -l

就执行
$ sudo cp /var/lib/alsa/asound.state /var/lib/alsa/asound.state_bak
$ sudo /etc/init.d/alsa-utils stop
$ sudo gedit /var/lib/alsa/asound.state

修改文件如下
代码:
# This text should be added to the beginning of
# /var/lib/alsa/asound.state.  You only need to add
# it once -- it is saved across reboots.
pcm.asymed {
type asym
playback.pcm dmix
capture.pcm dsnoop
}
pcm.default {
type plug
slave.pcm asymed
}
pcm.dmix {
type dmix
ipc_key 5678293
ipc_key_add_uid yes
slave {
pcm 'hw:0,0'
period_time 0
period_size 128
buffer_size 2048
format S16_LE
rate 48000
}
}
pcm.dsnoop {
type dsnoop
ipc_key 5778293
ipc_key_add_uid yes
slave {
pcm 'hw:0,0'
period_time 0
period_size 128
buffer_size 2048
format S16_LE
rate 48000
}
}


最后再执行
$ sudo /etc/init.d/alsa-utils start

就 OK了 希望对你们能有帮助

注意:
这样改了以后主就不能使用主声道控制音量咯,需要控制音量请用PCM 。最好在修改以前把主声道的音量调到最大,PCM调小 然后再修改 不然修改后如果主声道默认你调的音量不大的话音量就很小咯 所以先把主声道调大 以后想控制音量用 PCM一样的


页首
 用户资料  
 
6 楼 
 文章标题 :
帖子发表于 : 2008-06-07 15:37 

注册: 2008-05-28 14:14
帖子: 102
送出感谢: 0 次
接收感谢: 0 次
>传说中的声卡独占?不知道是不是
>你一边听音乐还一边看视频?……强。

我觉得这的确是个问题,不是说非要一边听音乐一边看视频,
而你有可能你的flash视频没有关闭,这时你打开mp3是没有声音的,
一定要先把flash关闭才行,太麻烦了,在windows下就没有这个问题,
win下面都能实现,Linux应该要做得更好才行,ubuntu要加油啊!

这个问题不知道有没有简单的方法解决,现在网上的方法各不相同不知道怎么办才好


页首
 用户资料  
 
7 楼 
 文章标题 :
帖子发表于 : 2008-06-07 15:41 
头像

注册: 2007-08-20 8:13
帖子: 247
送出感谢: 0 次
接收感谢: 0 次
俺的可以边音乐边电影边flash :em42


_________________
每天都在起步。。。如同起床


页首
 用户资料  
 
8 楼 
 文章标题 :
帖子发表于 : 2008-06-09 9:04 

注册: 2008-05-28 14:14
帖子: 102
送出感谢: 0 次
接收感谢: 0 次
XEUY 写道:
俺的可以边音乐边电影边flash :em42

我的mp3和电影可以同时开,都有声音,便mp3和flash不能同时开会有一个没声音,
而且如果是电影和flash同时开的话,不但电影没声音而且会造成电影画面很卡


页首
 用户资料  
 
9 楼 
 文章标题 :
帖子发表于 : 2008-06-09 16:01 

注册: 2008-05-28 14:14
帖子: 102
送出感谢: 0 次
接收感谢: 0 次
liuke.forever 写道:
>传说中的声卡独占?不知道是不是
>你一边听音乐还一边看视频?……强。

我觉得这的确是个问题,不是说非要一边听音乐一边看视频,
而你有可能你的flash视频没有关闭,这时你打开mp3是没有声音的,
一定要先把flash关闭才行,太麻烦了,在windows下就没有这个问题,
win下面都能实现,Linux应该要做得更好才行,ubuntu要加油啊!

这个问题不知道有没有简单的方法解决,现在网上的方法各不相同不知道怎么办才好

我终于找到解决办法了,
1,在主音量控制里的设备要选为Alsa,应该8.04默认的就是Alsa
2,要把软件的声音输出设备改为Alsa,比如Mplayer,Amarok的声音输出设备改为Asla,因为这些软件的默认声音输出
设备不是Asla
所以此问题的关键还是Asla,因该采用Asla是可以解决声卡独占问题的。


页首
 用户资料  
 
10 楼 
 文章标题 : Re: [问题]播放音乐的时候,flash没声音
帖子发表于 : 2008-06-09 18:38 
头像

注册: 2008-05-31 17:27
帖子: 1025
地址: SUES
送出感谢: 0 次
接收感谢: 0 次
ebok 写道:
不知大家有没有这个问题,我用rhythbox或者amarok播放音乐的时候,同时上土豆或者优酷,播放的flash是没声音的,关了音乐播放器也不行,关了网页再开也不行,重启firerox 3b5 同时还要关闭播放器才可以。

改改~输出方式就好了~一个OSS 一个ALSA,一点问题都没有了~


页首
 用户资料  
 
11 楼 
 文章标题 : Re:
帖子发表于 : 2008-11-16 0:37 

注册: 2008-06-01 13:59
帖子: 50
送出感谢: 0 次
接收感谢: 0 次
liuke.forever 写道:
liuke.forever 写道:
>传说中的声卡独占?不知道是不是
>你一边听音乐还一边看视频?……强。

我觉得这的确是个问题,不是说非要一边听音乐一边看视频,
而你有可能你的flash视频没有关闭,这时你打开mp3是没有声音的,
一定要先把flash关闭才行,太麻烦了,在windows下就没有这个问题,
win下面都能实现,Linux应该要做得更好才行,ubuntu要加油啊!

这个问题不知道有没有简单的方法解决,现在网上的方法各不相同不知道怎么办才好

我终于找到解决办法了,
1,在主音量控制里的设备要选为Alsa,应该8.04默认的就是Alsa
2,要把软件的声音输出设备改为Alsa,比如Mplayer,Amarok的声音输出设备改为Asla,因为这些软件的默认声音输出
设备不是Asla
所以此问题的关键还是Asla,因该采用Asla是可以解决声卡独占问题的。


可以详细说说怎么设置吗?


页首
 用户资料  
 
12 楼 
 文章标题 : Re: [问题]播放音乐的时候,flash没声音
帖子发表于 : 2008-11-18 16:46 

注册: 2008-11-07 12:27
帖子: 8
送出感谢: 0 次
接收感谢: 0 次
sudo apt-get install libflashsupport


页首
 用户资料  
 
13 楼 
 文章标题 : Re: [问题]播放音乐的时候,flash没声音
帖子发表于 : 2012-01-17 0:03 

注册: 2011-10-18 21:20
帖子: 3
送出感谢: 0 次
接收感谢: 0 次
代码:
sudo apt-get install flashplugin-nonfree-extrasound
完美解决。


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 13 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 4 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译