无法访问windowws共享

为当前最终发行版之前的所有版本提供支持
piolong
帖子: 35
注册时间: 2007-04-11 15:14
送出感谢: 0
接收感谢: 0

无法访问windowws共享

#1

帖子 piolong » 2008-04-30 9:04

8.04安装完成后无法访问windows的共享文件。我怀疑是nautius的问题。
smb://xxx.xxx.xxx.xxx
显示不出任何东西。
是空白的
鹦鹉螺不能显示根目录的共享文件夹。但是如果使用smb://ip/共享名/,就可以访问。但是访问很慢。经常直接就死掉了。不知道为什么。

但是在kde下用konqueror访问共享就没有问题。
不知道各位有没有遇到过
附件
1.png
2.png
上次由 piolong 在 2008-06-18 13:48,总共编辑 2 次。
头像
bones7456
论坛版主
帖子: 8495
注册时间: 2006-04-12 20:05
来自: 杭州
送出感谢: 0
接收感谢: 8 次
联系:

#2

帖子 bones7456 » 2008-04-30 9:06

:arrow:

位置-连接到服务器-windows共享,试试看...
关注我的blog: ε==3
piolong
帖子: 35
注册时间: 2007-04-11 15:14
送出感谢: 0
接收感谢: 0

#3

帖子 piolong » 2008-04-30 9:21

楼上的,不行
nomove
帖子: 58
注册时间: 2008-04-13 13:13
送出感谢: 0
接收感谢: 0

#4

帖子 nomove » 2008-05-18 10:11

怎么不行 详细说说?
达文西
帖子: 12
注册时间: 2008-05-03 21:50
送出感谢: 0
接收感谢: 0

#5

帖子 达文西 » 2008-05-19 10:59

加上共享文件夹试试。
wenfeng_tom
帖子: 12
注册时间: 2008-04-14 13:35
送出感谢: 0
接收感谢: 0

#6

帖子 wenfeng_tom » 2008-05-23 11:26

sudo mount //ip/共享目录 /media/本地加载目录 -o username=xxx,password=xxx
iny
帖子: 142
注册时间: 2008-05-22 9:43
送出感谢: 0
接收感谢: 0

#7

帖子 iny » 2008-05-23 14:11

mount error 111 = Connection refused
Refer to the mount.cifs(8) manual page (e.g.man mount.cifs)
piolong
帖子: 35
注册时间: 2007-04-11 15:14
送出感谢: 0
接收感谢: 0

#8

帖子 piolong » 2008-06-18 13:47

难道你们都没有遇到这样的问题吗?
e2002
帖子: 245
注册时间: 2006-06-07 18:15
送出感谢: 1 次
接收感谢: 2 次

[问题]Kubuntu 8.04 KDE4 的Konqueror无法访问其他机器上的中文名称的samba共享

#9

帖子 e2002 » 2008-07-11 22:31

只要是共享名称中含有中文(中文显示正常)
或者访问共享文件夹内的中文文件夹与中文文件(中文显示正常),均出错.
英文的则一切正常.

请问这是不是 Konqueror的bug?
sfissw
帖子: 354
注册时间: 2007-06-21 1:30
来自: Shanghai
送出感谢: 0
接收感谢: 0
联系:

#10

帖子 sfissw » 2008-07-11 22:33

我碰到过一次差不多的

smb://192.168.1.3 不行
smb://192.168.1.3/c 就行了
e2002
帖子: 245
注册时间: 2006-06-07 18:15
送出感谢: 1 次
接收感谢: 2 次

#11

帖子 e2002 » 2008-07-15 13:53

直接使用分别 Ubuntu8.04.1 livdCD/Kubuntu8.04.1 livdCD 和Kubuntu8.04 KDE4测试
发现 :

//Ubuntu8.04.1 livdCD 中 Nautilus:
//Kubuntu8.04.1 livdCD 中 Konqueror:

1. 能正常访问 smb://<192.168.1.xxx>/<中文名称共享>/中文文件夹/中文文件名称,显示正常
2. 能正常访问 smb://<ComputerName>/<中文名称共享>/中文文件夹/中文文件名称,显示正常
3. smb:/ 显示的 <中文工作组>乱码,无法进入
4. 访问<WorkGroup>/<中文机器名称>,,显示乱码,无法进入访问



//Kubuntu8.04 KDE4 (硬盘上)中Dolphin,Konqueror:
1. 正常显示 smb://<192.168.1.xxx>/<中文名称共享>, 但无法进入
正常显示 smb://<ComputerName>/<中文名称共享>,但无法进入访问
2. 正常显示 smb://<192.168.1.xxx>/<Share>/<中文文件夹>, 但<中文文件夹>无法进入.
正常显示 smb://<ComputerName>/<Share>/<中文文件夹>, 但<中文文件夹>无法进入.
3. 地址栏键入 : smb:/ ,Dolphin窗口崩溃
地址栏键入 : smb://<ComputerName> , 如有中文名称共享,崩溃.
4. 地址栏键入 : smb://<ComputerName>/<Share>/,则其中的中文文件夹显示正常,但无法进入访问.
附件
Kubuntu8K4_samba_4.png
Kubuntu8K4_samba_3.png
Kubuntu8K4_samba_2.png
Kubuntu8K4_samba_1.png
Kubuntu804_live_samba_1.png
Kubuntu804_live_samba_2.png
Kubuntu804_live_samba_3.png
Kubuntu804_live_samba_4.png
Ubuntu804_live_samba_3.png
Ubuntu804_live_samba_4.png
e2002
帖子: 245
注册时间: 2006-06-07 18:15
送出感谢: 1 次
接收感谢: 2 次

#12

帖子 e2002 » 2008-07-15 15:05

在 Kubuntu 8.04 KDE4 中装上 Nautilus , 就可以正常访问 smb://<ComputerName>/<Share>/<中文文件夹>/<中文文件>了,看来确实是 KDE4的Dolphin有问题


最后的问题在于 : samba 如何设置才能支持 中文的 工作组名称/计算机名称?
或者说 samba 目前的版本是不是还不支持?
big-tiger
帖子: 54
注册时间: 2006-05-24 7:33
送出感谢: 0
接收感谢: 0

#13

帖子 big-tiger » 2008-07-16 17:50

我也遇到了同样的问题,可以看到域里面的计算机名字,点击进去以后目录空白,不能访问共享文件。

到现在也没有解决。不知道什么原因。
头像
xyf
帖子: 2032
注册时间: 2007-05-05 23:59
来自: 嘉兴
送出感谢: 0
接收感谢: 1 次

#14

帖子 xyf » 2008-07-16 18:30

我也遇到同样的问题,不加共享目录就一片空白,记得7.10时都正常的。
头像
daf3707
论坛版主
帖子: 12671
注册时间: 2007-06-13 15:57
来自: 在他乡
送出感谢: 49 次
接收感谢: 85 次

#15

帖子 daf3707 » 2008-07-16 18:31

我也 无法正常使用。
回复

回到 “老旧版本支持”