当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 3 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 声卡问题!
帖子发表于 : 2008-05-01 7:35 

注册: 2008-04-29 22:49
帖子: 13
送出感谢: 0 次
接收感谢: 0 次
请问一下,我装完8.04正式版后声音右边有个红色的叉,说没有找到音量控制插件和/或设备,应该是检测不到声卡吧?我之前用同一张系统碟安装后就有声音了,但刚刚重装后就这样了,哪位大哥知道是怎么回事阿???

在网上找了一篇文章:
进入终端输入:
aplay -l
如果成功显示类似内容:
card 0: IXP [ATI IXP], device 0: ATI IXP AC97 [ATI IXP AC97]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 0: IXP [ATI IXP], device 1: ATI IXP IEC958 [ATI IXP IEC958 (AC97)]
Subdevices: 1/1
Subdevice #0: subdevice #0
不成功显示:
aplay: device_list:221: no soundcard found…
不成功的话,往下看。
去除系统自带声音模块
sudo apt-get –purge remove linux-sound-base alsa-base alsa-utils
重新安装,并安装最新模块:
sudo apt-get install linux-sound-base alsa-base alsa-utils
重启后可能不能进入gdm图型登录窗口。
ubuntu 的用户输入
sudo apt-get install gdm ubuntu-desktop
Xubuntu的用户输入:
sudo apt-get install gdm xubuntu-desktop
重启一下。
安装alsa模块:
sudo apt-get install build-essential linux-headers-$(uname -r) module-assistant alsa-source
配置一次
sudo dpkg-reconfigure alsa-source
将会有一个蓝色窗口询问你是否安装。
选择yes
接着会询问你安装的声卡型号。
如果你清楚你要安装的型号就选你要装的,但个人推荐全选。
如果没有出错的话就是成功了。
请再重启你的电脑就可以听到优美的声音了。

这说的是对的吗?我用aplay -l命令提示说找不到声卡,但我执行sudo apt-get –purge remove linux-sound-base alsa-base alsa-utils这句的时候提示:E: 无效的操作 –purge,后面的没办法试了,哪位大哥有更好的方法吗?


页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2008-05-01 7:55 

注册: 2008-04-29 22:49
帖子: 13
送出感谢: 0 次
接收感谢: 0 次
原来是内核问题,我是看着ubuntu速成手册配置的,里面说台式机用realtime 内核更好,于是我就换了,开始我也没注意到声音,后来发觉没声音了,相比我上次装系统,只是上次没换内核,所以我就进去本来那个内核试一下,一到登录界面就有声音了,请问一下,换内核后怎么才可以识别到声卡呢?上网找声卡驱动???


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2008-05-01 9:24 

注册: 2008-04-26 21:53
帖子: 33
送出感谢: 0 次
接收感谢: 0 次
我也没声音
N天了
各种找解决办法
失败中。。。。


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 3 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 4 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译