当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 10 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : [问题] ubuntu 8.04下安装VMware-workstation-6.0.0-45731
帖子发表于 : 2008-05-01 10:48 

注册: 2007-10-09 16:58
帖子: 27
地址: http://www.kueye.cn/
送出感谢: 0 次
接收感谢: 0 次
引用:
安装 VMware Workstation (VMware-workstation-6.0.0-45731.i386.tar.gz)
Linux Serial Number: WC5FW-V0CFX-4804A-4WTNL

1. 将软件包解压缩,得到名为 vmware-distrib 的文件包。
2. 安装前期必备软件
sudo apt-get install build-essential

sudo apt-get install gcc-3.4
sudo apt-get install linux-headers-`uname -r`
export CC=gcc-3.4


3.进入到vmware所在目录
运行安装脚本 sudo ./shlmware-install.pl
安装提示一步步往下做,默认为回车键或Y


我是按上面的方法做的,(执行“export CC=gcc-3.4”的时候终端是没反映的吗?我是菜鸟)

运行安装脚本 sudo ./shlmware-install.pl
一路回车:
引用:
A previous installation of VMware Workstation has been detected.

The previous installation was made by the tar installer (version 4).

Keeping the tar4 installer database format.

Uninstalling the tar installation of VMware Workstation.

Stopping VMware services:
Virtual machine monitor done

The removal of VMware Workstation 6.0.0 build-45731 for Linux completed
successfully. Thank you for having tried this software.

Installing VMware Workstation. This may take from several minutes to over an
hour depending upon its size.

In which directory do you want to install the binary files?
[/usr/bin]

What is the directory that contains the init directories (rc0.d/ to rc6.d/)?
[/etc]

What is the directory that contains the init scripts?
[/etc/init.d]

In which directory do you want to install the daemon files?
[/usr/sbin]

In which directory do you want to install the library files?
[/usr/lib/vmware]

The path "/usr/lib/vmware" does not exist currently. This program is going to
create it, including needed parent directories. Is this what you want?
[yes]


In which directory do you want to install the manual files?
[/usr/share/man]
In which directory do you want to install the documentation files?
[/usr/share/doc/vmware]

The path "/usr/share/doc/vmware" does not exist currently. This program is
going to create it, including needed parent directories. Is this what you want?
[yes]

The installation of VMware Workstation 6.0.0 build-45731 for Linux completed
successfully. You can decide to remove this software from your system at any
time by invoking the following command: "/usr/bin/vmware-uninstall.pl".

Before running VMware Workstation for the first time, you need to configure it
by invoking the following command: "/usr/bin/vmware-config.pl". Do you want
this program to invoke the command for you now? [yes]

Making sure services for VMware Workstation are stopped.

Stopping VMware services:
Virtual machine monitor done

Configuring fallback GTK+ 2.4 libraries.

In which directory do you want to install the theme icons?
[/usr/share/icons]

What directory contains your desktop menu entry files? These files have a
.desktop file extension. [/usr/share/applications]

In which directory do you want to install the application's icon?
[/usr/share/pixmaps]

/usr/share/applications/vmware-workstation.desktop: warning: value "vmware-workstation.png" for key "Icon" in group "Desktop Entry" is an icon name with an extension, but there should be no extension as described in the Icon Theme Specification if the value is not an absolute path
/usr/share/applications/vmware-player.desktop: warning: value "vmware-player.png" for key "Icon" in group "Desktop Entry" is an icon name with an extension, but there should be no extension as described in the Icon Theme Specification if the value is not an absolute path
Trying to find a suitable vmmon module for your running kernel.

None of the pre-built vmmon modules for VMware Workstation is suitable for your
running kernel. Do you want this program to try to build the vmmon module for
your system (you need to have a C compiler installed on your system)? [yes]

Using compiler "/usr/bin/gcc". Use environment variable CC to override.

What is the location of the directory of C header files that match your running
kernel? [/lib/modules/2.6.24-16-generic/build/include]

Extracting the sources of the vmmon module.

Building the vmmon module.

Using 2.6.x kernel build system.
make: Entering directory `/tmp/vmware-config0/vmmon-only'
make -C /lib/modules/2.6.24-16-generic/build/include/.. SUBDIRS=$PWD SRCROOT=$PWD/. modules
make[1]: Entering directory `/usr/src/linux-headers-2.6.24-16-generic'
CC [M] /tmp/vmware-config0/vmmon-only/linux/driver.o
In file included from /tmp/vmware-config0/vmmon-only/./include/vmware.h:25,
from /tmp/vmware-config0/vmmon-only/linux/driver.c:48:
/tmp/vmware-config0/vmmon-only/./include/vm_basic_types.h:170: 错误: 与‘uintptr_t’类型冲突
include/linux/types.h:40: 错误: ‘uintptr_t’的上一个声明在此
在包含自 /tmp/vmware-config0/vmmon-only/./include/x86.h:23 的文件中,
从 /tmp/vmware-config0/vmmon-only/linux/driver.h:15,
从 /tmp/vmware-config0/vmmon-only/linux/driver.c:49:
/tmp/vmware-config0/vmmon-only/./include/x86cpuid.h:381:1: 警告: “BIT_MASK”重定义
在包含自 include/linux/kernel.h:15 的文件中,
从 /tmp/vmware-config0/vmmon-only/linux/driver.c:11:
include/linux/bitops.h:7:1: 警告: 这是先前定义的位置
在包含自 /tmp/vmware-config0/vmmon-only/./include/vmci_kernel_defs.h:26 的文件中,
从 /tmp/vmware-config0/vmmon-only/./common/vmciContext.h:19,
从 /tmp/vmware-config0/vmmon-only/linux/driver.h:21,
从 /tmp/vmware-config0/vmmon-only/linux/driver.c:49:
/tmp/vmware-config0/vmmon-only/./include/compat_wait.h:37:5: 警告: “VMW_HAVE_EPOLL”未定义
/tmp/vmware-config0/vmmon-only/./include/compat_wait.h:43:5: 警告: “VMW_HAVE_EPOLL”未定义
In file included from /tmp/vmware-config0/vmmon-only/./include/vmci_kernel_defs.h:26,
from /tmp/vmware-config0/vmmon-only/./common/vmciContext.h:19,
from /tmp/vmware-config0/vmmon-only/linux/driver.h:21,
from /tmp/vmware-config0/vmmon-only/linux/driver.c:49:
/tmp/vmware-config0/vmmon-only/./include/compat_wait.h:60: 错误: 与‘poll_initwait’类型冲突
include/linux/poll.h:65: 错误: ‘poll_initwait’的上一个声明在此
/tmp/vmware-config0/vmmon-only/linux/driver.c:150: 警告: 从不兼容的指针类型初始化
/tmp/vmware-config0/vmmon-only/linux/driver.c: 在函数‘LinuxDriver_Ioctl’中:
/tmp/vmware-config0/vmmon-only/linux/driver.c:1715: 错误: ‘struct mm_struct’没有名为‘dumpable’的成员
make[2]: *** [/tmp/vmware-config0/vmmon-only/linux/driver.o] 错误 1
make[1]: *** [_module_/tmp/vmware-config0/vmmon-only] 错误 2
make[1]: Leaving directory `/usr/src/linux-headers-2.6.24-16-generic'
make: *** [vmmon.ko] 错误 2
make: Leaving directory `/tmp/vmware-config0/vmmon-only'
Unable to build the vmmon module.

For more information on how to troubleshoot module-related problems, please
visit our Web site at "http://www.vmware.com/download/modules/modules.html" and
"http://www.vmware.com/support/reference/linux/prebuilt_modules_linux.html".

Execution aborted.

tao@tao-desktop:~/桌面/vmware-distrib$

请高手帮我分析一下是哪里错了,因为我这里电信要用星空极速上网,而最新版很难破解,所以打算在ubuntu下虚拟XP,然后共享XP的网络上网。

另外,我现在用的是vmware下虚拟的ubuntu 8.04,然后在ubuntu 8.04下试装vmware


页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2008-05-01 11:01 
头像

注册: 2005-09-10 16:04
帖子: 3537
地址: DG-GD-China
送出感谢: 0 次
接收感谢: 0 次
试试virtualbox咯
你想虚拟XP,然后利用虚拟机里的XP让ubuntu上网?
似乎很难哦


_________________
http://element.blog.ubuntu.org.cn/
Ubuntu Jaunty Jackalope...
AMD Barton 2600+
MSI K7N2 Delta-L
Kingston DDR400 512M*2+256M*1
nVidia FX5200
Seagate 80G(Jaunty Jackalope)
Seagate 160G(XXxxXX)
SyncMaster 732N


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2008-05-01 11:05 

注册: 2007-10-09 16:58
帖子: 27
地址: http://www.kueye.cn/
送出感谢: 0 次
接收感谢: 0 次
Element 写道:
试试virtualbox咯
你想虚拟XP,然后利用虚拟机里的XP让ubuntu上网?
似乎很难哦


难也要试试嘛``
老在虚拟机下弄ubuntu``不爽


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2008-05-01 11:07 
头像

注册: 2005-09-10 16:04
帖子: 3537
地址: DG-GD-China
送出感谢: 0 次
接收感谢: 0 次
你这种反过来的,我觉得是不可能的,你的ubuntu都不能上网,你别想你的虚拟机里的可以上网了


_________________
http://element.blog.ubuntu.org.cn/
Ubuntu Jaunty Jackalope...
AMD Barton 2600+
MSI K7N2 Delta-L
Kingston DDR400 512M*2+256M*1
nVidia FX5200
Seagate 80G(Jaunty Jackalope)
Seagate 160G(XXxxXX)
SyncMaster 732N


页首
 用户资料  
 
5 楼 
 文章标题 :
帖子发表于 : 2008-05-01 11:14 

注册: 2007-10-09 16:58
帖子: 27
地址: http://www.kueye.cn/
送出感谢: 0 次
接收感谢: 0 次
Element 写道:
你这种反过来的,我觉得是不可能的,你的ubuntu都不能上网,你别想你的虚拟机里的可以上网了

并不是ubuntu上不了网``
是要用“星空极速”这个拔号器才能上网``
而它又没有linux版本的``


页首
 用户资料  
 
6 楼 
 文章标题 :
帖子发表于 : 2008-05-01 11:17 
头像

注册: 2005-09-10 16:04
帖子: 3537
地址: DG-GD-China
送出感谢: 0 次
接收感谢: 0 次
http://www.lupaworld.com/viewthread_29803.html
在网上搜吧,肯定可以破解的
要不你就打10000,让他们过来给你搞,先把你的XP藏好,你告诉他们你就这么一个系统,他们没办法就给你开路由功能了,而不需要那个什么星空极速的垃圾软件了


_________________
http://element.blog.ubuntu.org.cn/
Ubuntu Jaunty Jackalope...
AMD Barton 2600+
MSI K7N2 Delta-L
Kingston DDR400 512M*2+256M*1
nVidia FX5200
Seagate 80G(Jaunty Jackalope)
Seagate 160G(XXxxXX)
SyncMaster 732N


页首
 用户资料  
 
7 楼 
 文章标题 :
帖子发表于 : 2008-05-01 11:20 

注册: 2007-10-09 16:58
帖子: 27
地址: http://www.kueye.cn/
送出感谢: 0 次
接收感谢: 0 次
Element 写道:
http://www.lupaworld.com/viewthread_29803.html
在网上搜吧,肯定可以破解的
要不你就打10000,让他们过来给你搞,先把你的XP藏好,你告诉他们你就这么一个系统,他们没办法就给你开路由功能了,而不需要那个什么星空极速的垃圾软件了


先谢谢朋友,此法是有用的,我去看试过,而现在用不了了,因为电信这下用的是动态加密,最少有8个帐号,以前版本的星空极速在windows下都用不了``用是可恶,看来我得试试打电话了``


页首
 用户资料  
 
8 楼 
 文章标题 :
帖子发表于 : 2008-05-01 11:25 

注册: 2008-03-27 22:54
帖子: 33
送出感谢: 0 次
接收感谢: 0 次
内核没有加载vmware的模块儿,我在安装vmware6.02的时候也遇到这种问题,不过在网上搜索了一下才知道要打一个补丁才可以,不过我的补丁是6.02的。你可以试一下看6.00版本的vmware能不能用。用法如下
解压后进入目录以root身份运行 runme.pl 然后一路回车,我机器安装Vmware的性能不太令我满意,我现在主要使用Vbox,不知道你的机器如何!! 祝你好运!!!


附件:
vmware-any-any-update116补丁包.rar [398.53 KiB]
被下载 439 次
页首
 用户资料  
 
9 楼 
 文章标题 :
帖子发表于 : 2008-05-01 11:41 

注册: 2007-10-09 16:58
帖子: 27
地址: http://www.kueye.cn/
送出感谢: 0 次
接收感谢: 0 次
twg1023 写道:
内核没有加载vmware的模块儿,我在安装vmware6.02的时候也遇到这种问题,不过在网上搜索了一下才知道要打一个补丁才可以,不过我的补丁是6.02的。你可以试一下看6.00版本的vmware能不能用。用法如下
解压后进入目录以root身份运行 runme.pl 然后一路回车,我机器安装Vmware的性能不太令我满意,我现在主要使用Vbox,不知道你的机器如何!! 祝你好运!!!


谢谢,我试下,机器:AMD4000+ DDR800 2G + X1650GT


页首
 用户资料  
 
10 楼 
 文章标题 :
帖子发表于 : 2008-05-02 11:33 

注册: 2008-04-28 8:34
帖子: 8
送出感谢: 0 次
接收感谢: 0 次
电信的星空急速那个软件可以不用,直接自己在XP下建个宽带连接应该就可以上了……


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 10 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 5 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译