[问题]救命8.04的firefox3不能启动了

为当前最终发行版之前的所有版本提供支持
rocck
帖子: 29
注册时间: 2007-10-27 8:43
送出感谢: 0
接收感谢: 0

[问题]救命8.04的firefox3不能启动了

#1

帖子 rocck » 2008-05-02 15:58

因为系统自带的ff3b5有好些插件不能用,就从网上找了个ff2的deb包安上了,结果发现因为3的存在,2就是傀儡
就用remove命令删除了2了
然后 就发现ff3也不能用了
点击ff3的图标就提示
----
无法启动应用程序 执行子进程firefox 失败
----------
然后尝试卸载ff3再从新安装ff3
就出现如下提示
------
$ sudo apt-get install firefox
[sudo] password for h:
正在读取软件包列表... 完成
正在分析软件包的依赖关系树
读取状态信息... 完成
firefox 已经是最新的版本了。
共升级了 0 个软件包,新安装

$ firefox
程序 'firefox' 尚未安装。 您可以通过输入以下命令安装:
sudo apt-get install firefox-3.0
bash: firefox:找不到命令
$ sudo apt-get install firefox-3.0
正在读取软件包列表... 完成
正在分析软件包的依赖关系树
读取状态信息... 完成
firefox-3.0 已经是最新的版本了。
firefox-3.0 设定为手动安装。
共升级了 0 个软件包,新安装了 0 个软件包,要卸载 0 个软件包,有 3 个软件未被升级。
------------

期间从新立得彻底删除从新安装 都无效

各位高手能告诉下这是什么问题么
还好当初安了个opera 要不现在求救都没地方拉
rocck
帖子: 29
注册时间: 2007-10-27 8:43
送出感谢: 0
接收感谢: 0

#2

帖子 rocck » 2008-05-02 16:07

:shock: :shock: :shock:
有专家在么
谁帮我喊一声哦
:roll: :roll: :roll: :roll:
JiangHui
论坛版主
帖子: 21301
注册时间: 2007-08-02 20:29
系统: 窓辺とうこ
送出感谢: 0
接收感谢: 13 次

#3

帖子 JiangHui » 2008-05-02 16:31

新立得,选择firefox ,强制版本
rocck
帖子: 29
注册时间: 2007-10-27 8:43
送出感谢: 0
接收感谢: 0

#4

帖子 rocck » 2008-05-02 16:48

JiangHui 写了:新立得,选择firefox ,强制版本
按钮灰色 不可用
JiangHui
论坛版主
帖子: 21301
注册时间: 2007-08-02 20:29
系统: 窓辺とうこ
送出感谢: 0
接收感谢: 13 次

#5

帖子 JiangHui » 2008-05-02 17:26

rocck 写了:
JiangHui 写了:新立得,选择firefox ,强制版本
按钮灰色 不可用
我这 强制版本 都不是灰色的?
rocck
帖子: 29
注册时间: 2007-10-27 8:43
送出感谢: 0
接收感谢: 0

#6

帖子 rocck » 2008-05-03 8:23

可是我的是。。。。
很怪异
我跟朋友尝试了好多办法 都无法完全干净的清理掉ff
附件
Screenshot-新立得软件包管理器 .png
JiangHui
论坛版主
帖子: 21301
注册时间: 2007-08-02 20:29
系统: 窓辺とうこ
送出感谢: 0
接收感谢: 13 次

#7

帖子 JiangHui » 2008-05-03 10:56

rocck 写了:可是我的是。。。。
很怪异
我跟朋友尝试了好多办法 都无法完全干净的清理掉ff
那等等吧,等3好用了……
目前先用opera……
头像
leeaman
帖子: 30702
注册时间: 2007-02-02 18:14
系统: debian sid
送出感谢: 1 次
接收感谢: 23 次

#8

帖子 leeaman » 2008-05-03 12:16

去mozilla下载tar.gz格式的解压就可以用了,安全一点
醉了星星,醉月亮●●●●●The Long Way To Go(*^_^*)
头像
solcomo
帖子: 2838
注册时间: 2007-04-25 13:12
送出感谢: 0
接收感谢: 0
联系:

#9

帖子 solcomo » 2008-05-03 12:17

whereis firefox
♜♞♝♛♚♝♞♜
♟♟♟♟♟♟♟♟
♙♙♙♙♙♙♙♙
♖♘♗♕♔♗♘♖

☠☯⚔⚓☣☦☃☕
☹☻☪☭☬⚖⚛⚜
ℜℳℬ™ ℋℯℓ℘ ℳℭ
sƂɐʍ рǀɹoʍ əɥʇ oS
头像
lll9p
帖子: 1806
注册时间: 2007-07-18 18:56
送出感谢: 0
接收感谢: 0
联系:

#10

帖子 lll9p » 2008-05-03 12:34

用欣立得完全删除firefox,删除 ~/.mozilla
再重新安裝
头像
paulcross
帖子: 484
注册时间: 2006-07-23 20:27
送出感谢: 0
接收感谢: 0

#11

帖子 paulcross » 2008-05-03 12:41

删除掉firefox的所有东西
sudo apt-get remove firefox*

删除掉所有没用的东西

sudo apt-get autoremove

删除掉所有没用的配置文件

dpkg -l |grep ^rc|awk '{print $2}' |sudo xargs dpkg -P


然后用新立得安装firefox 2或者3都可以
rocck
帖子: 29
注册时间: 2007-10-27 8:43
送出感谢: 0
接收感谢: 0

#12

帖子 rocck » 2008-05-03 17:17

楼上几位的办法都尝试了
不行滴...
我崩溃了
朋友是从gentoo被我拉到ubuntu这边来的
现在可好
我这一崩溃 他现在开始说服我去gentoo了
头像
paulcross
帖子: 484
注册时间: 2006-07-23 20:27
送出感谢: 0
接收感谢: 0

#13

帖子 paulcross » 2008-05-03 17:49

linux 本爱就是这样的
但是久病成良医 经过的失败越多 学到的东西也越多

其实你错就错在不研究下怎么把2的插件安到3上 而是去下载一个2

2的多数插件3确实不兼容 不过没关系 可以通过修改版本号实现兼容 就修改一行 很简单的 一次就知道了
rocck
帖子: 29
注册时间: 2007-10-27 8:43
送出感谢: 0
接收感谢: 0

#14

帖子 rocck » 2008-05-03 18:57

楼上就不能把具体方法写出来么
这下好了
ff问题不用解决了
系统检测到自动更新
更新了以后
桌面都进不去了

提示什么 busybox
initramfs
然后就没反应了
头像
paulcross
帖子: 484
注册时间: 2006-07-23 20:27
送出感谢: 0
接收感谢: 0

#15

帖子 paulcross » 2008-05-03 19:07

具体方法要我另装一遍才能写出来啊
毕竟我记不准那么多具体的选项的名字 不过论坛里都有别人作国的

busybox 这个问题也很普遍 论坛里也有答案 不过我建议还是刻张光盘 重装得了
系统原来带的那些东西 如 firefox evolution nautilus都不要动
回复

回到 “老旧版本支持”