8.04安装vmware 6.5 Beta出现这样的错误,如何解决?

为当前最终发行版之前的所有版本提供支持
回复
头像
relaxssl
帖子: 1448
注册时间: 2007-01-30 7:13
送出感谢: 5 次
接收感谢: 0

8.04安装vmware 6.5 Beta出现这样的错误,如何解决?

#1

帖子 relaxssl » 2008-05-03 22:07

错误如图所示,但能正常使用,不知道这个错误关联的是哪个功能? 如何解决?
附件
screenshot3.png
screenshot4.png
ilife
帖子: 17
注册时间: 2008-04-19 9:45
送出感谢: 0
接收感谢: 0
联系:

#2

帖子 ilife » 2008-05-03 22:20

换virtualbox。。。
听说最新版的不错。
头像
relaxssl
帖子: 1448
注册时间: 2007-01-30 7:13
送出感谢: 5 次
接收感谢: 0

#3

帖子 relaxssl » 2008-05-03 22:32

ilife 写了:换virtualbox。。。
听说最新版的不错。
我用vmware习惯了,现在8.04suspend和resum的速度都比7.04还要快,飞的感觉,工作很节约时间,7.10还是算了,几乎不用它,比7.04落后。
8.04确实进步了不少。
头像
shanliang8008
帖子: 1362
注册时间: 2007-07-16 19:43
来自: tangshan
送出感谢: 0
接收感谢: 0

#4

帖子 shanliang8008 » 2008-05-03 22:47

不用解决 我的也那样 不过 不用虚拟机了 机会干不 消耗大资源的东西
头像
relaxssl
帖子: 1448
注册时间: 2007-01-30 7:13
送出感谢: 5 次
接收感谢: 0

#5

帖子 relaxssl » 2008-05-03 23:05

shanliang8008 写了:不用解决 我的也那样 不过 不用虚拟机了 机会干不 消耗大资源的东西
工作需要,里不开。
头像
shanliang8008
帖子: 1362
注册时间: 2007-07-16 19:43
来自: tangshan
送出感谢: 0
接收感谢: 0

#6

帖子 shanliang8008 » 2008-05-03 23:50

别管他一样用 我的也那样
kitrea
帖子: 1
注册时间: 2007-03-01 1:28
送出感谢: 0
接收感谢: 0

#7

帖子 kitrea » 2008-05-04 0:12

正在用virtualbax学习ububtu中
hanjiangli2000
帖子: 9
注册时间: 2008-05-10 14:04
送出感谢: 0
接收感谢: 0

#8

帖子 hanjiangli2000 » 2008-05-17 9:19

我的也出现同样的错误,求解
头像
wjj
帖子: 52
注册时间: 2007-12-10 9:17
送出感谢: 0
接收感谢: 0
联系:

#9

帖子 wjj » 2008-05-17 9:27

恐怕是ubuntu不支持vwmare了,用vbox吧,要不自己编译一下看看!!
头像
relaxssl
帖子: 1448
注册时间: 2007-01-30 7:13
送出感谢: 5 次
接收感谢: 0

#10

帖子 relaxssl » 2008-05-17 20:07

在编译过程中会发生vmmon不能正常编译的过程 需要对代码做如下调整
到解压缩后vmware-distrib/lib/modules/source中 找到vmmon.tar
tar xvf vmmon.tar
cd vmmon-only/include
vi compat_kernel.h
找到 static inline _syscall1(int, compat_exit, int, exit_code); 直接删除 2.6.24已经不支持这样做了 也不需要了
:wq退出
vi vcpuset.h
找到 #include "asm/bitops.h" 这个路径不对,实质上这个不是给linux用的 改为 #include "linux/bitops.h"(也可以直接gkedit编辑)
:wq退出
cd ../..
sudo tar cvf vmmon.tar vmmon-only

然后再安装就不会出问题了
hanjiangli2000
帖子: 9
注册时间: 2008-05-10 14:04
送出感谢: 0
接收感谢: 0

#11

帖子 hanjiangli2000 » 2008-05-18 11:01

问题依旧阿 ~~~~
VMCI还是不正常
回复

回到 “老旧版本支持”