当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 3 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : [求助]软件更新出现错误
帖子发表于 : 2008-05-04 20:28 
头像

注册: 2007-10-20 15:26
帖子: 175
送出感谢: 0 次
接收感谢: 0 次
软件包毁损,用apt-get -f install也没效果:

gun@gun-ubuntu:~$ sudo apt-get -f install
正在读取软件包列表... 完成
正在分析软件包的依赖关系树
读取状态信息... 完成
正在更正依赖关系... 完成
将会安装下列额外的软件包:
libotr
下列【新】软件包将被安装:
libotr
共升级了 0 个软件包,新安装了 1 个软件包,要卸载 0 个软件包,有 1 个软件未被升级。
有 1 个软件包没有被完全安装或卸载。
需要下载 0B/128kB 的软件包。
操作完成后,会消耗掉 418kB 的额外磁盘空间。
您希望继续执行吗?[Y/n]y
(正在读取数据库 ... 系统当前总共安装有 129649 个文件和目录。)
正在解压缩 libotr (从 .../libotr_3.1.0-schmidtke1_i386.deb) ...
dpkg:处理 /var/cache/apt/archives/libotr_3.1.0-schmidtke1_i386.deb (--unpack)时出错:
正试图覆盖“/usr/lib/libotr.so.2.1.0”,它属于软件包 libotr2
dpkg-deb: 子进程 paste 被信号(Broken pipe)终止了
在处理时有错误发生:
/var/cache/apt/archives/libotr_3.1.0-schmidtke1_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)


页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2008-05-04 20:50 

注册: 2006-03-10 15:10
帖子: 3182
地址: xi'an China
送出感谢: 0 次
接收感谢: 2
怀疑你混用不同版本系统的源了

如果是的话,去掉不恰当的源再继续。不是的话,多提供点信息


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2008-05-04 20:57 
头像

注册: 2007-10-20 15:26
帖子: 175
送出感谢: 0 次
接收感谢: 0 次
楼上正解
刚加了“ 加个源!用最新最酷的软件(转自Linux桌面中文网)”里的源,忘了改版本了,谢谢了。

顺便问下,这样混用不同版本的源更新软件后,会不会有暂时发现不了的错误?


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 3 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 4 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译