5月2日软件包升级后出错,每次安装软件后有以下提示,我该如何解决?谢谢!

为当前最终发行版之前的所有版本提供支持
回复
thomsi
帖子: 67
注册时间: 2007-08-17 14:04
送出感谢: 0
接收感谢: 0
联系:

5月2日软件包升级后出错,每次安装软件后有以下提示,我该如何解决?谢谢!

#1

帖子 thomsi » 2008-05-05 10:38

5月2日软件包升级后出错,每次安装软件后有以下提示,我该如何解决?谢谢!
正在设置 capplets-data (1:2.22.1-0ubuntu4.1) ...
dpkg:处理 capplets-data (--configure)时出错:
子进程 post-installation script 返回了错误号 127
正在设置 evolution-common (2.22.1-0ubuntu3.1) ...
dpkg:处理 evolution-common (--configure)时出错:
子进程 post-installation script 返回了错误号 127
dpkg:依赖关系问题使得 gnome-control-center 的配置工作不能继续:
gnome-control-center 依赖于 capplets-data (>= 1:2.22);然而:
软件包 capplets-data 还没有被配置。
gnome-control-center 依赖于 capplets-data (<< 1:2.23);然而:
软件包 capplets-data 还没有被配置。
dpkg:处理 gnome-control-center (--configure)时出错:
依赖关系问题 - 仍未被配置
正在设置 gnome-system-monitor (2.22.1-0ubuntu1) ...
dpkg:处理 gnome-system-monitor (--configure)时出错:
子进程 post-installation script 返回了错误号 127
dpkg:依赖关系问题使得 nautilus 的配置工作不能继续:
nautilus 依赖于 gnome-control-center (>= 2.6);然而:
软件包 gnome-control-center 还没有被配置。
dpkg:处理 nautilus (--configure)时出错:
依赖关系问题 - 仍未被配置
正在设置 update-manager (1:0.87.26) ...
dpkg:处理 update-manager (--configure)时出错:
子进程 post-installation script 返回了错误号 127
在处理时有错误发生:
capplets-data
evolution-common
gnome-control-center
gnome-system-monitor
nautilus
update-manager
头像
ljj_jjl2008
论坛版主
帖子: 14253
注册时间: 2007-09-16 8:29
送出感谢: 94 次
接收感谢: 231 次

#2

帖子 ljj_jjl2008 » 2008-05-05 16:03

我碰上过类似问题,开始用:sudo -f install,不管用。
后来进新立德把报告错误的那几个包彻底删除了,然后重新安装,中间卸载了很多东西,就好了。
你可以用新立德尝试一下。
thomsi
帖子: 67
注册时间: 2007-08-17 14:04
送出感谢: 0
接收感谢: 0
联系:

使用新立德包管理器还是一样无法卸载,提示一样的错误。

#3

帖子 thomsi » 2008-05-14 12:00

正在读取软件包列表... 完成
正在分析软件包的依赖关系树
读取状态信息... 完成
下列软件包将被【卸载】:
capplets-data evolution-common fast-user-switch-applet gnome-panel-data
gnome-system-monitor update-manager
共升级了 0 个软件包,新安装了 0 个软件包,要卸载 6 个软件包,有 0 个软件未被升级。
有 6 个软件包没有被完全安装或卸载。
操作完成后,会释放 129MB 的磁盘空间。
您希望继续执行吗?[Y/n]y
(正在读取数据库 ... 系统当前总共安装有 125814 个文件和目录。)
正在删除 capplets-data ...
scrollkeeper-update: symbol lookup error: /usr/lib/libxslt.so.1: undefined symbol: xmlXPathContextSetCache
dpkg:处理 capplets-data (--remove)时出错:
子进程 post-removal script 返回了错误号 127
正在删除 evolution-common ...
scrollkeeper-update: symbol lookup error: /usr/lib/libxslt.so.1: undefined symbol: xmlXPathContextSetCache
dpkg:处理 evolution-common (--remove)时出错:
子进程 post-removal script 返回了错误号 127
正在删除 fast-user-switch-applet ...
scrollkeeper-update: symbol lookup error: /usr/lib/libxslt.so.1: undefined symbol: xmlXPathContextSetCache
dpkg:处理 fast-user-switch-applet (--remove)时出错:
子进程 post-removal script 返回了错误号 127
正在删除 gnome-panel-data ...
scrollkeeper-update: symbol lookup error: /usr/lib/libxslt.so.1: undefined symbol: xmlXPathContextSetCache
dpkg:处理 gnome-panel-data (--remove)时出错:
子进程 post-removal script 返回了错误号 127
正在删除 gnome-system-monitor ...
scrollkeeper-update: symbol lookup error: /usr/lib/libxslt.so.1: undefined symbol: xmlXPathContextSetCache
dpkg:处理 gnome-system-monitor (--remove)时出错:
子进程 post-removal script 返回了错误号 127
正在删除 update-manager ...
scrollkeeper-update: symbol lookup error: /usr/lib/libxslt.so.1: undefined symbol: xmlXPathContextSetCache
dpkg:处理 update-manager (--remove)时出错:
子进程 post-removal script 返回了错误号 127
在处理时有错误发生:
capplets-data
evolution-common
fast-user-switch-applet
gnome-panel-data
gnome-system-monitor
update-manager
回复

回到 “老旧版本支持”