当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 2 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : I have got some problems with GRUB
帖子发表于 : 2008-05-08 9:14 

注册: 2006-11-17 8:04
帖子: 3
送出感谢: 0 次
接收感谢: 0 次
I'm sorry for my poor English because my system doesn't support Chinese input. Early, I installed two OS on my PC, one is Windows XP, one is Ubuntu 7.10. So, the GRUB is in charge of my PC's boot. But last night one sudden problem occurred to it, When I turn on my PC, the choosing menu didn't show up, leaving only a black screen, So I use my live cd to boot, after that I did this:
代码:
grub> find /boot/grub/stage1
 (hd0,11)

grub> root (hd0,11)

grub> setup (hd0)
 Checking if "/boot/grub/stage1" exists... yes
 Checking if "/boot/grub/stage2" exists... yes
 Checking if "/boot/grub/e2fs_stage1_5" exists... yes
 Running "embed /boot/grub/e2fs_stage1_5 (hd0)"...  15 sectors are embedded.
succeeded
 Running "install /boot/grub/stage1 (hd0) (hd0)1+15 p (hd0,11)/boot/grub/stage2
 /boot/grub/menu.lst"... failed

Error 12: Invalid device requested

So, does anybody tell me how can I recover GRUB?


页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2008-05-08 9:24 
头像

注册: 2005-08-14 21:55
帖子: 58428
地址: 长沙
送出感谢: 4
接收感谢: 272
root过去,似乎是正常的。可读。难道设备不可写了?建议到英文论坛发发。


_________________
● 鸣学


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 2 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:Exabot [Bot] 和 4 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译