[问题]如何在apt中安装老版本的mysql

为当前最终发行版之前的所有版本提供支持
回复
librancj
帖子: 28
注册时间: 2006-10-17 9:55
送出感谢: 0
接收感谢: 0

[问题]如何在apt中安装老版本的mysql

#1

帖子 librancj » 2008-05-08 17:34

ubuntu里需要运行一个程序,这个程序应该是很老的编译...本来在ubuntu8.04下的新的利中安装了mysql5.X
,但是运行那个程序的时候提示缺少 libmysqlclient.ro.10等几个文件 搜索了一下发现是mysqlclnet3.25版本的库文件..

使用了以下方法皆未成功:
1.去网上找了libmysqlclient10.deb包.安装好之后,缺少文件提示没了.却提示连接数据库出错..我想应该是库文件函数问题吧..毕竟系统中的mysqlclient是5.X版本的.

2.直接把mysql5.X带的库文件libmysqlclient.ro.15.0.0等文件,软链接到libmysqlclient.ro.10
这时再执行那个程序发现可以连接数据库了..但是程序执行过程中却提示"段错误".

以前装老版本的ubuntu没出过这种问题....

现在我想下载mysqlclient3.25版本...不知道如何在apt里下载...不知道源里还有这东西没
librancj
帖子: 28
注册时间: 2006-10-17 9:55
送出感谢: 0
接收感谢: 0

#2

帖子 librancj » 2008-05-09 7:29

没有人能帮帮忙吗 - -!
回复

回到 “老旧版本支持”