[问题]gpg: 找不到有效的 OpenPGP 数据

为当前最终发行版之前的所有版本提供支持
回复
516218688
帖子: 10
注册时间: 2008-04-12 14:05
送出感谢: 0
接收感谢: 0

[问题]gpg: 找不到有效的 OpenPGP 数据

#1

帖子 516218688 » 2008-05-09 13:41

weiyalong@weiyalong-desktop:~$ wget -q http://packages.medibuntu.org/medibuntu-key.gpg -O- | sudo apt-key add -
[sudo] password for weiyalong:
gpg: 找不到有效的 OpenPGP 数据。
weiyalong@weiyalong-desktop:~$



这是怎么回事啊???
fason
帖子: 40
注册时间: 2007-08-01 16:51
送出感谢: 0
接收感谢: 0

#2

帖子 fason » 2008-05-09 13:59

1. http://packages.medibuntu.org/medibuntu-key.gpg 这个文件在你的网络环境下能下载吗?
2.sudo时密码有没有错
516218688
帖子: 10
注册时间: 2008-04-12 14:05
送出感谢: 0
接收感谢: 0

#3

帖子 516218688 » 2008-05-09 14:03

密码没有错
willshou
帖子: 1
注册时间: 2008-12-17 10:47
送出感谢: 0
接收感谢: 0

Re: [问题]gpg: 找不到有效的 OpenPGP 数据

#4

帖子 willshou » 2008-12-28 20:46

我也是这个问题,解决不了阿!! :em20
yqw1122
帖子: 35
注册时间: 2009-08-15 22:45
送出感谢: 0
接收感谢: 0

Re: [问题]gpg: 找不到有效的 OpenPGP 数据

#5

帖子 yqw1122 » 2009-08-30 1:30

我也出现了这样的问题,不知道怎么解决呢
smile20088
帖子: 2
注册时间: 2007-10-22 10:14
送出感谢: 0
接收感谢: 0

Re: [问题]gpg: 找不到有效的 OpenPGP 数据

#6

帖子 smile20088 » 2010-12-08 9:28

同样的问题.... :em06
浏阳河
帖子: 1
注册时间: 2011-03-30 19:24
送出感谢: 0
接收感谢: 0

Re: [问题]gpg: 找不到有效的 OpenPGP 数据

#7

帖子 浏阳河 » 2011-04-26 14:50

:em11 是网络连接的问题 哈哈
mislay
帖子: 10
注册时间: 2014-12-14 23:03
系统: ubuntu 14.04
送出感谢: 0
接收感谢: 0

Re: [问题]gpg: 找不到有效的 OpenPGP 数据

#8

帖子 mislay » 2015-12-04 15:17

keyserver.ubuntu.com使用非标准的11371端口,而一般公司的防火墙都屏蔽掉了该端口,而允许标准的80端口。

所以可以以如下方式强行使用80端口添加软件源:

seagull@seagull-desktop:~$ sudo apt-key adv --recv-keys --keyserver hkp://keyserver.ubuntu.com:80 AAAD1D3563E5A736A4F561EE884D6308E89713C4

红色部分是你要请求的Key.

通过如上方式你可成功导入key.

代码: 全选

mislay@SisOS:~$ sudo add-apt-repository ppa:tiheum/equinox
[sudo] password for mislay: 
 
 更多信息: https://launchpad.net/~tiheum/+archive/ubuntu/equinox
按回车继续或者 Ctrl+c 取消添加

gpg: 钥匙环‘/tmp/tmpuhislie8/secring.gpg’已建立
gpg: 钥匙环‘/tmp/tmpuhislie8/pubring.gpg’已建立
gpg: 下载密钥‘4631BBEA’,从 hkp 服务器 keyserver.ubuntu.com
gpg: /tmp/tmpuhislie8/trustdb.gpg:建立了信任度数据库
gpg: 密钥 4631BBEA:公钥“Launchpad equinoxart”已导入
gpg: 合计被处理的数量:1
gpg:               已导入:1  (RSA: 1)
OK
回复

回到 “老旧版本支持”