当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 8 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : [已解决]硬盘挂载问题
帖子发表于 : 2008-05-11 17:43 

注册: 2007-12-17 11:53
帖子: 99
送出感谢: 0 次
接收感谢: 0 次
大大们 我有三个问题:
1 今天不知道怎么会 移动硬盘不能自动挂载

只能自己挂载
为什么呢 后来改了/etc/mtab文件
因为分四个区 所以改成了
/dev/sdb5 /home/markgoo/RemoveableDisk/sdb5 auto defaults 0 0
/dev/sdb6 /home/markgoo/RemoveableDisk/sdb6 auto defaults 0 0
/dev/sdb7 /home/markgoo/RemoveableDisk/sdb7 auto defaults 0 0
/dev/sdb8 /home/markgoo/RemoveableDisk/sdb8 auto defaults 0 0

但是挂载的时候不行,说已经挂载了 我想问题是出在设置了自动挂载了 该怎么改这个文件
2 还有 之前我只要一插上移动硬盘就能自动挂上去的 现在怎么不行了呢

3 还有 /etc/mtab和/etc/fstab有什么区别?


希望大大们告诉我 谢拉!!


最后由 markgoo 编辑于 2008-05-12 20:52,总共编辑了 1 次

页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2008-05-11 21:28 

注册: 2007-12-17 11:53
帖子: 99
送出感谢: 0 次
接收感谢: 0 次
有人回复吗?
或者把你们能够自动挂载移动硬盘的这个文件帖出来让我看看阿行阿,我感激不尽!!


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2008-05-11 21:31 

注册: 2007-10-03 0:22
帖子: 175
送出感谢: 0 次
接收感谢: 0 次
/etc/mtab是当前的挂载信息
/etc/fstab是设定文件。

所以你要修改也要修改/etc/fstab才对。


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2008-05-11 21:33 

注册: 2007-12-17 11:53
帖子: 99
送出感谢: 0 次
接收感谢: 0 次
也就是说我需要把这两个同步吗?
能贴一份你的这个配置吗?


页首
 用户资料  
 
5 楼 
 文章标题 :
帖子发表于 : 2008-05-11 21:36 

注册: 2007-10-03 0:22
帖子: 175
送出感谢: 0 次
接收感谢: 0 次
你只需要修改fstab就可以了,修改正确之后可以用mount -a 命令来挂载磁盘。
如果你不清除fstab的知识,建议你不要随便修改,如果你不知道mount命令的用法,建议你先执行man mount 看看相关帮助文档。

其实你的问题搜索一下论坛就可以得到解决方法,为什么不搜索一下??


页首
 用户资料  
 
6 楼 
 文章标题 :
帖子发表于 : 2008-05-11 21:50 

注册: 2007-12-17 11:53
帖子: 99
送出感谢: 0 次
接收感谢: 0 次
我已经搜索了很多了。。。
也看了N多帖子了。
但是还是有一些疑问。


页首
 用户资料  
 
7 楼 
 文章标题 :
帖子发表于 : 2008-05-12 12:27 

注册: 2007-12-17 11:53
帖子: 99
送出感谢: 0 次
接收感谢: 0 次
# /etc/fstab: static file system information.
#
# <file system> <mount point> <type> <options> <dump> <pass>
proc /proc proc defaults 0 0
/host/ubuntu/disks/root.disk / ext3 loop,errors=remount-ro 0 1
/host/ubuntu/disks/boot /boot none bind 0 0
/host/ubuntu/disks/swap.disk none swap loop,sw 0 0
/dev/scd0 /media/cdrom0 udf,iso9660 user,noauto,exec,utf8 0 0


这是我另一台机器用WUBI装的系统的/etc/fstab,这个能够自动装载移动硬盘,可是没有看见配置啊
这是怎么回事呢?


页首
 用户资料  
 
8 楼 
 文章标题 :
帖子发表于 : 2008-05-12 20:53 

注册: 2007-12-17 11:53
帖子: 99
送出感谢: 0 次
接收感谢: 0 次
现在好了 重新改了下文件

proc /proc proc defaults 0 0
UUID=7047a92c-c43c-4c2f-a1c5-456ead8b11d2 / ext3 relatime,errors=remount-ro 0 1
UUID=995b78c7-08d6-44ba-8342-1cf2f6857900 /boot ext3 relatime 0 2
UUID=a919302e-b15f-4df1-8696-305e6094da71 none swap sw 0 0
/dev/scd0 /media/cdrom0 udf,iso9660 user,noauto,exec,utf8 0 0
/dev/sda4 /home/markgoo/MyDisk ext3 defaults 0 0


现在是这样,只剩下本机的磁盘什么的,并没有出现移动硬盘的属性设置/
我想可能是
proc /proc proc defaults 0 0
这句话起的作用?

有大大知道原因吗?为什么我没有添加配置,反而能够自动加载了呢?


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 8 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 4 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译