[问题]为何在ubuntu下安装tar.gz或则tar.bz2的文件老是没法make?

为当前最终发行版之前的所有版本提供支持
回复
头像
古道风
帖子: 21
注册时间: 2008-05-13 18:03
来自: 杭州
送出感谢: 0
接收感谢: 0
联系:

[问题]为何在ubuntu下安装tar.gz或则tar.bz2的文件老是没法make?

#1

帖子 古道风 » 2008-05-13 18:11

安装了好几个了,都是这个原因,现在我的系统所有的东西都依赖deb或者系统的自带的安装。
今天下载了gphpedit (还没按上)、nvu(后来这个通过又下载了deb双击安装的)
他提示的代码如下:
头像
古道风
帖子: 21
注册时间: 2008-05-13 18:03
来自: 杭州
送出感谢: 0
接收感谢: 0
联系:

#2

帖子 古道风 » 2008-05-13 18:15

phper@phper-desktop:~/soft/gphpedit-0.9.91$ ./configure
checking for a BSD-compatible install... /usr/bin/install -c
checking whether build environment is sane... yes
checking for gawk... no
checking for mawk... mawk
checking whether make sets $(MAKE)... yes
checking whether to enable maintainer-specific portions of Makefiles... no
checking for gcc... gcc
checking for C compiler default output file name... configure: error: C compiler cannot create executables
See `config.log' for more details.

是不是这里错了,但不知道啥意思 :? ,新手,大家多多见谅

phper@phper-desktop:~/soft/gphpedit-0.9.91$ make
make: *** 没有指明目标并且找不到 makefile。 停止。
头像
coolwin
帖子: 271
注册时间: 2008-03-17 17:47
送出感谢: 0
接收感谢: 0

#3

帖子 coolwin » 2008-05-13 19:06

./configure的问题

错误: C compiler cannot create executables
原因:
解决:sudo apt-get gcc libc6-dev

错误:checking for C compiler default output... configure: error: C compiler cannot create executables
原因:
解决:sudo apt-get install libc6-dev

错误:configure: error: C++ preprocessor "/lib/cpp" fails sanity check
原因:gcc的组件没装全
解决:apt-get install build-essential

错误: Can't find X includes. Please check your installation and add the correct paths!
原因:没有X的包含文件
解决:安装xlibs-dev即可

错误: Qt (>= Qt 3.0) (headers and libraries) not found. Please check your installation!
原因:查找提供qt的lib&&headers的软件包,并安装之
解决:apt-get install libqt3-headers libqt3-mt-dev

错误:in the prefix, you've chosen, are no KDE headers installed. This will fail.
So, check this please and use another prefix!
原因:install a KDE application in a Gnome environment。
解决:which basically means its going to want to install a lot of KDE specific packages to work. This 'configure:error'
is due to it expecting you to be running KDE and again refers to some 'headers'.
sudo apt-get update
sudo apt-get install kdelibs4-dev kdelibs4c2a

错误:./admin/cvs.sh: 585: autoconf: not found
原因:
解决:apt-get install autoconf

错误: *** GTK >= 2.4.0 not installed! ***
原因:没装GTK
解决:apt-get build-dep gedit

错误:heching for gtk-config... no
checking for GTK - version = 1.2.0... no
*** The gtk-config script installed by GTK could not be found
*** If GTK was installed in PREFIX, make sure PREFIX/bin is in
*** your path, or set the GTK_CONFIG enviroment variable to the
*** full path to gtk-config.
configure: error: Cannot find GTK: Is gtk-config in path?
原因:
解决:sudo apt-get install libgtk1.2-dev

问题:eclipse中encoding不支持中文
解决:编辑/var/lib/locales/supported.d/local,加一行zh_CN.GBK GBK,执行sudo locale-gen

错误:gnome.h: No such file or directory

错误: No package 'libpanelapplet-2.0' found
原因:
解决:sudo apt-get install gnome-panel

问题:eva不弹出输入法
解决:sudo apt-get install scim-qtimm

问题:No package 'gtk+-2.0' found
No package 'gtksourceview-1.0' found
No package 'libgnomeui-2.0' found
No package 'libglade-2.0' found
No package 'libgnomeprintui-2.2' found
解决:sudo apt-get install libgtk2.0-dev libgtksourceview-dev libgnomeui-dev libglade2-dev libgnomeprint2.2-dev

问题:No package 'libpanelapplet-2.0' found
解决:sudo apt-get install libpanelappletmm-2.6-dev
dbzhang800
帖子: 3182
注册时间: 2006-03-10 15:10
来自: xi'an China
送出感谢: 0
接收感谢: 2 次
联系:

#4

帖子 dbzhang800 » 2008-05-13 19:14

:em38 猫头 好有耐心啊
头像
coolwin
帖子: 271
注册时间: 2008-03-17 17:47
送出感谢: 0
接收感谢: 0

#5

帖子 coolwin » 2008-05-13 19:28

是兔子
头像
古道风
帖子: 21
注册时间: 2008-05-13 18:03
来自: 杭州
送出感谢: 0
接收感谢: 0
联系:

#6

帖子 古道风 » 2008-05-13 19:47

谢谢 coolwin

再若若的问一下,我看了你刚才的回答,知道了原因,
那我可以不可以这样理解,是不是因为上面的原因,我安装这样的所有软件是不是都会出现这样的情况?

我说的是比如tar.gz tar.bz2等软件

我隐隐约约好像记得很早以前老是这样的情况,一直没法安装,但是偶尔好像成功过一次,那个软件名字叫XXAMP,是个web服务器集成软件(不过当时在在redhad下)

不需要编译的,比如说rpm 的应该没有事吧
头像
coolwin
帖子: 271
注册时间: 2008-03-17 17:47
送出感谢: 0
接收感谢: 0

#7

帖子 coolwin » 2008-05-13 20:09

第一个问题不是绝对的,因为并不是所有的软件都需要那些包的。
你之前安的那个软件正好是不需要这些包。

deb 和rpm包安装都比较方便了,deb包直接安装就可以。
rpm包在安装了alien以后就可以将rpm变成deb包安装了。
头像
古道风
帖子: 21
注册时间: 2008-05-13 18:03
来自: 杭州
送出感谢: 0
接收感谢: 0
联系:

#8

帖子 古道风 » 2008-05-13 20:33

好了,谢谢coolwin 的回答,明白了


结贴!!!
头像
古道风
帖子: 21
注册时间: 2008-05-13 18:03
来自: 杭州
送出感谢: 0
接收感谢: 0
联系:

#9

帖子 古道风 » 2008-05-13 20:34

:lol: :lol: :lol:
回复

回到 “老旧版本支持”