[问题]疯了!从没有任何一次安装成功过.gz格式软件过!

为当前最终发行版之前的所有版本提供支持
夜鸣剑
帖子: 20
注册时间: 2008-05-14 17:34
送出感谢: 0
接收感谢: 0

[问题]疯了!从没有任何一次安装成功过.gz格式软件过!

#1

帖子 夜鸣剑 » 2008-05-14 17:57

阅读过很多资料了~~不要说我直接上来提问,实在是山穷水尽。

这种事情在达人看来简直不值一提,但是我不知道为什么我无一成功。

在ubuntu下,.gz这样以源代码形式发布的软件,只需要编译安装即可,过程就是三板斧

./configure
make
sudo make install

make install前面加sudo是因为需要管理员权限。

这都OK吧?

我安装软件的时候,编译都没有问题,但是到了make的时候,无一通过,基本上说:

make: *** No targets specified and no makefile found. Stop.

或者另外一句,大意是没有rule那样的。

尝试过几十种软件了(都是源里无法获取的),没有一个成功。望达人教我!!

附上comple的结果,以安装pango-1.2.0为例,也许问题出在c语言环境上。

checking for a BSD-compatible install... /usr/bin/install -c
checking whether build environment is sane... yes
checking whether make sets ${MAKE}... yes
checking for working aclocal-1.4... missing
checking for working autoconf... missing
checking for working automake-1.4... missing
checking for working autoheader... missing
checking for working makeinfo... missing
checking for gcc... gcc
checking for C compiler default output... configure: error: C compiler cannot create executables
check `config.log' for details.
头像
syrano
帖子: 4313
注册时间: 2007-10-06 18:40
送出感谢: 0
接收感谢: 5 次

#2

帖子 syrano » 2008-05-14 18:23


sudo aptitude install 软件名
夜鸣剑
帖子: 20
注册时间: 2008-05-14 17:34
送出感谢: 0
接收感谢: 0

#3

帖子 夜鸣剑 » 2008-05-14 20:28

谢谢楼上热心回答,但是并不是答案啊。

总有软件不被官方源支持的,比如大名鼎鼎的vmware,你得自己去安装。

所以,有谁能告诉我,我安装源代码软件出了什么问题?
头像
leeaman
帖子: 30702
注册时间: 2007-02-02 18:14
系统: debian sid
送出感谢: 1 次
接收感谢: 23 次

#4

帖子 leeaman » 2008-05-14 20:33

认真看readme.txt
醉了星星,醉月亮●●●●●The Long Way To Go(*^_^*)
夜鸣剑
帖子: 20
注册时间: 2008-05-14 17:34
送出感谢: 0
接收感谢: 0

#5

帖子 夜鸣剑 » 2008-05-14 20:44

楼上的,的确,这话在网上各大帖子都是这么讲的。

我看了,虽然我确信,肯定是我自己哪出了毛病啊,可是的确一看再看一试再试却没有成功。

所以,看来并没有什么特别的新手很容易犯的错误? 安装.gz文件大家的确也都是解压了之后那三板斧就都ok了?

如果的确是这样,那我就不能指望一个特别的答案了。
头像
leeaman
帖子: 30702
注册时间: 2007-02-02 18:14
系统: debian sid
送出感谢: 1 次
接收感谢: 23 次

#6

帖子 leeaman » 2008-05-14 20:50

是不是dev包没有装呢?
醉了星星,醉月亮●●●●●The Long Way To Go(*^_^*)
fanguanqun
帖子: 21
注册时间: 2008-04-15 15:37
送出感谢: 0
接收感谢: 0

#7

帖子 fanguanqun » 2008-05-14 20:52

楼主,你在ubuntu里问怎么编译安装软件,是问错地方了,这里的人只会告诉你改用apt-get。
另外和你说下,如果你想学编译源码最好还是改用kde的linux版本,gonme的软件太少了。其实很多软件只要那三板斧就可以了,可在gonme上就很困难。缺qt啊,缺kde什么的比较普遍。
头像
xiooli
帖子: 6956
注册时间: 2007-11-19 21:51
来自: 成都
送出感谢: 0
接收感谢: 3 次
联系:

#8

帖子 xiooli » 2008-05-14 20:54

ls很误解人啊。lz应该的某些库没有装全。
sirxenofex
帖子: 204
注册时间: 2008-01-07 16:39
送出感谢: 0
接收感谢: 0

#9

帖子 sirxenofex » 2008-05-14 20:56

多学习啊,多留心啊,其实答案超明显,你就没看出来。configure脚本检测了编译需要的工具,你把那几个missing的用apt-get装上就行了。或者看看置顶,看看如何安装编译环境。
夜鸣剑
帖子: 20
注册时间: 2008-05-14 17:34
送出感谢: 0
接收感谢: 0

#10

帖子 夜鸣剑 » 2008-05-14 21:00

谢谢各位楼上。

如果说gnome桌面不好,那么ubuntu支持kde么? 应该也可以另装kde的吧?我不很清楚这个了,不过不想换到别的linux平台去,我挺喜欢ubuntu的。这些年试用了不少版本,没有一个能让我有耐心多去用用的。

如果是如楼上所说某些库没有装,我该去什么地方查少了什么东西啊。
头像
hethe
帖子: 3666
注册时间: 2005-08-01 9:14
送出感谢: 0
接收感谢: 0

#11

帖子 hethe » 2008-05-14 21:02

checking for working aclocal-1.4... missing
checking for working autoconf... missing
checking for working automake-1.4... missing
checking for working autoheader... missing
checking for working makeinfo... missing
Gedanken ohne Inhalt sind leer .Anschauungen ohne Begriffe sind blind.
夜鸣剑
帖子: 20
注册时间: 2008-05-14 17:34
送出感谢: 0
接收感谢: 0

#12

帖子 夜鸣剑 » 2008-05-14 21:25

呵呵,谢楼上,我现在尝试安装上述东西下看看
夜鸣剑
帖子: 20
注册时间: 2008-05-14 17:34
送出感谢: 0
接收感谢: 0

#13

帖子 夜鸣剑 » 2008-05-14 21:58

很不幸啊。

atp-get得到autoconf,但是却找不到automake, aclocal和makeinfo(如果他们的确是包的话)。

然后再./configure,得到的结果除了autoconf和autoheader两处提示找到之外,另外三处依然是missing,当然,还是不能make。

所以我去下载了automake,还是.gz格式!!(我觉得这就是一个循环)

然后我./configure,然后我make,然后我make install,每个都出来一长串一长串的屏幕提示(幸好没有stop了)。但是,然后我命令行运行automake(虽然不知这样可行否),结果是没有反应。

然后我继续尝试安装pango,编译的时候,居然还是提示没有找到automake!!

这也许说明,我的automake并没有安装成功。

那么怎么版呢? 我来问怎么安装源代码,这里朋友提醒我缺少库,我去安装缺少的东西,结果这缺少的东西依然得用源代码安装!
头像
windwiny
帖子: 2254
注册时间: 2007-03-13 17:26
送出感谢: 0
接收感谢: 1 次

#14

帖子 windwiny » 2008-05-15 9:10

。。难道装完一个包你不会再运行一下试试吗?


天, 新手就用新立得,, 有些包比如 automake 包名有带版本号的 automake1.9
goodayoo
帖子: 87
注册时间: 2007-10-23 11:19
送出感谢: 0
接收感谢: 0

#15

帖子 goodayoo » 2008-05-15 9:30

configue后提示Missing的东西,用APT-get一个个安装完就可以MAKE了。

其实编译安装又费时又费力,能用APT-GET就尽量用吧。卸载也方便。

最后,Ubuntu下可以直接装KDE环境,我就是双环境,在启动时选择会话就可以进入Gnome或KDE4了,很方便。
回复

回到 “老旧版本支持”