当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 5 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : Ubuntu 8.04 在从2.6.24-16更新到2.6.24-17后出现的问题
帖子发表于 : 2008-05-15 10:03 

注册: 2008-05-15 9:59
帖子: 3
送出感谢: 0 次
接收感谢: 0 次
安装之后Grub中出现两4个选项,16两个,17两个
进入17后会进入Busybox,16里面提示我有一个软件包出错如下:

bean@bean-desktop:~$ sudo apt-get install supertuxkart
[sudo] password for bean:
正在读取软件包列表... 完成
正在分析软件包的依赖关系树
读取状态信息... 完成
您可能需要运行“apt-get -f install”来纠正下列错误:
下列的软件包有不能满足的依赖关系:
linux-ubuntu-modules-2.6.24-17-generic: 依赖: linux-image-2.6.24-17-generic 但是它将不会被安装
supertuxkart: 依赖: plib1.8.4c2 (>= 1.8.4-7) 但是它将不会被安装
依赖: supertuxkart-data (= 0.4-1) 但是它将不会被安装
E: 有未能满足的依赖关系。请尝试不指明软件包的名字来运行“apt-get -f install”(也可以指定一个解决办法)。
bean@bean-desktop:~$ apt-get -f install
E: 无法打开锁文件 /var/lib/dpkg/lock - open (13 Permission denied)
E: Unable to lock the administration directory (/var/lib/dpkg/), are you root?
bean@bean-desktop:~$ sudo apt-get -f install
正在读取软件包列表... 完成
正在分析软件包的依赖关系树
读取状态信息... 完成
正在更正依赖关系... 完成
将会安装下列额外的软件包:
linux-image-2.6.24-17-generic
建议安装的软件包:
linux-doc-2.6.24 linux-source-2.6.24
下列【新】软件包将被安装:
linux-image-2.6.24-17-generic
共升级了 0 个软件包,新安装了 1 个软件包,要卸载 0 个软件包,有 73 个软件未被升级。
有 1 个软件包没有被完全安装或卸载。
需要下载 0B/18.4MB 的软件包。
操作完成后,会消耗掉 61.8MB 的额外磁盘空间。
您希望继续执行吗?[Y/n]y
(正在读取数据库 ... 系统当前总共安装有 133971 个文件和目录。)
正在解压缩 linux-image-2.6.24-17-generic (从 .../linux-image-2.6.24-17-generic_2.6.24-17.31_i386.deb) ...
Done.
dpkg:处理 /var/cache/apt/archives/linux-image-2.6.24-17-generic_2.6.24-17.31_i386.deb (--unpack)时出错:
无法在安装新的版本前,为“./boot/vmlinuz-2.6.24-17-generic”做一个符号链接备份: 操作不允许
dpkg-deb: 子进程 paste 被信号(Broken pipe)终止了
Running postrm hook script /sbin/update-grub.
Searching for GRUB installation directory ... found: /boot/grub
Searching for default file ... found: /boot/grub/default
Testing for an existing GRUB menu.lst file ... found: /boot/grub/menu.lst
Searching for splash image ... none found, skipping ...
Found kernel: /boot/vmlinuz-2.6.24-17-generic
Found kernel: /boot/vmlinuz-2.6.24-16-generic
Found kernel: /boot/memtest86+.bin
Updating /boot/grub/menu.lst ... done

在处理时有错误发生:
/var/cache/apt/archives/linux-image-2.6.24-17-generic_2.6.24-17.31_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
bean@bean-desktop:~$ sudo apt-get install
正在读取软件包列表... 完成
正在分析软件包的依赖关系树
读取状态信息... 完成
您也许需要运行“apt-get -f install”来纠正上面的错误。
下列的软件包有不能满足的依赖关系:
linux-ubuntu-modules-2.6.24-17-generic: 依赖: linux-image-2.6.24-17-generic 但是它还没有被安装
E: 不能满足依赖关系。不妨试一下 -f 选项。


页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2008-05-16 15:22 
头像

注册: 2007-03-15 16:58
帖子: 2796
地址: 湖北武汉
送出感谢: 2
接收感谢: 4
输入命令


apt-get -f install


是不是你没有更新完就重启了?!


_________________
引用:


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2008-05-16 18:06 

注册: 2008-05-15 9:59
帖子: 3
送出感谢: 0 次
接收感谢: 0 次
没有阿
我执行了apt-get -f install
但没效果
错误在原帖里就有


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2008-05-16 20:26 

注册: 2008-04-30 21:40
帖子: 431
送出感谢: 0 次
接收感谢: 0 次
侥幸,我昨夜升级的,网速刚好很快,升级顺利,没有发现大的升级错误。。。


但发现:
菜单上(系统所有)少了好几个程序,比如系统自带的磁盘分区管理软件(我正要用它,发现没有了)。

还有个问题:
在我昨天将U的16版升级到17版后,出现了不能挂载本硬盘其他NTFS格式分区(升级前是可以的)的情况!但另一个独立硬盘的NTFS格式分区却可以正常挂载、卸载。
用ntfs-config来管理,用户下可以看到未挂载分区、但不能加载!提示需要root用户。进入root用户,又发现想挂的分区都不见了!

美中不足,还没体验到17的优点,就先来个下马威。


页首
 用户资料  
 
5 楼 
 文章标题 :
帖子发表于 : 2008-05-17 7:42 

注册: 2008-05-15 9:59
帖子: 3
送出感谢: 0 次
接收感谢: 0 次
我都要绝望啦!现在什么都不能apt-get 请哪位帮帮忙


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 5 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 4 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译