关于fluent软件的问题

为当前最终发行版之前的所有版本提供支持
回复
sharko
帖子: 7
注册时间: 2007-10-18 10:55
来自: 重庆
送出感谢: 0
接收感谢: 0

关于fluent软件的问题

#1

帖子 sharko » 2008-05-15 17:09

各位大虾,我在8。04上安装了fluent 和前处理软件gambit,但启动gambit失败,这是什么问题,怎么解决?启动提示如下:
LANG zh_CN.UTF-8 changed temporarily to en_CA for gambit use.
Starting /usr/local/Fluent.Inc/gambit2.3.16/lnx86/gambit ...
Gambit build SP2006033020.
Warning: locale not supported by C library, locale unchanged
Locking assertion failure. Backtrace:
#0 /usr/lib/libxcb-xlib.so.0 [0xb28ee767]
#1 /usr/lib/libxcb-xlib.so.0(xcb_xlib_unlock+0x31) [0xb28ee8b1]
#2 /usr/lib/libX11.so.6(_XReply+0xfd) [0xb2ba31bd]
#3 /usr/local/Fluent.Inc/gambit2.3.16/lnx86/gambit [0x9a650a9]
#4 /usr/local/Fluent.Inc/gambit2.3.16/lnx86/gambit [0x9a6547a]
#5 /usr/local/Fluent.Inc/gambit2.3.16/lnx86/gambit [0x9a63be7]
#6 /usr/local/Fluent.Inc/gambit2.3.16/lnx86/gambit [0x9a642ab]
#7 /usr/local/Fluent.Inc/gambit2.3.16/lnx86/gambit(vgl_OpenGLDevBestVisualX+0x1f7) [0x99b7305]
#8 /usr/local/Fluent.Inc/gambit2.3.16/lnx86/BX.so(vgl_visual+0x2a6) [0xb6aba04a]
#9 /usr/local/Fluent.Inc/gambit2.3.16/lnx86/G.so(_Z16cpp_teleuse_mainiPPc+0x31a) [0xb61c7dd2]
#10 /usr/local/Fluent.Inc/gambit2.3.16/lnx86/G.so(teleuse_main+0x1e) [0xb614b82a]
#11 /usr/local/Fluent.Inc/gambit2.3.16/lnx86/BX.so(motif_init+0xfb) [0xb6ab9b33]
#12 /usr/local/Fluent.Inc/gambit2.3.16/lnx86/gambit(_Z17local_gambit_mainiPPc+0x2a6) [0x808c972]
#13 /usr/local/Fluent.Inc/gambit2.3.16/lnx86/gambit [0x808d8b3]
#14 /lib/tls/i686/cmov/libc.so.6(__libc_start_main+0xe0) [0xb292b450]
#15 /usr/local/Fluent.Inc/gambit2.3.16/lnx86/gambit(XMapRaised+0x31) [0x8072bd1]
Locking assertion failure. Backtrace:
#0 /usr/lib/libxcb-xlib.so.0 [0xb28ee767]
#1 /usr/lib/libxcb-xlib.so.0(xcb_xlib_lock+0x2e) [0xb28ee81e]
#2 /usr/lib/libX11.so.6 [0xb2ba2518]
#3 /usr/lib/libX11.so.6(XGetVisualInfo+0x26) [0xb2b990a6]
#4 /usr/local/Fluent.Inc/gambit2.3.16/lnx86/gambit [0x9a647ef]
#5 /usr/local/Fluent.Inc/gambit2.3.16/lnx86/gambit(vgl_OpenGLDevBestVisualX+0x1f7) [0x99b7305]
#6 /usr/local/Fluent.Inc/gambit2.3.16/lnx86/BX.so(vgl_visual+0x2a6) [0xb6aba04a]
#7 /usr/local/Fluent.Inc/gambit2.3.16/lnx86/G.so(_Z16cpp_teleuse_mainiPPc+0x31a) [0xb61c7dd2]
#8 /usr/local/Fluent.Inc/gambit2.3.16/lnx86/G.so(teleuse_main+0x1e) [0xb614b82a]
#9 /usr/local/Fluent.Inc/gambit2.3.16/lnx86/BX.so(motif_init+0xfb) [0xb6ab9b33]
#10 /usr/local/Fluent.Inc/gambit2.3.16/lnx86/gambit(_Z17local_gambit_mainiPPc+0x2a6) [0x808c972]
#11 /usr/local/Fluent.Inc/gambit2.3.16/lnx86/gambit [0x808d8b3]
#12 /lib/tls/i686/cmov/libc.so.6(__libc_start_main+0xe0) [0xb292b450]
#13 /usr/local/Fluent.Inc/gambit2.3.16/lnx86/gambit(XMapRaised+0x31) [0x8072bd1]
gambit: ../../src/xcb_lock.c:77: _XGetXCBBuffer: Assertion `((int) ((xcb_req) - (dpy->request)) >= 0)' failed.

Received exception: SIGABRT (abort signal)

Please send the GAMBIT.9111/jou and GAMBIT.9111/trn files to your local
Fluent office or distributor. Also send a message including any
relevant errors or warnings you see above in this window. You may
wish to delete the temporary directory GAMBIT.9111 after sending the
above files.
ERROR: Please retain a copy of the GAMBIT.9111/jou, GAMBIT.9111/trn, and
GAMBIT.9111/*.dbs files, any imported geometry and any relevant
errors or warnings you see above in this window and contact
support at your local Fluent office or distributor.
忽略
sharko
帖子: 7
注册时间: 2007-10-18 10:55
来自: 重庆
送出感谢: 0
接收感谢: 0

#2

帖子 sharko » 2008-05-15 18:40

哪位大侠给解答一下啊,很郁闷~~~~
头像
fanqo
帖子: 67
注册时间: 2007-10-03 9:40
来自: 山东济宁
送出感谢: 0
接收感谢: 0

#3

帖子 fanqo » 2008-05-15 23:19

恩,我也是同样的问题,我把系统默认语言换成英文的也没用,还是一样gambit有问题。
holysword
帖子: 4
注册时间: 2007-06-07 12:51
送出感谢: 0
接收感谢: 0

#4

帖子 holysword » 2008-05-29 13:29

sudo ./gambit -x11
zhuge000
帖子: 101
注册时间: 2008-04-18 17:06
送出感谢: 0
接收感谢: 0

#5

帖子 zhuge000 » 2008-05-29 13:40

请问楼主你的fluent是在哪里下的,verycd上么?
我装的是这个,运行不了……

若不是在verycd上下的那个,给个地址好么?
sharko
帖子: 7
注册时间: 2007-10-18 10:55
来自: 重庆
送出感谢: 0
接收感谢: 0

#6

帖子 sharko » 2008-06-10 9:40

holysword 写了:sudo ./gambit -x11


按这位前辈说明运行确实可以,只要在gambit后加-x11就能运行起,前辈能否解释下这句的作用,原理啊
回复

回到 “老旧版本支持”