UPDATE MANAGER运行不了/添加/删除软件也运行不了-UBUNTU7.04

为当前最终发行版之前的所有版本提供支持
回复
ginbnag
帖子: 17
注册时间: 2007-09-13 21:56
送出感谢: 0
接收感谢: 0

UPDATE MANAGER运行不了/添加/删除软件也运行不了-UBUNTU7.04

#1

帖子 ginbnag » 2008-05-26 12:11

5/22, 电脑启动时出错, 搜索帮助,有人提议直接 FSCK. 后可以开启电脑

今天想装个软件,发现 添加/删除软件功能用不了了
然后想更新一下系统吧, 又发现 UPDATE MANAGER运行不了, 双击没用,不出现任何图标

网上搜寻帮助, MS没有人遇到过这种情况

有人说 sudo aptitude install update-manager-core

结果如下:
fiona@fiona:~$ sudo aptitude install update-manager-core
正在读取软件包列表... 完成
正在分析软件包的依赖关系树
Reading state information... 完成
Reading extended state information
Initializing package states... 完成
Building tag database... 完成
No packages will be installed, upgraded, or removed.
0 packages upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Need to get 0B of archives. After unpacking 0B will be used.
Writing extended state information... 完成
/bin/sh: /usr/sbin/dpkg-preconfigure: Permission denied
正在设置 libssl0.9.8 (0.9.8c-4ubuntu0.3) ...
Can't locate Debconf/Db.pm in @INC (@INC contains: /etc/perl /usr/local/lib/perl/5.8.8 /usr/local/share/perl/5.8.8 /usr/lib/perl5 /usr/share/perl5 /usr/lib/perl/5.8 /usr/share/perl/5.8 /usr/local/lib/site_perl .) at /usr/share/debconf/frontend line 6.
BEGIN failed--compilation aborted at /usr/share/debconf/frontend line 6.
dpkg:处理 libssl0.9.8 (--configure)时出错:
子进程·post-installation script·返回了错误号·2
dpkg:依赖关系问题使得 openssh-client 的配置工作不能继续:
openssh-client 依赖于 libssl0.9.8 (>= 0.9.8c-1);然而:
软件包 libssl0.9.8 还没有被配置。
openssh-client 依赖于 libssl0.9.8 (>= 0.9.8c-4ubuntu0.3);然而:
软件包 libssl0.9.8 还没有被配置。
dpkg:处理 openssh-client (--configure)时出错:
依赖关系问题 - 仍未被配置
dpkg:依赖关系问题使得 openssl 的配置工作不能继续:
openssl 依赖于 libssl0.9.8 (>= 0.9.8c-1);然而:
软件包 libssl0.9.8 还没有被配置。
dpkg:处理 openssl (--configure)时出错:
依赖关系问题 - 仍未被配置
dpkg:依赖关系问题使得 ca-certificates 的配置工作不能继续:
ca-certificates 依赖于 openssl;然而:
软件包 openssl 还没有被配置。
dpkg:处理 ca-certificates (--configure)时出错:
依赖关系问题 - 仍未被配置
正在设置 cupsys (1.2.8-0ubuntu8.4) ...
Can't locate Debconf/Db.pm in @INC (@INC contains: /etc/perl /usr/local/lib/perl/5.8.8 /usr/local/share/perl/5.8.8 /usr/lib/perl5 /usr/share/perl5 /usr/lib/perl/5.8 /usr/share/perl/5.8 /usr/local/lib/site_perl .) at /usr/share/debconf/frontend line 6.
BEGIN failed--compilation aborted at /usr/share/debconf/frontend line 6.
dpkg:处理 cupsys (--configure)时出错:
子进程·post-installation script·返回了错误号·2
dpkg:依赖关系问题使得 ssh-askpass-gnome 的配置工作不能继续:
ssh-askpass-gnome 依赖于 openssh-client | ssh (>= 1:1.2pre7-4) | ssh-krb5;然而:
软件包 openssh-client 还没有被配置。
未曾安装软件包“ssh”。
未曾安装软件包“ssh-krb5”。
dpkg:处理 ssh-askpass-gnome (--configure)时出错:
依赖关系问题 - 仍未被配置
正在设置 cupsys-bsd (1.2.8-0ubuntu8.4) ...
Can't locate Debconf/Db.pm in @INC (@INC contains: /etc/perl /usr/local/lib/perl/5.8.8 /usr/local/share/perl/5.8.8 /usr/lib/perl5 /usr/share/perl5 /usr/lib/perl/5.8 /usr/share/perl/5.8 /usr/local/lib/site_perl .) at /usr/share/debconf/frontend line 6.
BEGIN failed--compilation aborted at /usr/share/debconf/frontend line 6.
dpkg:处理 cupsys-bsd (--configure)时出错:
子进程·post-installation script·返回了错误号·2
在处理时有错误发生:
libssl0.9.8
openssh-client
openssl
ca-certificates
cupsys
ssh-askpass-gnome
cupsys-bsd
E: Sub-process /usr/bin/dpkg returned an error code (1)
A package failed to install. Trying to recover:
正在设置 libssl0.9.8 (0.9.8c-4ubuntu0.3) ...
Can't locate Debconf/Db.pm in @INC (@INC contains: /etc/perl /usr/local/lib/perl/5.8.8 /usr/local/share/perl/5.8.8 /usr/lib/perl5 /usr/share/perl5 /usr/lib/perl/5.8 /usr/share/perl/5.8 /usr/local/lib/site_perl .) at /usr/share/debconf/frontend line 6.
BEGIN failed--compilation aborted at /usr/share/debconf/frontend line 6.
dpkg:处理 libssl0.9.8 (--configure)时出错:
子进程·post-installation script·返回了错误号·2
dpkg:依赖关系问题使得 openssl 的配置工作不能继续:
openssl 依赖于 libssl0.9.8 (>= 0.9.8c-1);然而:
软件包 libssl0.9.8 还没有被配置。
dpkg:处理 openssl (--configure)时出错:
依赖关系问题 - 仍未被配置
正在设置 cupsys-bsd (1.2.8-0ubuntu8.4) ...
Can't locate Debconf/Db.pm in @INC (@INC contains: /etc/perl /usr/local/lib/perl/5.8.8 /usr/local/share/perl/5.8.8 /usr/lib/perl5 /usr/share/perl5 /usr/lib/perl/5.8 /usr/share/perl/5.8 /usr/local/lib/site_perl .) at /usr/share/debconf/frontend line 6.
BEGIN failed--compilation aborted at /usr/share/debconf/frontend line 6.
dpkg:处理 cupsys-bsd (--configure)时出错:
子进程·post-installation script·返回了错误号·2
正在设置 cupsys (1.2.8-0ubuntu8.4) ...
Can't locate Debconf/Db.pm in @INC (@INC contains: /etc/perl /usr/local/lib/perl/5.8.8 /usr/local/share/perl/5.8.8 /usr/lib/perl5 /usr/share/perl5 /usr/lib/perl/5.8 /usr/share/perl/5.8 /usr/local/lib/site_perl .) at /usr/share/debconf/frontend line 6.
BEGIN failed--compilation aborted at /usr/share/debconf/frontend line 6.
dpkg:处理 cupsys (--configure)时出错:
子进程·post-installation script·返回了错误号·2
dpkg:依赖关系问题使得 openssh-client 的配置工作不能继续:
openssh-client 依赖于 libssl0.9.8 (>= 0.9.8c-1);然而:
软件包 libssl0.9.8 还没有被配置。
openssh-client 依赖于 libssl0.9.8 (>= 0.9.8c-4ubuntu0.3);然而:
软件包 libssl0.9.8 还没有被配置。
dpkg:处理 openssh-client (--configure)时出错:
依赖关系问题 - 仍未被配置
dpkg:依赖关系问题使得 ca-certificates 的配置工作不能继续:
ca-certificates 依赖于 openssl;然而:
软件包 openssl 还没有被配置。
dpkg:处理 ca-certificates (--configure)时出错:
依赖关系问题 - 仍未被配置
dpkg:依赖关系问题使得 ssh-askpass-gnome 的配置工作不能继续:
ssh-askpass-gnome 依赖于 openssh-client | ssh (>= 1:1.2pre7-4) | ssh-krb5;然而:
软件包 openssh-client 还没有被配置。
未曾安装软件包“ssh”。
未曾安装软件包“ssh-krb5”。
dpkg:处理 ssh-askpass-gnome (--configure)时出错:
依赖关系问题 - 仍未被配置
在处理时有错误发生:
libssl0.9.8
openssl
cupsys-bsd
cupsys
openssh-client
ca-certificates
ssh-askpass-gnome

~~~~~~~~~~~~
请大侠帮忙看看到底出了什么问题?
实在是不懂
谢谢啦~~~~~~~~~~
头像
BigSnake.NET
帖子: 12522
注册时间: 2006-07-02 11:16
来自: 廣州
送出感谢: 0
接收感谢: 7 次
联系:

#2

帖子 BigSnake.NET » 2008-05-26 12:12

代码: 全选

sudo chmod a+rx /usr/sbin/dpkg-preconfigure
^_^ ~~~
要理解递归,首先要理解递归。

地球人都知道,理论上,理论跟实际是没有差别的,但实际上,理论跟实际的差别是相当大滴。
头像
cnkilior
论坛版主
帖子: 4979
注册时间: 2007-08-05 17:40
送出感谢: 0
接收感谢: 5 次

#3

帖子 cnkilior » 2008-05-26 12:25

/bin/sh: /usr/sbin/dpkg-preconfigure: Permission denied

这是错误的关键!
ginbnag
帖子: 17
注册时间: 2007-09-13 21:56
送出感谢: 0
接收感谢: 0

#4

帖子 ginbnag » 2008-05-27 10:50

BigSnake.NET 写了:

代码: 全选

sudo chmod a+rx /usr/sbin/dpkg-preconfigure


用此指令, 沒有任何顯示.
請問此指令是用來做什麽的啊?
對LINUX系統真的是一無所知
只因老板讓用UBUNTU系統.....唉
很多時候出了故障,只能到網上搜索恢復指令
知其然不知其所以然啊

請高人再指點指點

萬分焦慮ING.........

謝謝~~~謝謝~~~
ginbnag
帖子: 17
注册时间: 2007-09-13 21:56
送出感谢: 0
接收感谢: 0

#5

帖子 ginbnag » 2008-05-27 10:54

cnkilior 写了:/bin/sh: /usr/sbin/dpkg-preconfigure: Permission denied

这是错误的关键!


嗯...........怎麽修復這錯誤啊

Permission denied........怎麽又被拒了捏???

請高人指點~~~

謝謝~!~~~~
ginbnag
帖子: 17
注册时间: 2007-09-13 21:56
送出感谢: 0
接收感谢: 0

#6

帖子 ginbnag » 2008-05-27 10:58

謝謝上面朋友的回復

不知 UPDATE MANAGER更新管理器是否可重新安裝? (可千萬不要重裝系統哦.......硬盤沒有分區.......擔心重裝後所有資料都不見了.......那可是超級災難哪........)

另, 如何恢復 添加/刪除應用程序 功能?

請高人指點指點..........

謝謝!!!!!!!!!!
回复

回到 “老旧版本支持”