当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 6 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : [求助]开机启动后。linux不能自动挂载分区。
帖子发表于 : 2008-05-29 14:29 

注册: 2008-05-11 22:57
帖子: 17
送出感谢: 0 次
接收感谢: 0 次
在朋友的介绍下。刚接触linux。所以我是超级超级菜菜鸟。

安装完以后。几天没怎么动linux.今天启动的时候。发现不能自动挂载分区。搞的进不了盘。东西全看不了。

sudo /etc/fstab后。
出的东西是

# /etc/fstab: static file system information.
#
# -- This file has been automaticly generated by ntfs-config --
#
# <file system> <mount point> <type> <options> <dump> <pass>

proc /proc proc defaults 0 0
# Entry for /dev/sda7 :
UUID=91140615-971e-41fd-9dbf-c1de61189a54 / ext3 relatime,errors=remount-ro 0 1
# Entry for /dev/sda8 :
UUID=77ee0b1c-7594-4998-804a-bea101b26d6d none swap sw 0 0
# Entry for /dev/sda1 :
UUID=B630947730944073 /media/sda1 ntfs-3g defaults,locale=zh_CN.UTF-8 0 0
# Entry for /dev/sda5 :
UUID=A6903CF9903CD193 /media/sda5 ntfs-3g defaults,locale=zh_CN.UTF-8 0 0
# Entry for /dev/sda6 :
UUID=20082264082238E4 /media/sda6 ntfs-3g defaults,locale=zh_CN.UTF-8 0 0
# Entry for /dev/sda9 :
UUID=42645D96645D8E13 /media/sda9 ntfs-3g defaults,locale=zh_CN.UTF-8 0 0
# Entry for /dev/sda10 :
UUID=1A8863CA8863A2CD /media/sda10 ntfs-3g defaults,locale=zh_CN.UTF-8 0 0


朋友说是可能是因为突然停电。而引起的列表错误。自己也不知道怎么搞。朋友也不在旁边。

高手指点啊。


页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2008-05-29 14:30 

注册: 2008-05-11 22:57
帖子: 17
送出感谢: 0 次
接收感谢: 0 次
那个加载的选项。本来是朋友帮写上去的。自己对这些。完全不懂。 :oops:


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2008-05-29 14:34 

注册: 2008-05-11 22:57
帖子: 17
送出感谢: 0 次
接收感谢: 0 次
打开/media后。还是可以看到以前做标识的那些sda1什么的。。但是进去后就是全是空白。。。

不知道怎样挂载。 :em21


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2008-05-29 14:40 
头像

注册: 2007-06-02 18:12
帖子: 239
送出感谢: 0 次
接收感谢: 2
sudo mount -a


页首
 用户资料  
 
5 楼 
 文章标题 :
帖子发表于 : 2008-05-29 14:42 

注册: 2008-05-11 22:57
帖子: 17
送出感谢: 0 次
接收感谢: 0 次
这个试过了啊。。

朋友早给我说过了。

我把那里面的东西发给你看。

coward@coward-desktop:~$ sudo mount -a
[sudo] password for coward:
$LogFile indicates unclean shutdown (0, 0)
Failed to mount '/dev/sda1': 操作不支持
Mount is denied because NTFS is marked to be in use. Choose one action:

Choice 1: If you have Windows then disconnect the external devices by
clicking on the 'Safely Remove Hardware' icon in the Windows
taskbar then shutdown Windows cleanly.

Choice 2: If you don't have Windows then you can use the 'force' option for
your own responsibility. For example type on the command line:

mount -t ntfs-3g /dev/sda1 /media/sda1 -o force

Or add the option to the relevant row in the /etc/fstab file:

/dev/sda1 /media/sda1 ntfs-3g force 0 0
$LogFile indicates unclean shutdown (0, 0)
Failed to mount '/dev/sda5': 操作不支持
Mount is denied because NTFS is marked to be in use. Choose one action:

Choice 1: If you have Windows then disconnect the external devices by
clicking on the 'Safely Remove Hardware' icon in the Windows
taskbar then shutdown Windows cleanly.

Choice 2: If you don't have Windows then you can use the 'force' option for
your own responsibility. For example type on the command line:

mount -t ntfs-3g /dev/sda5 /media/sda5 -o force

Or add the option to the relevant row in the /etc/fstab file:

/dev/sda5 /media/sda5 ntfs-3g force 0 0
$LogFile indicates unclean shutdown (0, 0)
Failed to mount '/dev/sda6': 操作不支持
Mount is denied because NTFS is marked to be in use. Choose one action:

Choice 1: If you have Windows then disconnect the external devices by
clicking on the 'Safely Remove Hardware' icon in the Windows
taskbar then shutdown Windows cleanly.

Choice 2: If you don't have Windows then you can use the 'force' option for
your own responsibility. For example type on the command line:

mount -t ntfs-3g /dev/sda6 /media/sda6 -o force

Or add the option to the relevant row in the /etc/fstab file:

/dev/sda6 /media/sda6 ntfs-3g force 0 0
$LogFile indicates unclean shutdown (0, 0)
Failed to mount '/dev/sda9': 操作不支持
Mount is denied because NTFS is marked to be in use. Choose one action:

Choice 1: If you have Windows then disconnect the external devices by
clicking on the 'Safely Remove Hardware' icon in the Windows
taskbar then shutdown Windows cleanly.

Choice 2: If you don't have Windows then you can use the 'force' option for
your own responsibility. For example type on the command line:

mount -t ntfs-3g /dev/sda9 /media/sda9 -o force

Or add the option to the relevant row in the /etc/fstab file:

/dev/sda9 /media/sda9 ntfs-3g force 0 0
$LogFile indicates unclean shutdown (0, 0)
Failed to mount '/dev/sda10': 操作不支持
Mount is denied because NTFS is marked to be in use. Choose one action:

Choice 1: If you have Windows then disconnect the external devices by
clicking on the 'Safely Remove Hardware' icon in the Windows
taskbar then shutdown Windows cleanly.

Choice 2: If you don't have Windows then you can use the 'force' option for
your own responsibility. For example type on the command line:

mount -t ntfs-3g /dev/sda10 /media/sda10 -o force

Or add the option to the relevant row in the /etc/fstab file:

/dev/sda10 /media/sda10 ntfs-3g force 0 0


页首
 用户资料  
 
6 楼 
 文章标题 :
帖子发表于 : 2008-05-29 15:10 

注册: 2007-10-04 15:23
帖子: 147
送出感谢: 0 次
接收感谢: 0 次
defaults,locale=zh_CN.UTF-8改为force吧,我的就是这么
最后那句是说了吗


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 6 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 5 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译