安装软件遇到的问题

为当前最终发行版之前的所有版本提供支持
回复
xxg030520
帖子: 9
注册时间: 2008-05-27 10:27
送出感谢: 0
接收感谢: 0

安装软件遇到的问题

#1

帖子 xxg030520 » 2008-05-30 13:15

[size=0]学习在ubuntu8.04上安装一些软件,按照网上朋友的方法尝试,先解压,然后./configure检查系统信息,输入存放文件的目录,但是再在终端输入#make时就出错,具体如下:checking for C++ compiler default out put file name...configure:error:c++ compiler cannot create executables.后来又查料些资料,在终端输入 sudo apt-get install libc6-dev ,系统提示已经是最新版本了;在终端输入sudo apt-get gcc libc6-dev,就说是无效的操作 gcc,现在我该怎么办啊,大家帮帮忙啊! [/size]
dbzhang800
帖子: 3182
注册时间: 2006-03-10 15:10
来自: xi'an China
送出感谢: 0
接收感谢: 2 次
联系:

#2

帖子 dbzhang800 » 2008-05-30 13:24

代码: 全选

sudo apt-get install build-essential
头像
AutoXBC
帖子: 1750
注册时间: 2007-10-23 12:54
送出感谢: 2 次
接收感谢: 24 次

#3

帖子 AutoXBC » 2008-05-30 13:42

为单个软件检查编译环境

代码: 全选

sudo apt-get build-dep 软件名
xxg030520
帖子: 9
注册时间: 2008-05-27 10:27
送出感谢: 0
接收感谢: 0

#4

帖子 xxg030520 » 2008-05-30 16:58

我是菜鸟啊,能不能说地清楚点啊,遇到这个问题我应该怎么做啊,谢谢阿!
头像
AutoXBC
帖子: 1750
注册时间: 2007-10-23 12:54
送出感谢: 2 次
接收感谢: 24 次

#5

帖子 AutoXBC » 2008-05-30 23:15

二楼是安装编译套件,想编译程序首先要安装 build-essential 这个包,不是只装 gcc 就可以的。
三楼是根据数据库的记载检查单个程序在编译时需要的特殊依赖和开发包,发现缺少的部分自动下载安装。

这两个执行完了再 ./configure,这一步通过后才可以 make ,不通过看出错信息。其实 Ubuntu 上几乎不需要编译什么,把新立得用熟就可以了。
回复

回到 “老旧版本支持”