当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 7 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : [已解决] 关于启动自动运行ufw的问题
帖子发表于 : 2008-06-05 17:29 
头像

注册: 2007-02-27 21:47
帖子: 1473
地址: GL
送出感谢: 0 次
接收感谢: 0 次
是有关ufw的,发在服务器维护没有回答。

我用ufw防火墙,每次启动后都要手动在终端中sudo ufw enable,很是麻烦。想把ufw加到会话中启动自己运行,但试了几种方案都无效。第一种方案,会话中加入一条gksu ufw enable,启动过程中倒是提示输入密码,可以输过密码后发现ufw还是没有运行(终端中sudo ufw status说的)。第二种方案直接加一条ufw enable(我知道需要su权限,可第一方案无效),当然没啥用了。

请问各位使用ufw的朋友是怎么弄的?

(另:每次启动时都出来一个OOo Write的空白窗口,是怎么回事?我确实用了快速启动,但也不会这样啊)


_________________
Intel Pentium Dual Core 2.1G, 250G, DDRII 3G, ATI Radeon HD 4330
LMDE


最后由 RegentW 编辑于 2008-06-05 18:13,总共编辑了 1 次

页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2008-06-05 17:31 
头像

注册: 2007-04-25 13:12
帖子: 2838
送出感谢: 0 次
接收感谢: 0 次
ufw不是服务形式启动的吗

看看这个文件/etc/ufw/ufw.conf


_________________
♜♞♝♛♚♝♞♜
♟♟♟♟♟♟♟♟
♙♙♙♙♙♙♙♙
♖♘♗♕♔♗♘♖

☠☯⚔⚓☣☦☃☕
☹☻☪☭☬⚖⚛⚜
ℜℳℬ™ ℋℯℓ℘ ℳℭ
sƂɐʍ рǀɹoʍ əɥʇ oS


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2008-06-05 17:35 
头像

注册: 2007-02-27 21:47
帖子: 1473
地址: GL
送出感谢: 0 次
接收感谢: 0 次
solcomo 写道:
ufw不是服务形式启动的吗

看看这个文件/etc/ufw/ufw.conf

代码:
regent@regent-studio:~$ sudo gedit /etc/ufw/ufw.conf
# /etc/ufw/ufw.conf
#

# set to yes to start on boot
ENABLED=yes

这个倒是能看懂,但我看了这个ufw.conf文件的最后修改日期,是5月1日 :roll:


_________________
Intel Pentium Dual Core 2.1G, 250G, DDRII 3G, ATI Radeon HD 4330
LMDE


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2008-06-05 17:44 
头像

注册: 2007-04-25 13:12
帖子: 2838
送出感谢: 0 次
接收感谢: 0 次
用 sysv-rc-conf
看看ufw开了没


_________________
♜♞♝♛♚♝♞♜
♟♟♟♟♟♟♟♟
♙♙♙♙♙♙♙♙
♖♘♗♕♔♗♘♖

☠☯⚔⚓☣☦☃☕
☹☻☪☭☬⚖⚛⚜
ℜℳℬ™ ℋℯℓ℘ ℳℭ
sƂɐʍ рǀɹoʍ əɥʇ oS


页首
 用户资料  
 
5 楼 
 文章标题 :
帖子发表于 : 2008-06-05 17:51 
头像

注册: 2007-02-27 21:47
帖子: 1473
地址: GL
送出感谢: 0 次
接收感谢: 0 次
安装了sysv-rc-conf,运行sudo sysv-rc-conf结果如下


附件:
~.png
~.png [ 42.38 KiB | 被浏览 511 次 ]



_________________
Intel Pentium Dual Core 2.1G, 250G, DDRII 3G, ATI Radeon HD 4330
LMDE
页首
 用户资料  
 
6 楼 
 文章标题 :
帖子发表于 : 2008-06-05 17:51 
头像

注册: 2007-02-27 21:47
帖子: 1473
地址: GL
送出感谢: 0 次
接收感谢: 0 次
那些1/2/3/4/5/0/6/s是什么意思?


_________________
Intel Pentium Dual Core 2.1G, 250G, DDRII 3G, ATI Radeon HD 4330
LMDE


页首
 用户资料  
 
7 楼 
 文章标题 :
帖子发表于 : 2008-06-05 18:12 
头像

注册: 2007-02-27 21:47
帖子: 1473
地址: GL
送出感谢: 0 次
接收感谢: 0 次
解决了,原来是因为系统中同时存在着firestarter。我把firestarter卸掉,重启,ufw就在自动运行了 :D


_________________
Intel Pentium Dual Core 2.1G, 250G, DDRII 3G, ATI Radeon HD 4330
LMDE


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 7 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:Sogou [Spider] 和 4 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译