[已解决][问题]求助,ubuntu 不能播放 RMVB 文件(GStreamer 遇到了常规流错误)

为当前最终发行版之前的所有版本提供支持
chochiea
帖子: 25
注册时间: 2008-06-01 22:36
来自: 陕西省西安市
送出感谢: 0
接收感谢: 0
联系:

[已解决][问题]求助,ubuntu 不能播放 RMVB 文件(GStreamer 遇到了常规流错误)

#1

帖子 chochiea » 2008-06-06 12:08

播放RMVB时,出提示框,报告:发生了一个错误:GStreamer 遇到了常规流错误
下面就一个确定按钮~~搞的我头晕死了,请求高手帮助~~

我已经执行过下面操作,配置了多媒体应用环境设置:
----------------------------
连接国外网 加入Medibuntu源,输入命令
sudo wget http://www.medibuntu.org/sources.list.d/hardy.list -O /etc/apt/sources.list.d/medibuntu.list
sudo apt-get update && sudo apt-get install medibuntu-keyring
sudo apt-get update

确认已加入ubuntu-cn源

安装多媒体解码器,输入命令
* Xine多媒体引擎解码器
sudo apt-get install libxine1-ffmpeg libxine1-all-plugins libxine1-plugins w32codecs gcc-3.3-base libstdc++5
* Gstreamer多媒体引擎解码器
sudo apt-get install gstreamer0.10-ffmpeg gstreamer0.10-pitfdll gstreamer0.10-plugins-bad gstreamer0.10-plugins-bad-multiverse gstreamer0.10-plugins-ugly gstreamer0.10-plugins-ugly-multiverse gstreamer0.10-esd
* DVD影碟功能支持
sudo apt-get install libdvdnav4 libdvdread3 libdvdcss2
配置电影播放器
sudo apt-get remove totem-mozilla -y
sudo apt-get install smplayer smplayer-themes mozilla-mplayer
---------------------------------------

所有操作的终端提示都正常,我以为我已经搞定了,可还是不能播放,清高手来指点下~~谢谢
上次由 chochiea 在 2008-06-23 16:06,总共编辑 1 次。
头像
weive
帖子: 3235
注册时间: 2007-10-21 18:36
来自: 汕头/广东/中国
送出感谢: 2 次
接收感谢: 3 次

#2

帖子 weive » 2008-06-06 12:20

找个realplayer装上。
老子的哲学是“”,庄子的哲学是“
人有一技在身,则逍遥游而无不为
wanzy
帖子: 110
注册时间: 2008-05-11 12:08
送出感谢: 0
接收感谢: 0

#3

帖子 wanzy » 2008-06-06 12:25

我也遇到了这个问题,等待高手相助
chochiea
帖子: 25
注册时间: 2008-06-01 22:36
来自: 陕西省西安市
送出感谢: 0
接收感谢: 0
联系:

#4

帖子 chochiea » 2008-06-06 17:58

二楼的大虾,我在论坛里见有人说在ubuntu里装realplayer是一场噩梦,有这么糟糕吗?
另外,不装别的播放软件,就把这个解决了,我也能知道是什么原因,解决的思路是什么,
要不然,始终还是知其然,不知其所以然。
mlb123
帖子: 3
注册时间: 2006-10-23 12:56
送出感谢: 0
接收感谢: 0

#5

帖子 mlb123 » 2008-06-06 19:03

下载个W32code装上应该可以了。
头像
syrano
帖子: 4313
注册时间: 2007-10-06 18:40
送出感谢: 0
接收感谢: 5 次

#6

帖子 syrano » 2008-06-06 19:57

mplayer+w32codes
至高之光
帖子: 77
注册时间: 2007-06-25 22:12
送出感谢: 0
接收感谢: 0
联系:

#7

帖子 至高之光 » 2008-06-06 20:22

用 MPlayer + W32codecs 或者 totem-xine + xine 中的一堆。
头像
冲浪板
论坛版主
帖子: 7467
注册时间: 2007-05-06 8:19
送出感谢: 0
接收感谢: 5 次

#8

帖子 冲浪板 » 2008-06-06 22:56

还是建议realplayer 11的说
whuiss
帖子: 55
注册时间: 2008-04-30 18:38
来自: Whu_ISS
送出感谢: 0
接收感谢: 0
联系:

#9

帖子 whuiss » 2008-06-06 23:35

遇到同样问题,只好去下了个realplayer11
头像
jaywee
帖子: 517
注册时间: 2006-06-18 21:49
送出感谢: 0
接收感谢: 0
联系:

#10

帖子 jaywee » 2008-06-07 2:45

装个Mplayer吧!~
Time waits for no man!
头像
lhw828
帖子: 2802
注册时间: 2007-03-15 16:58
来自: 湖北武汉
送出感谢: 2 次
接收感谢: 3 次
联系:

#11

帖子 lhw828 » 2008-06-07 3:08

换一个文件试试。也许是文件的问题啊
chochiea
帖子: 25
注册时间: 2008-06-01 22:36
来自: 陕西省西安市
送出感谢: 0
接收感谢: 0
联系:

#12

帖子 chochiea » 2008-06-07 11:28

syrano 写了:mplayer+w32codes
谢谢,关键词提醒,原来我没装mplayer
已经搞定,谢谢大家撒
人品好,机品就好。
人品不好,什么都装不上,安装出现问题?从人品上找原因~~
jiangdavid
帖子: 7
注册时间: 2008-06-07 11:59
送出感谢: 0
接收感谢: 0

#13

帖子 jiangdavid » 2008-06-07 12:01

由于版权的问题在Ubuntu Linux 中系统默认安装的totem不能播放我们常用的RMVB、AVI、mp3和rm等文件,这也使得我们众多的新手们不能在Ubuntu中听歌看电影,这几天问到这个问题的朋友也很多,今天就和大家详细得讲解一下这个问题的处理方法

1.更新源

如果你已经更新源这一步可以跳过!如果你还不知道什么是”源”,怎样更新”源”,你可以查看本站的《细说Ubuntu Linux 软件源》这篇文章
2.卸载系统默认的totem

sudo apt-get remove totem-gstreamer
3.安装totem-xine。

sudo apt-get install totem-xine libxine1-ffmpeg libxine1-gnome libxine1-plugins libxine1 libstdc++5
4.安装解码器。同上

sudo apt-get install w32codecs

就这样简单的几步就解决问题了!简单吧!
我也是昨天刚弄明白的!
头像
skyx
论坛版主
帖子: 9203
注册时间: 2006-12-23 13:46
来自: Azores Islands
送出感谢: 0
接收感谢: 1 次
联系:

#14

帖子 skyx » 2008-06-08 9:48

1. totem-gstreamer +gstreamer

同样可以播放rmvb,我测试过, 但我用的视频文件有限, 我手上的都可以播放

totem+gstreamer 是gnome的御用方案

2.xine-gui/kaffine +libxine

有xine-gui 或kaffine ,个人以为没必要安装totem-xine, karron过去在初学者园地的那个置顶帖的确影响广泛,其它论坛或blog直到现在,仍然沿用了totem-xine +libxine的方案,即然用libxine,我觉得播放器还是用xine


3
win32codecs+mplayer/gmplayer/smplayer

这个组合很强


4
http://www.real.com/linux

realplayer过去在linux平台用起来很不好,但现在的比较好用

5

http://www.verycd.com/groups/@g2214375/267528.topic

这个看dvd也不错。
no security measure is worth anything if an attacker has physical access to the machine
lanana
帖子: 202
注册时间: 2008-04-19 23:11
送出感谢: 0
接收感谢: 0

#15

帖子 lanana » 2008-06-08 11:19

其实感觉realplayer还是可以的哈
回复

回到 “老旧版本支持”