[问题]如何删除kernel 2.6.24-19以前的版本?????

为当前最终发行版之前的所有版本提供支持
ywj009
帖子: 32
注册时间: 2007-08-24 12:39
送出感谢: 0
接收感谢: 0

[问题]如何删除kernel 2.6.24-19以前的版本?????

#1

帖子 ywj009 » 2008-06-10 13:27

更新了ubuntu8.10,现在是kernel 2.6.24-19了。貌似16、17还在,如何删除他们,以节省硬盘空间?
sam1860
帖子: 312
注册时间: 2006-10-28 11:05
送出感谢: 0
接收感谢: 0

#2

帖子 sam1860 » 2008-06-10 13:30

在新立得中按名称分别搜索24-16, 24-17
google drive client for linux 下载
---------------------------------------------------------------
项目|9918视频秀
CentOS, Nginx, Java, C++, Go, MySQL, Redis
ywj009
帖子: 32
注册时间: 2007-08-24 12:39
送出感谢: 0
接收感谢: 0

#3

帖子 ywj009 » 2008-06-10 13:46

可是我搜索出来了几十个条目,显示为“已”安装的也有好多好多,如何选择呢?
sam1860
帖子: 312
注册时间: 2006-10-28 11:05
送出感谢: 0
接收感谢: 0

#4

帖子 sam1860 » 2008-06-10 15:42

全删
google drive client for linux 下载
---------------------------------------------------------------
项目|9918视频秀
CentOS, Nginx, Java, C++, Go, MySQL, Redis
amd_ati
帖子: 13
注册时间: 2008-06-08 9:36
送出感谢: 0
接收感谢: 0

#5

帖子 amd_ati » 2008-06-10 22:47

我用的是

代码: 全选

dpkg --get-selections|grep linux
然后

代码: 全选

sudo apt-get remove linux-image-2.6.x
x是不需要的版本
yovz
帖子: 8
注册时间: 2008-04-02 18:43
送出感谢: 0
接收感谢: 0

#6

帖子 yovz » 2008-06-11 15:27

amd_ati 写了:我用的是

代码: 全选

dpkg --get-selections|grep linux
然后

代码: 全选

sudo apt-get remove linux-image-2.6.x
x是不需要的版本
按5楼的命令提示找不到 linux-image-2.6.24-16
头像
skyx
论坛版主
帖子: 9203
注册时间: 2006-12-23 13:46
来自: Azores Islands
送出感谢: 0
接收感谢: 1 次
联系:

#7

帖子 skyx » 2008-06-11 15:42

新立德搜索后还可以排序的.
no security measure is worth anything if an attacker has physical access to the machine
头像
eexpress
帖子: 58428
注册时间: 2005-08-14 21:55
来自: 长沙
送出感谢: 4 次
接收感谢: 256 次

#8

帖子 eexpress » 2008-06-11 15:43

sudo aptitude purge ~ilinux-image-.*\(\!`uname -r`\)

鳖人,居然就没人用我的高级语法。
● 鸣学
头像
syrano
帖子: 4313
注册时间: 2007-10-06 18:40
送出感谢: 0
接收感谢: 5 次

#9

帖子 syrano » 2008-06-11 16:51

eexpress 写了:sudo aptitude purge ~ilinux-image-.*\(\!`uname -r`\)

鳖人,居然就没人用我的高级语法。
:em20 :ema1 :em29
头像
syrano
帖子: 4313
注册时间: 2007-10-06 18:40
送出感谢: 0
接收感谢: 5 次

#10

帖子 syrano » 2008-06-11 16:53

eexpress 写了:sudo aptitude purge ~ilinux-image-.*\(\!`uname -r`\)

鳖人,居然就没人用我的高级语法。
:oops:
这样只是把内核删了,相关的模块,头文件都没有删
头像
eexpress
帖子: 58428
注册时间: 2005-08-14 21:55
来自: 长沙
送出感谢: 4 次
接收感谢: 256 次

#11

帖子 eexpress » 2008-06-11 16:54

你低估了威力吧。呵呵
● 鸣学
sheji
帖子: 431
注册时间: 2008-04-30 21:40
送出感谢: 0
接收感谢: 0

#12

帖子 sheji » 2008-06-11 17:05

难道是颗原子弹?别把全部内核给轰了~~
头像
Azone
帖子: 98
注册时间: 2007-08-02 16:01
送出感谢: 0
接收感谢: 0
联系:

#13

帖子 Azone » 2008-06-11 18:05

删了几个内核腾出了700多M的空间, :lol:
头像
HuntXu
论坛版主
帖子: 5776
注册时间: 2007-09-29 3:09
送出感谢: 0
接收感谢: 6 次

#14

帖子 HuntXu » 2008-06-11 18:06

eexpress 写了:sudo aptitude purge ~ilinux-image-.*\(\!`uname -r`\)

鳖人,居然就没人用我的高级语法。
神谕再现... :D
HUNT Unfortunately No Talent...
头像
dogfox
论坛版主
帖子: 5309
注册时间: 2006-09-02 14:18
来自: 汉桑城
送出感谢: 1 次
接收感谢: 1 次
联系:

#15

帖子 dogfox » 2008-06-11 18:14

eexpress 写了:sudo aptitude purge ~ilinux-image-.*\(\!`uname -r`\)

鳖人,居然就没人用我的高级语法。
的确很高级,不过俺不用
全世界linux爱好者联合起来 !
一切闭源操作系统都是纸老虎 !
要斗私批修,拒绝黑屏,使用linux !
让一部分人先用起Archlinux来 !
linux是第一生产力 !
讲正气,讲开源,讲free
要坚定不移的走开源的道路 !
linux明天会更好 !

dpkg -l |grep ^rc|awk '{print $2}' |tr ["\n"] [" "]|sudo xargs dpkg -P -
ubuntu粉丝群 26660836 已满员
回复

回到 “老旧版本支持”