[已解决]升级内核出错了,大侠们帮助阿

为当前最终发行版之前的所有版本提供支持
回复
头像
禾月
帖子: 17
注册时间: 2007-10-19 15:42
送出感谢: 0
接收感谢: 0

[已解决]升级内核出错了,大侠们帮助阿

#1

帖子 禾月 » 2008-06-26 9:04

系统提示升级内核的时候出现了如下错误,不知道如何是好,希望大侠们能帮助一下

/////////////////////////////////////////
下列的软件包将被升级:
linux-image-2.6.24-19-generic
共升级了 1 个软件包,新安装了 0 个软件包,要卸载 0 个软件包,有 0 个软件未被升级。
需要下载 0B/17.8MB 的软件包。
操作完成后,会消耗掉 0B 的额外磁盘空间。
您希望继续执行吗?[Y/n]y
(正在读取数据库 ... 系统当前总共安装有 120042 个文件和目录。)
正预备替换 linux-image-2.6.24-19-generic 2.6.24-19.33 (使用 .../linux-image-2.6.24-19-generic_2.6.24-19.34_amd64.deb) ...
Done.
正在解压缩将用于更替的包文件 linux-image-2.6.24-19-generic ...
dpkg:处理 /var/cache/apt/archives/linux-image-2.6.24-19-generic_2.6.24-19.34_amd64.deb (--unpack)时出错:
无法在安装新的版本前,为“./boot/vmlinuz-2.6.24-19-generic”做一个符号链接备份: 操作不允许
dpkg-deb: 子进程 paste 被信号(Broken pipe)终止了
Running postrm hook script /sbin/update-grub.
Searching for GRUB installation directory ... found: /boot/grub
Searching for default file ... found: /boot/grub/default
Testing for an existing GRUB menu.lst file ... found: /boot/grub/menu.lst
Searching for splash image ... none found, skipping ...
Found kernel: /boot/vmlinuz-2.6.24-19-generic
Found kernel: /boot/vmlinuz-2.6.24-18-generic
Found kernel: /boot/memtest86+.bin
Updating /boot/grub/menu.lst ... done

在处理时有错误发生:
/var/cache/apt/archives/linux-image-2.6.24-19-generic_2.6.24-19.34_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
///////////////////////////////////////////

****************************
晕倒,逼不得已把linux-image-2.6.24-19-generic内核删除了重
新装了一次,按理说原来就是这个内核了,怎么今天升级还是这
个版本呢?
****************************
上次由 禾月 在 2008-06-26 14:23,总共编辑 1 次。
头像
禾月
帖子: 17
注册时间: 2007-10-19 15:42
送出感谢: 0
接收感谢: 0

#2

帖子 禾月 » 2008-06-26 13:08

怎么没有大侠啊?
delectate
帖子: 18311
注册时间: 2008-01-09 22:41
送出感谢: 0
接收感谢: 6 次

#3

帖子 delectate » 2008-06-26 13:14

难道是权限问题?

你用的什么方式安装的?
头像
禾月
帖子: 17
注册时间: 2007-10-19 15:42
送出感谢: 0
接收感谢: 0

#4

帖子 禾月 » 2008-06-26 13:19

后代 写了:难道是权限问题?

你用的什么方式安装的?

应该不会是权限问题吧,以前都能安装的,不过以前都是用终端更新的,这次开始是用更新管理器更新的,出错后用终端试了一下也不行

wubi安装
delectate
帖子: 18311
注册时间: 2008-01-09 22:41
送出感谢: 0
接收感谢: 6 次

#5

帖子 delectate » 2008-06-26 13:30

又是wubi

帮不了你了
头像
cnkilior
论坛版主
帖子: 4979
注册时间: 2007-08-05 17:40
送出感谢: 0
接收感谢: 5 次

#6

帖子 cnkilior » 2008-06-26 14:43

后代 写了:又是wubi

帮不了你了
若赖赖
帖子: 16
注册时间: 2008-06-04 16:32
送出感谢: 0
接收感谢: 0

#7

帖子 若赖赖 » 2008-07-26 10:25

我也碰到这个问题了,请求大虾指教
2ine
帖子: 200
注册时间: 2008-05-02 15:55
送出感谢: 0
接收感谢: 0

#8

帖子 2ine » 2008-07-26 13:56

难道是RP问题。。
我的也是Wubi,也装了新内核,怎么就没有事情呢?

这个包很诡异啊,/var/cache/apt/archives/linux-image-2.6.24-19-generic_2.6.24-19.34_amd64.deb
注意后缀 _amd64
头像
sz158
帖子: 1
注册时间: 2008-07-24 2:53
送出感谢: 0
接收感谢: 0

#9

帖子 sz158 » 2008-07-28 20:28

我也是这个问题,这几天刚开机自动更新,出现这样的问题,也是wubi安装的`````
eos
帖子: 419
注册时间: 2007-02-06 16:21
送出感谢: 0
接收感谢: 0

#10

帖子 eos » 2008-07-28 23:24

我认为还是用live cd好
wubi 不可靠
回复

回到 “老旧版本支持”