当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 9 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : [已解决][问题]启动 GNOME 设置守护进程时出错。
帖子发表于 : 2008-06-29 8:41 

注册: 2008-06-02 16:30
帖子: 118
送出感谢: 0 次
接收感谢: 0 次
我对iptables一点都不懂,前天在网上看到一篇简单设置iptables的文章,就按它说的做了一下:
代码:
# iptables -A INPUT -m state --state ESTABLISHED,RELATED -j ACCEPT
# iptables -A INPUT -p tcp -i eth0 --dport ssh -j ACCEPT
# iptables -A INPUT -p tcp -i eth0 --dport 80 -j ACCEPT
# iptables -A INPUT -j DROP
# iptables -I INPUT 4 -i lo -j ACCEPT
# iptables-save > /etc/iptables.up.rules
# gedit /etc/network/interfaces然后我将原来这个文件的内容替换成了下面的内容:
auto eth0
iface eth0 inet dhcp
pre-up iptables-restore < /etc/iptables.up.rules

可是我发现这样以后我的网络断了。由于自己不懂,我就用自己的方法把上面的试置“恢复”了一下:
代码:
# iptables-restore
# rm /etc/iptables.up.rules
# gedit /etc/network/interfaces,由于当时没有注意看原来的内容,只是凭印象,好像记得是下面的内容,我就改了:
auto lo
iface lo inet dhcp

因为只是模糊记得有lo。
我这样做了以后,网络倒是正常了,可当我重启系统将要进入桌面时就好像没有反应了一样,过了一段时间,桌面出来了,在桌面的左上角出现了一个对话框显示如下内容:
代码:
启动 GNOME 设置守护进程时出错。

主题、声音或者背景设置等可能不会正常工作。

最后的错误信息是:

Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.

GNOME 在您下次登录时仍将试图重启动设置守护进程。

请路过的前辈们帮一下,是不是我改/etc/network/interfaces这个文件弄错了?有什么办法解决吗?


附件:
Screenshot-x-session-manager.png
Screenshot-x-session-manager.png [ 19.38 KiB | 被浏览 1451 次 ]



最后由 wangjunhuashuo 编辑于 2008-06-30 12:46,总共编辑了 1 次
页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2008-06-29 9:55 

注册: 2008-06-02 16:30
帖子: 118
送出感谢: 0 次
接收感谢: 0 次
怎么没有人来帮一下呀,急呀!


页首
 用户资料  
 
3 楼 
 文章标题 : There was an error starting the GNOME Settings Daemon
帖子发表于 : 2008-06-29 18:21 

注册: 2008-06-25 10:27
帖子: 15
送出感谢: 0 次
接收感谢: 0 次
There was an error starting the GNOME Settings Daemon
我的也是那样的情况


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2008-06-29 19:01 
头像

注册: 2007-07-10 12:16
帖子: 525
送出感谢: 0 次
接收感谢: 0 次
google到的 ,不知有用没,

解决方法:
在启动至将要登陆到用户桌面时, 按Ctrl Alt F1 进入命令行模式,作如下修改:
代码:
sudo nano /etc/network/interfaces

引用:
auto lo

iface lo inet loopback

auto eth0

iface eth0 inet dhcp

注意“eth0”最后一个字为零,而非英文字母“欧”
保存并退出文件的修改,使用如下命令重新启动网络服务:
代码:
sudo /etc/init.d/networking restart



很多人(包括我)遇到过这个守护进程出错的问题 ,出错原因有很多。我的升级几次后,就解决了


_________________
像一条秋天的道路:还未来得及扫干净,它又为干枯的树叶所覆盖。

The Kafka Project http://www.kafka.org


页首
 用户资料  
 
5 楼 
 文章标题 :
帖子发表于 : 2008-06-30 12:46 

注册: 2008-06-02 16:30
帖子: 118
送出感谢: 0 次
接收感谢: 0 次
哈哈,四楼说的我也找到了,这个方法是对的。谢谢!


页首
 用户资料  
 
6 楼 
 文章标题 :
帖子发表于 : 2008-07-03 15:11 

注册: 2008-03-30 17:08
帖子: 5
送出感谢: 0 次
接收感谢: 0 次
为什么我照4楼的方法做了以后就上不去网了呢?


_________________
www.lovexun.com图片


页首
 用户资料  
 
7 楼 
 文章标题 :
帖子发表于 : 2008-07-03 16:12 

注册: 2008-06-02 16:30
帖子: 118
送出感谢: 0 次
接收感谢: 0 次
呵呵,六楼只能等高手前天帮忙了,其实我觉得我们还是不要看着书本来瞎弄了,我们甚至都不明白那些书上说的代码的意思。万一出了问题,又是只等高手来解决。或许我们看到的只是他们认为正确的代码,或许他们连验证一下都没有。所以要慢慢学哟,等到完全明白一句代码是什么意思的时候再动手,即使出了问题也知道是怎么回事!…………路漫漫!


页首
 用户资料  
 
8 楼 
 文章标题 :
帖子发表于 : 2008-07-04 21:58 

注册: 2007-04-15 9:59
帖子: 2
送出感谢: 0 次
接收感谢: 0 次
四楼,说得对!
今天我也遇到这个问题,现在解决了,谢谢!
可是,有谁能够解释一下以下两条配置命令是什么意思?
auto lo
iface lo inet loopback


页首
 用户资料  
 
9 楼 
 文章标题 : Re: [已解决][问题]启动 GNOME 设置守护进程时出错。
帖子发表于 : 2008-11-21 9:57 

注册: 2007-12-31 14:45
帖子: 12
地址: 湖北
送出感谢: 0 次
接收感谢: 0 次
我照四楼的办,什么都没有改变,倒是还能上网


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 9 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:Google [Bot] 和 5 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译