当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 8 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : [问题]郁闷!无法上网?
帖子发表于 : 2008-06-29 15:37 

注册: 2008-06-28 8:14
帖子: 5
送出感谢: 0 次
接收感谢: 0 次
:( 电信要求用星空极速,没办法只有用最原始的办法,打电话给电信。说换了系统要求解除绑定,电信那个声音甜甜的接线员给我刷新了一下。但是Ubuntu还是无法连接上,唉!真的是开始起步是很难很寒的啊,有点对他望而却步了,没有网Ubuntu可没多大意思了!


页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2008-06-29 16:57 

注册: 2008-06-28 13:08
帖子: 4
送出感谢: 0 次
接收感谢: 0 次
不用解除绑定

具体去wiki ubuntu

看看把


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2008-06-29 17:03 
头像

注册: 2007-05-06 2:46
帖子: 15634
送出感谢: 0 次
接收感谢: 2
Ubuntu网络连接是有点别扭


定下心,仔细点


搞顺手了也很OK


页首
 用户资料  
 
4 楼 
 文章标题 : Re: [问题]郁闷!无法上网?
帖子发表于 : 2008-06-29 17:23 
头像

注册: 2008-01-23 15:16
帖子: 484
地址: Earth
送出感谢: 0 次
接收感谢: 0 次
梦清风 写道:
:( 电信要求用星空极速,没办法只有用最原始的办法,打电话给电信。说换了系统要求解除绑定,电信那个声音甜甜的接线员给我刷新了一下。但是Ubuntu还是无法连接上,唉!真的是开始起步是很难很寒的啊,有点对他望而却步了,没有网Ubuntu可没多大意思了!


我现在也是星空极速阿~
你能不能描述一下具体情况,这样提问是不是有失水准?
基本看不明白?


页首
 用户资料  
 
5 楼 
 文章标题 :
帖子发表于 : 2008-06-29 17:24 
头像

注册: 2008-01-23 15:16
帖子: 484
地址: Earth
送出感谢: 0 次
接收感谢: 0 次
hcym 写道:
Ubuntu网络连接是有点别扭


定下心,仔细点


搞顺手了也很OK


丝毫不别扭而且非常稳定~

设置自动拨号后,从来没有短线过,而且设置也非常简单?

请问那里别扭?


页首
 用户资料  
 
6 楼 
 文章标题 :
帖子发表于 : 2008-06-30 18:10 

注册: 2008-06-28 8:14
帖子: 5
送出感谢: 0 次
接收感谢: 0 次
我用的是星空急速3.1,我是在XP系统下安装的Ubuntu8.04.xp在C盘 Ubuntu在D盘 格式为FAT32。请楼上的各位指教一下小白, :lol:


页首
 用户资料  
 
7 楼 
 文章标题 :
帖子发表于 : 2008-06-30 18:23 
头像

注册: 2007-05-06 2:46
帖子: 15634
送出感谢: 0 次
接收感谢: 2
星空急速在XP也不是非用不可

我在XP就用的HelloNet5.1,压根没用过星空


Ubuntu就用自带拨号端,家里就用PPPOE

方法见置顶贴或WIKI


页首
 用户资料  
 
8 楼 
 文章标题 :
帖子发表于 : 2008-06-30 19:30 
头像

注册: 2008-01-25 18:21
帖子: 3
送出感谢: 0 次
接收感谢: 0 次
ubuntu 7.10配置 ADSL 拨号上网





文章来源:http://www.linuxdiyf.com/bbs/thread-63646-1-1.html1.打开应用程序菜单,依次选择附件 - 终端。



2.在弹出终端窗口後,输sudo pppoeconf,输入完成後回车。



3.然后会提示您输入当前Ubuntu管理员用户的密码,输入完成後回车。



询问你的网络设备,一般选择是,进行检测,然后一直选择是。



4.之后会提示您输入您的ADSL用户名(也就是帐号)和密码,在输入帐号时把原来的user删掉,其它的除密码之外的问题全部回答“是”(Yes)就可以了.



5.最後会提示您是否开机自动拨号,选择Y的话,默认开机会没有任何提示的情况下拨号,直接可以上网。如果选择N的话,需要拨号时请手工进入终端输入pon dsl-provider拨号命令。



6. 在终端输入

sudo gedit /etc/ppp/options



将 弹出的文档中的 lcp-echo-failure 4 改为 lcp-echo-failure 40 这是因为Ubutnu默认的设置有个很明显的缺陷,lcp-echo-failure次数被设为4,而lcp-echo-interval设为30秒。也就是说,如果120秒钟之内,ADSL服务器没有给回echo-reply信号,Ubuntu便会认为网络已经出了问题,马上中断重联,搞得人非常不爽。



如果你用XP拨号上ADSL是正常的,而在Ubuntu拨号上ADSL,却是不停断线,有可能是DHCP问题。这个问题,可能是你的MODEM自动给你的,某些MODEM是能自动拨号上去呢,比如我的MODEM大亚DB102-C 。你可以在浏览器输入:192.168.1.1去检测你的MODEM是否带路由功能,能自动拨号,如果输入后会有一个界面弹出,叫你输入用户名同密码的话,这就说明你的MODEM是带路由功能的,当然你可以直接上网查你MODEM的型号和功能。如果是的这样话,你可以进入你MODEM关闭它自己的 DHCP功能(如何进入你的MODEM关闭它的DHCP,请根据你的MODEM型号上网查询),关了DHCP之后,我在Ubuntu下ADSL的拨号就没有短过线了,还有关了MODEM的DHCP功能后,你进入XP用ADSL拨号会好慢,所以你要把本地连接按下图设置一下,这样就OK。



Ubutnu官方论坛上有个方法是:给你的eth设置一个固定IP,比如10.0.0.1或者192.168.0.1就可以了。还有如果你的MODEM可以拨号上网,你可以在Ubuntu就不用设PPPOE ,只需要设一下你的网卡,并将网关指向它就OK了。



让网络重新连接断网命令是poff 如果ADSL拨号还是有问题的话,大家可以到Ubutnu论坛使用搜索功能查找解决办法,又或者可以到Ubuntu WIKI或者参考 ADSL拨号指南河南网通拨号程序安装指南如果原来在XP下是使用星空极速上网的,可以参考Ubuntu Linux 和 Windows 下完全破解星空极速的方法如果是校园网的用户可以参考华为802.1x认证上网-5.18



其它常用网络配置

图形界面有时候配置网络不能生效,可以用命令行配置



IP命令行配置如下

sudo gedit /etc/network/interfaces

DHCP



DHCP配置如下(假设通过eth1上网)

# The primary network interface - use DHCP to find our address

auto eth1

iface eth1 inet dhcp //指定为dhcp



然后重启

sudo /etc/init.d/networking restart

Static IP



静态IP地址配置如下(假设通过eth1上网)

# The primary network interface

auto eth1

iface eth1 inet static //指定为static

address 192.168.3.90 //IP地址

gateway 192.168.3.1 //网关

netmask 255.255.255.0 //子网掩码



同样需要重启

sudo /etc/init.d/networking restart

DNS



如果有必要,配置DNS

sudo gedit /etc/resolv.conf

nameserver 192.168.3.2


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 8 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:Bing [Bot], Exabot [Bot] 和 4 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译