[问题]加载模块的问题

为当前最终发行版之前的所有版本提供支持
回复
phoenix_wjx
帖子: 30
注册时间: 2008-05-14 9:44
送出感谢: 0
接收感谢: 0

[问题]加载模块的问题

#1

帖子 phoenix_wjx » 2008-07-01 21:35

笔记本的网卡在ubuntu安装好后没有被认出来

查找wiki

Marvell 88E8040 PCI-E Fast Ethernet Controller (rev 12) sky2 Yes From Hardy 7.10

我手动加载了sky2.ko的模块,但ifconfig下还是看不到eth0,lspci也仍然显示未知marvell设备,究竟应该怎么做才能正确加载设备呢?

而且我一重启机器,已经加载的模块就看不到了,这又是为什么呢?
头像
eexpress
帖子: 58428
注册时间: 2005-08-14 21:55
来自: 长沙
送出感谢: 4 次
接收感谢: 256 次

#2

帖子 eexpress » 2008-07-01 21:38

在哪里看到的要加载这模块。官网吗?如果是,就应该有很详细的步骤说明的。
● 鸣学
phoenix_wjx
帖子: 30
注册时间: 2008-05-14 9:44
送出感谢: 0
接收感谢: 0

#3

帖子 phoenix_wjx » 2008-07-01 21:53

eexpress 写了:在哪里看到的要加载这模块。官网吗?如果是,就应该有很详细的步骤说明的。
wiki上找的,它说这个网卡的驱动是sky2的
phoenix_wjx
帖子: 30
注册时间: 2008-05-14 9:44
送出感谢: 0
接收感谢: 0

#4

帖子 phoenix_wjx » 2008-07-01 22:12

在/etc/modules中强制加了sky2,重启后用lsmod能看到这个模块了,但是lspci仍显示它是个未知设备,这是不是意味着该模块并不与我的网卡匹配?

加载模块与安装驱动究竟是不是同样的概念?
回复

回到 “老旧版本支持”