系统启动问题

为当前最终发行版之前的所有版本提供支持
回复
yayaku
帖子: 15
注册时间: 2007-11-07 20:55
送出感谢: 0
接收感谢: 0

系统启动问题

#1

帖子 yayaku » 2008-07-02 18:49

各位大大,看看怎么该。
安装的时候手工分区。第一个区是winxp的,第二个是交换分区,第三个是安装的系统。安装完毕后,重启,没有选单,直接进xp系统。
要该哪些文件,谢谢。
wanzihrg
帖子: 223
注册时间: 2008-03-15 10:34
送出感谢: 0
接收感谢: 0

#2

帖子 wanzihrg » 2008-07-02 23:36

这样吧,你把livccd放进光驱,然后从光盘启动,在终端中输入sudo grub
然后输入find /boot/grub/stage1
然后出现一个东西,比如说出现(hd0,2)
你就再输入root (hd0,2)
最后输入setup (hd0)
要是提示成功就可以重启了,grub应该出现了
yayaku
帖子: 15
注册时间: 2007-11-07 20:55
送出感谢: 0
接收感谢: 0

#3

帖子 yayaku » 2008-07-03 8:54

wanzihrg 写了:这样吧,你把livccd放进光驱,然后从光盘启动,在终端中输入sudo grub
然后输入find /boot/grub/stage1
然后出现一个东西,比如说出现(hd0,2)
你就再输入root (hd0,2)
最后输入setup (hd0)
要是提示成功就可以重启了,grub应该出现了


提示错误
Error 12: Invalid device requested
怎样解决,在线等,谢谢。顺便我把分区贴出来,看看有没有不对的。
附件
Screenshot--dev-sda - GParted.png
wanzihrg
帖子: 223
注册时间: 2008-03-15 10:34
送出感谢: 0
接收感谢: 0

#4

帖子 wanzihrg » 2008-07-05 1:51

我感觉照我说的应该米问题的,不过也可能你系统米装好,需要重新安装一遍

帮顶
1234qw
帖子: 389
注册时间: 2007-12-31 11:40
送出感谢: 0
接收感谢: 0

#5

帖子 1234qw » 2008-07-05 14:12

重装吧,建议你分区时分成3主分区1扩展分区
wanzihrg
帖子: 223
注册时间: 2008-03-15 10:34
送出感谢: 0
接收感谢: 0

#6

帖子 wanzihrg » 2008-07-05 15:02

的确,楼主分了四个主分区导致剩下140G米法使用了,因为硬盘上最多只能有四个主分区或3个主分区一个扩展分区,所以先分三个主分区,分一个扩展分区,再在扩展分区里面建逻辑分区
头像
cnkilior
论坛版主
帖子: 4979
注册时间: 2007-08-05 17:40
送出感谢: 0
接收感谢: 5 次

#7

帖子 cnkilior » 2008-07-05 15:48

建议重装。这样分区硬盘的空闲空间算废掉了,最多4个主分区你全用掉了!哎!

---------------
重分区+重装两个系统!

--------------

建议:sda1主分区;sda2主分区,扩展分区;sda5在sda2中的逻辑分区;sda6在sda2中的逻辑分区。。。以及sda789在sda2中的逻辑分区!
回复

回到 “老旧版本支持”