Please, run the configure script as first. what should i do?

为当前最终发行版之前的所有版本提供支持
回复
317248296
帖子: 6
注册时间: 2006-10-29 0:08
送出感谢: 0
接收感谢: 0

Please, run the configure script as first. what should i do?

#1

帖子 317248296 » 2008-07-04 2:16

Please, run the configure script as first.

what should i do?

安装声卡驱动的时候总是出现Please, run the configure script as first. what should i do?

能后安装过程就卡在这了




再附点详细的


bamboo@bamboo-desktop:~/alsa-driver-1.0.16$ sudo ./configure --with-cards=hda-intel
[sudo] password for bamboo:
checking for gcc... gcc
checking for C compiler default output file name... a.out
checking whether the C compiler works... yes
checking whether we are cross compiling... no
checking for suffix of executables...
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether gcc accepts -g... yes
checking for gcc option to accept ISO C89... none needed
checking for ranlib... ranlib
checking for a BSD-compatible install... /usr/bin/install -c
checking how to run the C preprocessor... gcc -E
checking for grep that handles long lines and -e... /bin/grep
checking for egrep... /bin/grep -E
checking for ANSI C header files... yes
checking for an ANSI C-conforming const... yes
checking for inline... inline
checking whether time.h and sys/time.h may both be included... yes
checking whether gcc needs -traditional... no
checking for current directory... /home/bamboo/alsa-driver-1.0.16
checking cross compile...
checking for directory with kernel source... /usr/src/linux
checking for directory with kernel build...
checking for kernel linux/version.h... no
The file /usr/src/linux/include/linux/version.h does not exist.
Please install the package with full kernel sources for your distribution
or use --with-kernel=dir option to specify another directory with kernel
sources (default is /usr/src/linux).
bamboo@bamboo-desktop:~/alsa-driver-1.0.16$ sudo make
make all-deps
make[1]: Entering directory `/home/bamboo/alsa-driver-1.0.16'
make[1]: 没有什么可以做的为 `all-deps'。
make[1]: Leaving directory `/home/bamboo/alsa-driver-1.0.16'

Please, run the configure script as first...

bamboo@bamboo-desktop:~/alsa-driver-1.0.16$ make install
if [ -L /include/sound ]; then \
rm -f /include/sound; \
ln -sf /home/bamboo/alsa-driver-1.0.16/include/sound /include/sound; \
else \
rm -rf /include/sound; \
install -d -m 755 -g root -o root /include/sound; \
for f in include/sound/*.h; do \
install -m 644 -g root -o root $f /include/sound; \
done \
fi
rm: 无法删除目录 “/include/sound”: Permission denied
install: 无法对 “include/sound/*.h” 执行 stat 调用: 没有该文件或目录
make: *** [install-headers] 错误 1
bamboo@bamboo-desktop:~/alsa-driver-1.0.16$
附件
14.png
上次由 317248296 在 2008-07-04 12:28,总共编辑 3 次。
头像
jarryson
帖子: 4002
注册时间: 2005-08-14 19:53
送出感谢: 1 次
接收感谢: 2 次
联系:

#2

帖子 jarryson » 2008-07-04 3:03

./configure +参数,不知道参数的看./configure --help

多看readme
317248296
帖子: 6
注册时间: 2006-10-29 0:08
送出感谢: 0
接收感谢: 0

#3

帖子 317248296 » 2008-07-04 9:34

:cry: 我那英语水平看不了全英文的帮助
317248296
帖子: 6
注册时间: 2006-10-29 0:08
送出感谢: 0
接收感谢: 0

#4

帖子 317248296 » 2008-07-04 10:04

而且我也加了./configure --with-cards=hda-intel 参数~
头像
ChloeRei
帖子: 1021
注册时间: 2007-11-23 9:49
送出感谢: 0
接收感谢: 1 次

#5

帖子 ChloeRei » 2008-07-04 10:39

The file /usr/src/linux/include/linux/version.h does not exist.
Please install the package with full kernel sources for your distribution

该怎么装我忘了……
317248296
帖子: 6
注册时间: 2006-10-29 0:08
送出感谢: 0
接收感谢: 0

#6

帖子 317248296 » 2008-07-04 12:14

:cry: 没有更有力更简洁的回答吗?
头像
solcomo
帖子: 2838
注册时间: 2007-04-25 13:12
送出感谢: 0
接收感谢: 0
联系:

#7

帖子 solcomo » 2008-07-04 12:18

configure没过...
♜♞♝♛♚♝♞♜
♟♟♟♟♟♟♟♟
♙♙♙♙♙♙♙♙
♖♘♗♕♔♗♘♖

☠☯⚔⚓☣☦☃☕
☹☻☪☭☬⚖⚛⚜
ℜℳℬ™ ℋℯℓ℘ ℳℭ
sƂɐʍ рǀɹoʍ əɥʇ oS
317248296
帖子: 6
注册时间: 2006-10-29 0:08
送出感谢: 0
接收感谢: 0

#8

帖子 317248296 » 2008-07-04 14:46

solcomo 写了:configure没过...

?????????????????????????????
头像
HuntXu
论坛版主
帖子: 5778
注册时间: 2007-09-29 3:09
送出感谢: 0
接收感谢: 6 次

#9

帖子 HuntXu » 2008-07-04 15:08

checking for kernel linux/version.h... no
The file /usr/src/linux/include/linux/version.h does not exist.
Please install the package with full kernel sources for your distribution
or use --with-kernel=dir option to specify another directory with kernel
sources (default is /usr/src/linux).


ln -sfv /usr/src/linux-***(取决你原本的是什么) /usr/src/linux

或者./configure --with-kernel=/usr/src/linux-***
HUNT Unfortunately No Talent...
zigzed
帖子: 267
注册时间: 2006-02-27 10:32
送出感谢: 0
接收感谢: 0

#10

帖子 zigzed » 2008-07-04 15:27

1. 安装内核源代码而不是头文件 (sudo aptitude install linux-source)
2. ./configure没有必要sudo
3. make没有必要sudo
4. 必须使用 sudo make install,因为安装的时候需要对某些系统目录有写的权限。
头像
jarryson
帖子: 4002
注册时间: 2005-08-14 19:53
送出感谢: 1 次
接收感谢: 2 次
联系:

#11

帖子 jarryson » 2008-07-04 15:56

ls正解。你干嘛./configure和make的时候加sudo,这样出来的文件你是没有权限访问的,但是一直加sudo也是可以的,make intsall的时候不加sudo你没有权限写入/分区
回复

回到 “老旧版本支持”