pidgin 安装问题

为当前最终发行版之前的所有版本提供支持
回复
superzy
帖子: 14
注册时间: 2007-10-18 16:46
送出感谢: 0
接收感谢: 0

pidgin 安装问题

#1

帖子 superzy » 2008-07-04 17:38

在编译安装pidgin时,报错:
Neither GnuTLS or NSS SSL development headers found.
是缺少什么依赖项呢?

我是菜鸟,第一次编译安装软件。在别人blog上查到安装时可能遇到的一些却少依赖项问题:
XScreenSaver extension development headers not found.: libxss-dev

Startup notification development headers not found.: libstartup-notification0-dev

GStreamer development headers not found.: libgstreamer0.10-dev

Meanwhile development headers not found.: libmeanwhile-dev

D-Bus development headers not found.: libdbus-1-dev libdbus-glib-1-dev

NetworkManager development headers not found.: network-manager-dev

Perl development headers not found.: libperl-dev

Tcl development headers not found.: tcl8.4-dev

Tk development headers not found.: tk8.4.dev

GtkSpell development headers not found.:libgtkspell-dev

avahi development headers not found.:libavahi-client-dev libavahi-glib-d
就是这个没有。

请问,怎么根据编译错误提示而知道是缺少什么依赖项呢?
头像
jimhu
帖子: 1322
注册时间: 2006-01-25 22:29
来自: 上海
送出感谢: 0
接收感谢: 0
联系:

#2

帖子 jimhu » 2008-07-04 18:17

Neither GnuTLS or NSS SSL development headers found.

提示说没有找到GnuTLS开发头文件库,也没有找到NSS SSL开发头文件库。

一般解决方法就是在新立得里面搜索GNUTLS或者NSS SSL,看看有没有带dev的相关软件包没有安装。装上就可以了吧。如果源里没有的话,就google一下,下载源代码,编译安装应该就可以了。
* MACBOOK MB063CH/B
OS:Snow Leopard/XP
* AMD X2 3600+/2G RAM/160GB+500GB Seagate/7300GT
OS:Arch/Vista

Kubuntu User #18899

=================================
Full Circle中文杂志 | Ubuntu社区独立发行的电子月刊
http://www.freeearth.org.cn
superzy
帖子: 14
注册时间: 2007-10-18 16:46
送出感谢: 0
接收感谢: 0

#3

帖子 superzy » 2008-07-04 18:38

谢谢ls,报错我能看明白。问题是我怎么知道缺少的包叫什么名字呢?
譬如我现在又遇到错诉:configure: error: Cyrus SASL library not found
新立得里面关键字搜索出很多,我怎么知道应该装哪个?
头像
cnkilior
论坛版主
帖子: 4979
注册时间: 2007-08-05 17:40
送出感谢: 0
接收感谢: 5 次

#4

帖子 cnkilior » 2008-07-04 18:56

我记得apt有个工具能解决编译依赖,好久没有弄了,忘了。
可以问问男人!
头像
carbont
帖子: 3406
注册时间: 2007-11-22 10:20
来自: 北京
送出感谢: 0
接收感谢: 1 次

#5

帖子 carbont » 2008-07-04 18:59

cnkilior 写了:我记得apt有个工具能解决编译依赖,好久没有弄了,忘了。
可以问问男人!

代码: 全选

sudo apt-get build-dep
是这个么??
我也好久没有编译过了——好久都没有装过什么新的软件了也。
lenovo Thinkpad R60i 0657 LHC
windowsXP……准备换回ubuntu了。

Twitter: @carbont
poet
帖子: 2841
注册时间: 2006-09-11 22:47
送出感谢: 0
接收感谢: 4 次

#6

帖子 poet » 2008-07-04 20:22

sudo apt-get build-dep pidgin

许多人就是不愿意用apt-get,但是apt-get能做的事情新力得根本做不了。
gulch
帖子: 188
注册时间: 2006-11-27 1:00
送出感谢: 0
接收感谢: 0

#7

帖子 gulch » 2008-07-05 23:20

sudo apt-get install libnspr4-dev libnss3-dev libgnutls-dev
回复

回到 “老旧版本支持”