当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 9 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : [问题]8.o4下 eclipse不能用
帖子发表于 : 2008-07-07 11:35 

注册: 2007-07-05 17:22
帖子: 14
送出感谢: 0 次
接收感谢: 0 次
使用apt的方式安装了sun的JKD6 在终端运行java -version也是出来的 结果是正确的..
下载eclipse并解压到opt目录 并运行 eclipse提示我设置workspace 然后点确定.
这时候弹出一个光秃秃的窗口 没有字也没有按钮 .标题是eclipse。
这会是那里出错了阿 搜索了下 有的说要在home的.mozilla下建立eclipse目录,但是我建了效果还是一样
WIKI上好像没有相关的文章 。聊天室也没有解答 ...


页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2008-07-07 11:45 
头像

注册: 2007-04-06 10:24
帖子: 2487
地址: ~/Shanghai
送出感谢: 0 次
接收感谢: 0 次
cat ~/yourworkspace/.metadata/.log > eclipse.log

帖出来看看,或者自己看看哪里出错


_________________
http://silenceisdefeat.com/~greco
代码:
''.join([chr(ord(c)-2) for c in 'O{"G/ockn"ku<"itgeq0ujkBiockn0eqo'])
echo -n "Z3JlY28uc2hpQGdtYWlsLmNvbQ==" | base64 -d


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2008-07-07 12:34 

注册: 2007-07-05 17:22
帖子: 14
送出感谢: 0 次
接收感谢: 0 次
错误日志在workspace 下 居然忘了 傻傻的在eclipse下找了半天....
googl 了下 没找到解决的办法...

java.lang.RuntimeException: Widget disposed too early!
at org.eclipse.ui.internal.WorkbenchPartReference$1.widgetDisposed(WorkbenchPartReference.java:171)
at org.eclipse.swt.widgets.TypedListener.handleEvent(TypedListener.java:117)
at org.eclipse.swt.widgets.EventTable.sendEvent(EventTable.java:84)

!MESSAGE Application error
!STACK 1
org.eclipse.swt.SWTError: XPCOM error -2147467262
at org.eclipse.swt.browser.Mozilla.error(Mozilla.java:1597)
at org.eclipse.swt.browser.Mozilla.setText(Mozilla.java:1820)
at org.eclipse.swt.browser.Browser.setText(Browser.java:737)


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2008-07-07 14:47 

注册: 2007-07-05 17:22
帖子: 14
送出感谢: 0 次
接收感谢: 0 次
在eclipse的论坛看到这样的解决办法 试了试 还是不行...

download the SWT binaries for Linux.
Installation procedure:

* unpack the archive: swt-*-linux-gtk.zip
* copy libswt*.so to
%JAVA_HOME%/jre/lib/i386, (%JAVA_HOME% is the folder where JRE is
installed on your system; e.g.: opt/jdk1.5._07),
* copy swt.jar to %JAVA_HOME%/jre/lib/ext


页首
 用户资料  
 
5 楼 
 文章标题 :
帖子发表于 : 2008-07-07 15:39 

注册: 2007-07-05 17:22
帖子: 14
送出感谢: 0 次
接收感谢: 0 次
问题解决了 我记得我把解决办法贴上来了 怎么不见了...

算了 懒得再找了 xulrunner禁用就可以了 在eclipse 的bug列表上可以看到这个


页首
 用户资料  
 
6 楼 
 文章标题 :
帖子发表于 : 2008-07-09 10:18 

注册: 2007-12-24 10:34
帖子: 15
送出感谢: 0 次
接收感谢: 0 次
你应该些详细点但还是有些帮助


页首
 用户资料  
 
7 楼 
 文章标题 :
帖子发表于 : 2008-07-09 17:31 

注册: 2008-07-09 17:30
帖子: 1
送出感谢: 0 次
接收感谢: 0 次
http://www.eclipseworld.org/bbs/read-ce ... age-6.html

看看这个连接,或许有帮助。


页首
 用户资料  
 
8 楼 
 文章标题 :
帖子发表于 : 2008-07-23 8:53 

注册: 2007-07-26 14:25
帖子: 39
送出感谢: 0 次
接收感谢: 0 次
试试把firefox升级到3.0, 8.04带的那个会和eclipse有冲突,我的一升级就OK了


页首
 用户资料  
 
9 楼 
 文章标题 :
帖子发表于 : 2008-08-18 14:07 

注册: 2006-06-23 15:43
帖子: 3
送出感谢: 0 次
接收感谢: 0 次
我也发生了这个问题,是因为MOZILLA_FIVE_HOME的关系,xulrunner的libgtkembedmoz.so不行,后来用了thunderbird的就好了。
sudo gedit /usr/bin/eclipse
加入
elif [ -e /usr/lib/thunderbird/libgtkembedmoz.so ]; then
export MOZILLA_FIVE_HOME=/usr/lib/thunderbird


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 9 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 4 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译