[已解决]安装amavisd-new出错,请各位帮忙

为当前最终发行版之前的所有版本提供支持
回复
nfddy
帖子: 22
注册时间: 2008-04-02 10:14
送出感谢: 0
接收感谢: 0

[已解决]安装amavisd-new出错,请各位帮忙

#1

帖子 nfddy » 2008-07-08 8:10

用apt-get install amavisd-new出错如下错误,不知如何解决。

Reading package lists... Done
Building dependency tree
Reading state information... Done
0 upgraded, 0 newly installed, 0 to remove and 5 not upgraded.
1 not fully installed or removed.
After this operation, 0B of additional disk space will be used.
Setting up amavisd-new (1:2.5.3-1ubuntu3) ...
Creating/updating amavis user account...
Broken amavis system user found. To insure data-safety,
it is up to you the local administrator to remove the broken
amavis user, or repair it so that it is sane
dpkg: error processing amavisd-new (--configure):
subprocess post-installation script returned error exit status 1
Errors were encountered while processing:
amavisd-new
E: Sub-process /usr/bin/dpkg returned an error code (1)
上次由 nfddy 在 2008-07-10 8:41,总共编辑 1 次。
海精灵
帖子: 111
注册时间: 2008-06-26 15:47
送出感谢: 0
接收感谢: 0
联系:

#2

帖子 海精灵 » 2008-07-08 12:33

路过,顶
nfddy
帖子: 22
注册时间: 2008-04-02 10:14
送出感谢: 0
接收感谢: 0

#3

帖子 nfddy » 2008-07-10 8:41

问题已自行解决。要先建立用户和目录,设置目录权限即可。
# sudo adduser amavis amavis
# sudo mkdir /var/lib/amavis
# sudo chown -R amavis:amavis amavis
# sudo apt-get install amavisd-new
回复

回到 “老旧版本支持”