当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 5 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : [问题]可不可以指定某个软件用指定的GCC版本??
帖子发表于 : 2008-07-08 11:25 

注册: 2008-06-18 20:31
帖子: 24
送出感谢: 0 次
接收感谢: 0 次
各位好!!小弟初学者。有个问题请教目前我UBUNTU的GCC版本是4.2.3的,我要用的一个软件的版本规定GCC是要4.1才能工作,那我现在的GCC是不是能向下兼容这个软件正常运行,还是要把现在我用的GCC版本降下来?能不能我现在同时安装GCC4.1然后指定这个软件运行GCC4.1呢??
有什么好的方法解决这个问题请高手详细赐教!!!!
Linux version 2.6.24-19-generic (buildd@yellow) (gcc version 4.2.3 (Ubuntu 4.2.3-2ubuntu7)) #1 SMP Wed Jun 18 14:15:37 UTC 2008


页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2008-07-08 11:54 
头像

注册: 2005-08-25 13:58
帖子: 808
地址: ustc
送出感谢: 0 次
接收感谢: 0 次
源里有gcc4.1,编译的时候加上参数 -V 4.1


_________________
爱喝真猪奶茶的夜鸣猪


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2008-07-08 13:32 

注册: 2008-06-18 20:31
帖子: 24
送出感谢: 0 次
接收感谢: 0 次
请问怎么编译具体步骤怎么样呢??我新手以前没碰过编译,怕搞坏了呵呵,楼上的能说说吗?


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2008-07-08 23:00 

注册: 2008-06-18 20:31
帖子: 24
送出感谢: 0 次
接收感谢: 0 次
谁愿意回答??给我个方向也好WIKI里没找到


页首
 用户资料  
 
5 楼 
 文章标题 :
帖子发表于 : 2008-07-09 9:25 
头像

注册: 2005-08-25 13:58
帖子: 808
地址: ustc
送出感谢: 0 次
接收感谢: 0 次
huangling2000 写道:
请问怎么编译具体步骤怎么样呢??我新手以前没碰过编译,怕搞坏了呵呵,楼上的能说说吗?

不知你那个是怎么编译的。有configure脚本吗?还是直接make的?


_________________
爱喝真猪奶茶的夜鸣猪


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 5 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 5 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译