请问怎样能把firebox的xulrunner卸掉

为当前最终发行版之前的所有版本提供支持
回复
liuzxit
帖子: 8
注册时间: 2008-07-07 23:33
送出感谢: 0
接收感谢: 0

请问怎样能把firebox的xulrunner卸掉

#1

帖子 liuzxit » 2008-07-08 23:32

现在我的xulrunner跟eclipse冲突, 我必须要删掉xulrunner, 但删掉后firefox又无法启动了, 我想从firefox的"管理附加元件"中把它卸掉, 但它的"uninstall"按钮却是灰色的,请问有没有办法让它卸掉还能保证firefox正常启动
头像
kofshower
帖子: 1343
注册时间: 2007-03-13 11:23
送出感谢: 0
接收感谢: 0
联系:

#2

帖子 kofshower » 2008-07-09 0:35

xulrunner是Firefox的Gecko runtime.开发过Mozilla平台的话就知道这个模块是负责网页的渲染的。要改的话不该直接卸载。ff3是直接跑在xulrunner上的。ff2不是。我想这是Eclipse的问题,完全没有考虑到ff的变化。我觉得要搞的话,直接卸载ff。然后下载一个ff3 for linux安装包。安装在其他路径。然后符号连接一个到桌面活菜单用
上次由 kofshower 在 2008-07-09 0:39,总共编辑 1 次。
"We are all in the mud, but some of us are looking at the stars." (Oscar Wilde)
We are not born for ourselves.
人生天地间,并非为自己
Homepage:http://sites.google.com/site/polarisnotme/
头像
hubert_star
论坛版主
帖子: 5372
注册时间: 2007-10-29 22:12
系统: OSX 10.9 + Ub 1304
来自: 江苏南京
送出感谢: 0
接收感谢: 5 次

Re: 请问怎样能把firebox的xulrunner卸掉

#3

帖子 hubert_star » 2008-07-09 0:38

liuzxit 写了:现在我的xulrunner跟eclipse冲突, 我必须要删掉xulrunner, 但删掉后firefox又无法启动了, 我想从firefox的"管理附加元件"中把它卸掉, 但它的"uninstall"按钮却是灰色的,请问有没有办法让它卸掉还能保证firefox正常启动
不知道是怎么个冲突法?
佛经说,人有八苦: 生、老、病、死、求不得、怨憎、爱别离、五阴盛 故我苦!
圣经说,人有七罪: 饕餮、贪婪、懒惰、淫欲、傲慢、嫉妒和暴怒  故我有罪!

我这篇帖子里面没有任何攻击我们伟大的中华人民共和国政府和任劳任怨的人民公仆(和本论坛高素质的版主)的文字和含义;

特此声明!

有些事,我们明知道是错的,也要去坚持,因为不甘心;有些人,我们明知道是爱的,也要去放弃,因为没结局;有时候,我们明知道没路了,却还在前行,因为习惯了。

欢迎来我的新浪微博@me
liuzxit
帖子: 8
注册时间: 2008-07-07 23:33
送出感谢: 0
接收感谢: 0

#4

帖子 liuzxit » 2008-07-09 8:27

冲突情况是:只要xulrunner保留,eclipse就不能完成启动,启动了大半后就弹出一个eclipse的空白内容框,然后关也关不掉,只能直接kill进程
liuzxit
帖子: 8
注册时间: 2008-07-07 23:33
送出感谢: 0
接收感谢: 0

#5

帖子 liuzxit » 2008-07-09 10:45

我现在把原有的firefox删掉,重新下载了一个firefox-3.0.tar.bz2解压后直接使用,eclipse也可以正常使用了,但新的问题又来了, 我在eclipse建立一个项目后,启动浏览,结果无法调出firefox,提示"file not found: firefox", 我在ubuntu的首选项更改了"web浏览器"为新的firefox的对应位置(其实我把新的firefox放在原来的firefox的路径上,所以启动位置其实是一样的),但问题依旧,

请问我在哪里可设置到让eclipse调用并打开firefox
fbsd4
帖子: 174
注册时间: 2007-03-19 8:07
送出感谢: 0
接收感谢: 0

#6

帖子 fbsd4 » 2008-07-09 10:58

你看看能不能装一个xul-runner1.8X上去。

ff3的是xul-runner1.9X。
头像
bones7456
论坛版主
帖子: 8495
注册时间: 2006-04-12 20:05
来自: 杭州
送出感谢: 0
接收感谢: 8 次
联系:

#7

帖子 bones7456 » 2008-07-09 11:02

我的 eclipse 和 ff3 都正常.
关注我的blog: ε==3
头像
kofshower
帖子: 1343
注册时间: 2007-03-13 11:23
送出感谢: 0
接收感谢: 0
联系:

#8

帖子 kofshower » 2008-07-09 12:02

liuzxit 写了:我现在把原有的firefox删掉,重新下载了一个firefox-3.0.tar.bz2解压后直接使用,eclipse也可以正常使用了,但新的问题又来了, 我在eclipse建立一个项目后,启动浏览,结果无法调出firefox,提示"file not found: firefox", 我在ubuntu的首选项更改了"web浏览器"为新的firefox的对应位置(其实我把新的firefox放在原来的firefox的路径上,所以启动位置其实是一样的),但问题依旧,

请问我在哪里可设置到让eclipse调用并打开firefox
如果你有做过/usr/bin/firefox /usr/lib/firefox /usr/share/firefox这三处的符号链接,确认么?
此外Eclipse一定是可以设置使用的explorer的,不然用各中浏览器调试的时候怎么办,只是我手头没有这个东西,没法看
"We are all in the mud, but some of us are looking at the stars." (Oscar Wilde)
We are not born for ourselves.
人生天地间,并非为自己
Homepage:http://sites.google.com/site/polarisnotme/
liuzxit
帖子: 8
注册时间: 2008-07-07 23:33
送出感谢: 0
接收感谢: 0

#9

帖子 liuzxit » 2008-07-09 12:23

谢谢kofshower提醒, 确实eclipse可以选择browser, 现在我设置了该选项, 问题全部解决了
头像
kofshower
帖子: 1343
注册时间: 2007-03-13 11:23
送出感谢: 0
接收感谢: 0
联系:

#10

帖子 kofshower » 2008-07-09 16:14

那就好,xulrunner是一个和NET FRAMEWORK完全对等的开发框架。里面其实不止有Gecko。还有跨平台的c-api,com库,网络库necko之类的。一些软件可能会依赖到它,所以最好别卸载。特别是做开发的话,IBM有些东西用的就是这个平台的
"We are all in the mud, but some of us are looking at the stars." (Oscar Wilde)
We are not born for ourselves.
人生天地间,并非为自己
Homepage:http://sites.google.com/site/polarisnotme/
回复

回到 “老旧版本支持”