[问题]怎样解决依赖问题?

为当前最终发行版之前的所有版本提供支持
回复
戆蝈蝈
帖子: 4
注册时间: 2008-01-25 10:59
送出感谢: 0
接收感谢: 0

[问题]怎样解决依赖问题?

#1

帖子 戆蝈蝈 » 2008-07-15 9:29

新手一个,想学习deb文件安装vmware(不用apt-get安装,不用新立得),提示依赖问题,请教怎样解决

dpkg:依赖关系问题使得 vmware-package 的配置工作不能继续:
vmware-package 依赖于 debhelper (>> 5);然而:
未曾安装软件包“debhelper”。
vmware-package 依赖于 dpkg-dev;然而:
未曾安装软件包“dpkg-dev”。
vmware-package 依赖于 fakeroot;然而:
未曾安装软件包“fakeroot”。
vmware-package 依赖于 libgnomecanvasmm-2.6-1c2a;然而:
未曾安装软件包“libgnomecanvasmm-2.6-1c2a”。
vmware-package 依赖于 libsexymm2;然而:
未曾安装软件包“libsexymm2”。
vmware-package 依赖于 libstdc++5;然而:
未曾安装软件包“libstdc++5”。
vmware-package 依赖于 libview2;然而:
未曾安装软件包“libview2”。
vmware-package 依赖于 module-assistant;然而:
未曾安装软件包“module-assistant”。
vmware-package 依赖于 prelink;然而:
未曾安装软件包“prelink”。
dpkg:处理 vmware-package (--install)时出错:
依赖关系问题 - 仍未被配置
在处理时有错误发生:
vmware-package
头像
luojie-dune
帖子: 22033
注册时间: 2007-07-30 18:28
系统: Linux
来自: 空气中
送出感谢: 9 次
接收感谢: 61 次

#2

帖子 luojie-dune » 2008-07-15 9:47

apt安装或者手动一个一个编译。
『这个世界都是我的 ,我爱你们』

ENTP ⥂ INTP ⥄ INFP ⇦ INTJ

在此发布的文章使用 Creative Commons Attribution-ShareAlike 4.0 协议
头像
jimhu
帖子: 1322
注册时间: 2006-01-25 22:29
来自: 上海
送出感谢: 0
接收感谢: 0
联系:

#3

帖子 jimhu » 2008-07-15 11:25

用新立得一个一个把这些缺失的软件包全装上,然后再装DEB包就可以了。
* MACBOOK MB063CH/B
OS:Snow Leopard/XP
* AMD X2 3600+/2G RAM/160GB+500GB Seagate/7300GT
OS:Arch/Vista

Kubuntu User #18899

=================================
Full Circle中文杂志 | Ubuntu社区独立发行的电子月刊
http://www.freeearth.org.cn
delectate
帖子: 18311
注册时间: 2008-01-09 22:41
送出感谢: 0
接收感谢: 6 次

#4

帖子 delectate » 2008-07-15 14:51

全部apt即可

太麻烦了,看起来比编译wine还累 :shock:
头像
mghohoo
帖子: 364
注册时间: 2008-07-13 18:29
来自: 广州
送出感谢: 0
接收感谢: 0

#5

帖子 mghohoo » 2008-07-15 19:14

archlinux的pacman 方便阿,自动安装,删除也方便
戆蝈蝈
帖子: 4
注册时间: 2008-01-25 10:59
送出感谢: 0
接收感谢: 0

#6

帖子 戆蝈蝈 » 2008-07-15 21:04

就没有工具能一次过安装吗?这样不是很麻烦
头像
luojie-dune
帖子: 22033
注册时间: 2007-07-30 18:28
系统: Linux
来自: 空气中
送出感谢: 9 次
接收感谢: 61 次

#7

帖子 luojie-dune » 2008-07-15 21:09

楼主难道不是自找的?
『这个世界都是我的 ,我爱你们』

ENTP ⥂ INTP ⥄ INFP ⇦ INTJ

在此发布的文章使用 Creative Commons Attribution-ShareAlike 4.0 协议
回复

回到 “老旧版本支持”