怎么这么多更新,烦死了。。

为当前最终发行版之前的所有版本提供支持
denzeljiang
帖子: 13
注册时间: 2007-06-12 1:01
送出感谢: 0
接收感谢: 0

怎么这么多更新,烦死了。。

#1

帖子 denzeljiang » 2008-07-21 10:09

几乎每天都下几十MB的更新,内核都有好几个版本了。。。

每次启动,grub里面都是一长串 不同内核的启动选项

但是有些内核连X都启动不起来。。。 不知道更新了又啥用。。

大家都是有更新就下的吗?
头像
bocelli99
帖子: 525
注册时间: 2007-07-10 12:16
送出感谢: 0
接收感谢: 0

#2

帖子 bocelli99 » 2008-07-21 10:20

有更新我是一定要上的
删旧内核:
uname -a  #使用这个命令可以查看当前系统使用的内核。
dpkg --get-selections|grep linux #列出当前内核。带image的则是已经安装的内核,用以下命令卸载:sudo apt-get remove linux-image-2.6.24-19-generic #其中 linux-image-2.6.24-19-generic 为版本号,输全 。
或者
新立得,搜索linux,把旧版本号的全部删除就是
grub/menu.lst也会自动改的。
还有可以搜论坛ee的神谕 :lol:
像一条秋天的道路:还未来得及扫干净,它又为干枯的树叶所覆盖。

The Kafka Project http://www.kafka.org
denzeljiang
帖子: 13
注册时间: 2007-06-12 1:01
送出感谢: 0
接收感谢: 0

#3

帖子 denzeljiang » 2008-07-21 10:29

libselinux1 install
linux-generic install
linux-headers-2.6.24-16 install
linux-headers-2.6.24-16-generic install
linux-headers-2.6.24-17 install
linux-headers-2.6.24-17-generic install
linux-headers-2.6.24-19 install
linux-headers-2.6.24-19-generic install
linux-headers-generic install
linux-image-2.6.24-16-generic install
linux-image-2.6.24-17-generic install
linux-image-2.6.24-19-generic install
linux-image-generic install
linux-libc-dev install
linux-restricted-modules-2.6.24-16-generic install
linux-restricted-modules-2.6.24-17-generic install
linux-restricted-modules-2.6.24-19-generic install
linux-restricted-modules-common install
linux-restricted-modules-generic install
linux-sound-base install
linux-ubuntu-modules-2.6.24-16-generic install
linux-ubuntu-modules-2.6.24-17-generic install
linux-ubuntu-modules-2.6.24-19-generic install
util-linux install
util-linux-locales install
当前是:
Linux denzel 2.6.24-16-generic
一直用的最老的。。。 [/quote]
头像
bocelli99
帖子: 525
注册时间: 2007-07-10 12:16
送出感谢: 0
接收感谢: 0

#4

帖子 bocelli99 » 2008-07-21 10:38

我的是2.6.24-20-generic
像一条秋天的道路:还未来得及扫干净,它又为干枯的树叶所覆盖。

The Kafka Project http://www.kafka.org
头像
syrano
帖子: 4313
注册时间: 2007-10-06 18:40
送出感谢: 0
接收感谢: 5 次

#5

帖子 syrano » 2008-07-21 10:45

bocelli99 写了:我的是2.6.24-20-generic
我的是2.6.26
E=m c^2
头像
bocelli99
帖子: 525
注册时间: 2007-07-10 12:16
送出感谢: 0
接收感谢: 0

#6

帖子 bocelli99 » 2008-07-21 10:49

syrano 写了:
bocelli99 写了:我的是2.6.24-20-generic
我的是2.6.26
爱因斯坦自己编译的??
像一条秋天的道路:还未来得及扫干净,它又为干枯的树叶所覆盖。

The Kafka Project http://www.kafka.org
hjy273
帖子: 62
注册时间: 2007-07-31 12:52
送出感谢: 0
接收感谢: 0

#7

帖子 hjy273 » 2008-07-21 10:52

bocelli99 写了:
syrano 写了:
bocelli99 写了:我的是2.6.24-20-generic
我的是2.6.26
爱因斯坦自己编译的??
头像
JangMunho
帖子: 1347
注册时间: 2006-01-18 12:55
来自: 也许真的没有人理解
送出感谢: 0
接收感谢: 1 次

#8

帖子 JangMunho » 2008-07-21 10:54

不要更新,小心系统彻底崩溃……
MacBook Pro 15" User
Cocoa Programmer
tlze
帖子: 61
注册时间: 2008-02-21 19:36
送出感谢: 0
接收感谢: 0
联系:

#9

帖子 tlze » 2008-07-21 11:07

我就天天更新看一下有没有什么新东西,喜欢尝新。还没见过更新后会有什么大问题。
ko2k8
帖子: 88
注册时间: 2008-05-16 11:26
送出感谢: 0
接收感谢: 0

#10

帖子 ko2k8 » 2008-07-21 11:19

我也觉得好烦,好累,但是为了安全也要更新,
头像
skyx
论坛版主
帖子: 9203
注册时间: 2006-12-23 13:46
来自: Azores Islands
送出感谢: 0
接收感谢: 1 次
联系:

#11

帖子 skyx » 2008-07-21 11:25

ko2k8 写了:我也觉得好烦,好累,但是为了安全也要更新,
security 和update的源加上就行了,proposed 源是用来测试的,不是小白最好不要加。


security 源中安全方面的更新很少。其实系统配好了,只要把security源加上,安全就有了。当然一般办公家用把update加上更好。
no security measure is worth anything if an attacker has physical access to the machine
ko2k8
帖子: 88
注册时间: 2008-05-16 11:26
送出感谢: 0
接收感谢: 0

#12

帖子 ko2k8 » 2008-07-21 11:40

skyx 写了:
ko2k8 写了:我也觉得好烦,好累,但是为了安全也要更新,
security 和update的源加上就行了,proposed 源是用来测试的,不是小白最好不要加。


security 源中安全方面的更新很少。其实系统配好了,只要把security源加上,安全就有了。当然一般办公家用把update加上更好。
收到
头像
jarryson
帖子: 4002
注册时间: 2005-08-14 19:53
送出感谢: 1 次
接收感谢: 2 次
联系:

#13

帖子 jarryson » 2008-07-21 13:19

更新也不是全为了更安全,比如内核更新会更新bug,但是最多的还是实现更多新功能,支持更多硬件。

你也可以不更新,系统就这样就行了。不过安装新软件前最好更新,因为软件编译环境如果差别太大会有问题。

更新完内核,显卡驱动一般是无法使用的。除非也一起更新了显卡驱动
ko2k8
帖子: 88
注册时间: 2008-05-16 11:26
送出感谢: 0
接收感谢: 0

#14

帖子 ko2k8 » 2008-07-21 14:53

jarryson 写了:更新也不是全为了更安全,比如内核更新会更新bug,但是最多的还是实现更多新功能,支持更多硬件。

你也可以不更新,系统就这样就行了。不过安装新软件前最好更新,因为软件编译环境如果差别太大会有问题。

更新完内核,显卡驱动一般是无法使用的。除非也一起更新了显卡驱动
收到
seenxu
帖子: 229
注册时间: 2008-04-26 7:47
来自: 德国 斯图加特
送出感谢: 0
接收感谢: 0

#15

帖子 seenxu » 2008-07-21 18:32

把更新关闭,让系统强制在任务栏弹出长时间未更新的通知,一般是一周更新一次就可以了。
欢迎访问斯图论坛 stu-cn.de
回复

回到 “老旧版本支持”