关于1张网卡双 IP 的问题!

为当前最终发行版之前的所有版本提供支持
回复
hwe21
帖子: 20
注册时间: 2008-05-29 14:53
送出感谢: 0
接收感谢: 0

关于1张网卡双 IP 的问题!

#1

帖子 hwe21 » 2008-07-21 16:00

请问是不是在 etc/udev/rules.d/70-persistent-net.rules,增加一个eth0:ADSL的设置如下:
SUBSYSTEM=="net", ACTION=="add", DRIVERS=="?*", ATTR{address}=="00:14:2a:d5:bf:50", ATTR{type}=="1", KERNEL=="eth*", NAME="eth0"
SUBSYSTEM=="net", ACTION=="add", DRIVERS=="?*", ATTR{address}=="00:14:2a:d5:bf:50", ATTR{type}=="1", KERNEL=="eth*", NAME="eth0:AD" (这条是我加的)

在/network/interfaces,增加eth0:ADSL的相关设置如下:

auto lo
iface lo inet loopback


iface eth0 inet static
address 132.136.56.51
netmask 255.255.255.192
gateway 132.136.56.15
DNS 10.5.22.67


auto eth0:AD
iface eth0:AD inet static
address 192.168.1.5
netmask 255.255.0.0
gateway 192.168.1.1
DNS 202.96.199.133

auto eth0



现在我的问题是 通过192的地址上公网,或通过132的地址上内网 反应都是很慢。有时候会都打不开。这是我的设置问题吗?
我ping IP地址都很好,但ping 网址都是不通的,是DNS没有设好?(DNS都是ping的通的202.96.199.133)
头像
jialeadmin
帖子: 724
注册时间: 2008-06-17 23:17
来自: 灾区
送出感谢: 0
接收感谢: 0
联系:

#2

帖子 jialeadmin » 2008-07-21 16:05

是不是一个是内网IP 另一个是广域IP呢 这个我也不知道
◆WINDOWS系统已彻底删除
◆正在安装UBUNTU 9.04
◆系统正在复制文件,请稍等...
┌────────────┐
│ ■■■■■■■□□□ 70% │
└────────────┘
fjuser
帖子: 43
注册时间: 2008-07-06 15:27
送出感谢: 0
接收感谢: 0

#3

帖子 fjuser » 2008-07-21 16:15

你需要加默认路由

另外你没有把你的网络环境说清楚
hwe21
帖子: 20
注册时间: 2008-05-29 14:53
送出感谢: 0
接收感谢: 0

#4

帖子 hwe21 » 2008-07-21 17:09

fjuser 写了:你需要加默认路由

另外你没有把你的网络环境说清楚


请问路由如何设?
好比windows下的route add命令

我现在的route

hewei@hewei-ubuntu:~$ route
内核 IP 路由表
目标 网关 子网掩码 标志 跃点 引用 使用 接口
132.136.56.0 * 255.255.255.192 U 0 0 0 eth0
192.168.1.0 * 255.255.255.0 U 0 0 0 eth0
link-local * 255.255.0.0 U 1000 0 0 eth0
default 192.168.1.1 0.0.0.0 UG 100 0 0 eth0
hewei@hewei-ubuntu:~$

如何加一条可选的路由到网关192.168.1.1 本机IP:192.168.1.5
hwe21
帖子: 20
注册时间: 2008-05-29 14:53
送出感谢: 0
接收感谢: 0

#5

帖子 hwe21 » 2008-07-22 8:30

请问如何加路由呀?
回复

回到 “老旧版本支持”