当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 4 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : [问题]软件安装问题,始终装不了
帖子发表于 : 2008-07-21 20:51 

注册: 2008-07-21 16:34
帖子: 6
送出感谢: 0 次
接收感谢: 0 次
请教 。。。
装软件拿MP3举例 在软件目录下运行 ./configure后
tiger@tiger-desktop:~/pro/mp3blaster-3.2.0$ ./configure
loading cache ./config.cache
checking for a BSD compatible install... /usr/bin/install -c
checking whether build environment is sane... yes
checking whether make sets ${MAKE}... yes
checking for working aclocal-1.4... missing
checking for working autoconf... found
checking for working automake-1.4... missing
checking for working autoheader... found
checking for working makeinfo... missing
checking for gcc... gcc
checking whether the C compiler (gcc ) works... yes
checking whether the C compiler (gcc ) is a cross-compiler... no
checking whether we are using GNU C... yes
checking whether gcc accepts -g... yes
checking for c++... c++
checking whether the C++ compiler (c++ ) works... yes
checking whether the C++ compiler (c++ ) is a cross-compiler... no
checking whether we are using GNU C++... yes
checking whether c++ accepts -g... yes
checking whether ln -s works... yes
checking for a BSD compatible install... /usr/bin/install -c
checking for ranlib... ranlib
checking for working const... yes
checking whether byte ordering is bigendian... no
checking how to run the C preprocessor... gcc -E
checking whether gcc needs -traditional... no
checking for strdup... yes
checking for strstr... yes
checking for main in -lm... yes
checking for main in -lncurses... no
checking for main in -lcurses... no
checking for main in -lossaudio... no
checking for main in -lpthread... yes
checking for main in -lvorbisfile... no
checking how to run the C++ preprocessor... c++ -E
checking for ANSI C header files... yes
checking for fcntl.h... yes
checking for malloc.h... yes
checking for sys/ioctl.h... yes
checking for unistd.h... yes
checking for errno.h... yes
checking for bool.h... no
checking for pthread.h... yes
checking for pthread/mit/pthread.h... no
checking for pth.h... no
checking for curses.h... no
checking for sys/soundcard.h... yes
checking for machine/soundcard.h... no
checking for soundcard.h... no
checking for getopt.h... yes
checking for sys/soundcard.h... (cached) yes
checking for machine/soundcard.h... (cached) no
checking for soundcard.h... (cached) no
checking for mysql/mysql.h... no
checking for mysql.h... no
checking for ncurses/ncurses.h... no
checking for ncurses/curses.h... no
checking for ncurses.h... no
checking for main in -lsidplay... no
You need a decent ncurses (called curses on OpenBSD) library!

有如下提示。 不能生成文件。请帮看下还少啥东东。像GCC C++ NCURSES 都装了的。

另外 装ADOBE READER 时。同时下载了RPM 和DEB格式。DEB 装入没有问题。
RPM就提示少依赖文件。
提示如下。
tiger@tiger-desktop:~/download$ rpm -i AdobeReader_chs-7.0.0-2.i386.rpm
error: 依赖性检测失败:
/bin/sh 被 AdobeReader_chs-7.0.0-2.i386 所需要
ld-linux.so.2 被 AdobeReader_chs-7.0.0-2.i386 所需要
libX11.so.6 被 AdobeReader_chs-7.0.0-2.i386 所需要
libXext.so.6 被 AdobeReader_chs-7.0.0-2.i386 所需要
libatk-1.0.so.0 被 AdobeReader_chs-7.0.0-2.i386 所需要
libc.so.6 被 AdobeReader_chs-7.0.0-2.i386 所需要
libc.so.6(GLIBC_2.0) 被 AdobeReader_chs-7.0.0-2.i386 所需要
libc.so.6(GLIBC_2.1) 被 AdobeReader_chs-7.0.0-2.i386 所需要
libc.so.6(GLIBC_2.1.2) 被 AdobeReader_chs-7.0.0-2.i386 所需要
libc.so.6(GLIBC_2.1.3) 被 AdobeReader_chs-7.0.0-2.i386 所需要
libc.so.6(GLIBC_2.2) 被 AdobeReader_chs-7.0.0-2.i386 所需要
libc.so.6(GLIBC_2.2.4) 被 AdobeReader_chs-7.0.0-2.i386 所需要
libc.so.6(GLIBC_2.3) 被 AdobeReader_chs-7.0.0-2.i386 所需要
libdl.so.2 被 AdobeReader_chs-7.0.0-2.i386 所需要
libdl.so.2(GLIBC_2.0) 被 AdobeReader_chs-7.0.0-2.i386 所需要
libdl.so.2(GLIBC_2.1) 被 AdobeReader_chs-7.0.0-2.i386 所需要
libgcc_s.so.1 被 AdobeReader_chs-7.0.0-2.i386 所需要
libgcc_s.so.1(GCC_3.0) 被 AdobeReader_chs-7.0.0-2.i386 所需要
libgcc_s.so.1(GLIBC_2.0) 被 AdobeReader_chs-7.0.0-2.i386 所需要
libgdk-x11-2.0.so.0 被 AdobeReader_chs-7.0.0-2.i386 所需要
libgdk_pixbuf-2.0.so.0 被 AdobeReader_chs-7.0.0-2.i386 所需要
libgdk_pixbuf_xlib-2.0.so.0 被 AdobeReader_chs-7.0.0-2.i386 所需要
libglib-2.0.so.0 被 AdobeReader_chs-7.0.0-2.i386 所需要
libgmodule-2.0.so.0 被 AdobeReader_chs-7.0.0-2.i386 所需要
libgobject-2.0.so.0 被 AdobeReader_chs-7.0.0-2.i386 所需要
libgtk-x11-2.0.so.0 被 AdobeReader_chs-7.0.0-2.i386 所需要
libm.so.6 被 AdobeReader_chs-7.0.0-2.i386 所需要
libm.so.6(GLIBC_2.0) 被 AdobeReader_chs-7.0.0-2.i386 所需要
libm.so.6(GLIBC_2.1) 被 AdobeReader_chs-7.0.0-2.i386 所需要
libpango-1.0.so.0 被 AdobeReader_chs-7.0.0-2.i386 所需要
libpangox-1.0.so.0 被 AdobeReader_chs-7.0.0-2.i386 所需要
libpthread.so.0 被 AdobeReader_chs-7.0.0-2.i386 所需要
libpthread.so.0(GLIBC_2.0) 被 AdobeReader_chs-7.0.0-2.i386 所需要
libpthread.so.0(GLIBC_2.1) 被 AdobeReader_chs-7.0.0-2.i386 所需要
libpthread.so.0(GLIBC_2.2) 被 AdobeReader_chs-7.0.0-2.i386 所需要
libresolv.so.2 被 AdobeReader_chs-7.0.0-2.i386 所需要
libresolv.so.2(GLIBC_2.2) 被 AdobeReader_chs-7.0.0-2.i386 所需要
libstdc++.so.5 被 AdobeReader_chs-7.0.0-2.i386 所需要
libstdc++.so.5(CXXABI_1.2) 被 AdobeReader_chs-7.0.0-2.i386 所需要
libstdc++.so.5(GLIBCPP_3.2) 被 AdobeReader_chs-7.0.0-2.i386 所需要
libz.so.1 被 AdobeReader_chs-7.0.0-2.i386 所需要


莫不是少这么多文件吧。哈。。。请高手帮解读下。先谢了。。


页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2008-07-21 20:56 
头像

注册: 2006-07-02 11:16
帖子: 12522
地址: 廣州
送出感谢: 0 次
接收感谢: 8
http://wiki.ubuntu.org.cn/index.php?title=UbuntuHelp:CommonQuestions/zh&variant=zh-cn#.E5.AE.89.E8.A3.85.E8.BD.AF.E4.BB.B6


_________________
^_^ ~~~
要理解递归,首先要理解递归。

地球人都知道,理论上,理论跟实际是没有差别的,但实际上,理论跟实际的差别是相当大滴。


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2008-07-21 21:46 
头像

注册: 2007-01-06 21:00
帖子: 920
送出感谢: 2
接收感谢: 0 次
搜索这个ncurses安装试试


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2008-07-21 22:17 

注册: 2008-07-21 21:42
帖子: 11
送出感谢: 0 次
接收感谢: 0 次
:oops: :oops: :oops: :oops:


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 4 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 4 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译