当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 9 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 如何退出图形界面回文本界面?
帖子发表于 : 2008-07-23 10:07 

注册: 2007-04-24 8:54
帖子: 73
送出感谢: 0 次
接收感谢: 0 次
我下载了最新的显卡驱动,说明写着要退出x界面才能装,网上搜了init 3命令 还有ctrl-alt-backspace都不管用,安装时候仍提示未退出x界面,而且网上说的什么在/etc下修改inittab.conf文件,我的ubuntu8最新的2008.7.23am10.06刚更新完所有的东西,没有找到所谓的inittab文件,请帮帮我,谢谢!

补充一下,我看了论坛的http://forum.ubuntu.org.cn/viewtopic.php?t=138078这个帖子里面说的方法,还是无法退出x界面。


最后由 youyoubai 编辑于 2008-07-23 10:25,总共编辑了 1 次

页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2008-07-23 10:19 
头像

注册: 2007-11-10 1:09
帖子: 133
地址: 上海
送出感谢: 0 次
接收感谢: 0 次
1. ctrl+alt+f1
2. sudo /etc/init.d/gdm stop
3. 运行显卡驱动安装文件


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2008-07-23 11:02 

注册: 2007-04-24 8:54
帖子: 73
送出感谢: 0 次
接收感谢: 0 次
哦 是我看错了 gdm后面没有.
现在可以安装了
可是按照
http://forum.ubuntu.org.cn/viewtopic.ph ... highlight=
装到第8步,进入图形界面,白屏了。。。。怎么办?

ps:
(1)上面链接第二步中一句话“然后删除 /lib/linux-restricted-modules/2.6.24-14-generic/文件夹下面带有nvidia字样的内容,这里是内核自带的驱动”我的linux-restricted-modules下面有类似文件(2.6.22-14-generic,2.6.24-16-generic,2.6.24-18-generic,等6个文件)每个文件下面都有nvidia字样内容,我并没有删除。
(2)我的安装时候没有报错


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2008-07-23 15:24 

注册: 2007-04-24 8:54
帖子: 73
送出感谢: 0 次
接收感谢: 0 次
这个问题很难很难吗?还是已经有人问过了?给个链接吧


页首
 用户资料  
 
5 楼 
 文章标题 :
帖子发表于 : 2008-07-23 21:20 
头像

注册: 2007-10-06 3:48
帖子: 510
地址: 霍格沃茨魔法学校葛莱芬多学院
送出感谢: 0 次
接收感谢: 0 次
lz还是把驱动删了,再装回glx-new
或者重新配一下xserver
或者修改xorg.conf里分辨率什么的
都试试,总有好弄的。
或者把nvidia字样的删掉重新装,新驱动可能会和默认驱动文件发生冲突。
再说一般也犯不着去编译最新驱动啊,有没什么效果。lz什么显卡,很新吗?


_________________
Because...nobody really uses an operating system,
people use...programs...on their computer.
And the only mission in life of an operating system is to helps those programs run.
----Linus


页首
 用户资料  
 
6 楼 
 文章标题 :
帖子发表于 : 2008-07-23 22:21 

注册: 2007-04-24 8:54
帖子: 73
送出感谢: 0 次
接收感谢: 0 次
我不是想编译啊 我菜鸟一个 看nvidia上面这是最新的驱动就拿来试试 没想到这样了 楼上说的什么卸载呀 重装啊 什么的 能不能写个 step by step的教程呀 thankyou


页首
 用户资料  
 
7 楼 
 文章标题 :
帖子发表于 : 2008-07-24 22:28 
头像

注册: 2007-11-10 1:09
帖子: 133
地址: 上海
送出感谢: 0 次
接收感谢: 0 次
以下是安装NVIDIA官方驱动的guide,原帖找不到了
引用:
Okay, I got my problem fixed. Hopefully this helps you.

First I downloaded the Linux driver directly from the nVidia website. The selection of install scripts they have is here: http://www.nvidia.com/object/unix.html.

Second I did the following:
sudo apt-get install linux-headers-`uname -r` build-essential gcc gcc-3.4 xserver-xorg-dev

most of which was already installed. I then removed the previously installed nVidia stuff:

sudo apt-get --purge remove nvidia-glx nvidia-settings nvidia-kernel-common
sudo rm /etc/init.d/nvidia-*

Next you have to quit the x server to run the script

sudo /etc/init.d/gdm stop
sudo sh NVIDIA-Linux-x86_64-1.0-9746-pkg2.run
sudo nvidia-xconfig --add-argb-glx-visuals
sudo /etc/init.d/gdm start

The script spit out a few strange messages at the beginning, but I continued with the install anyway. I also found that since I'm on a 64-bit machine I should not install the 32-bit OpenGL compatibility libraries (it asks, that's why I mention this.)#这里要注意,如果你要玩魔兽,请选择安装

After all that I checked my xorg.conf file, did a reboot and it worked.

You might also want to make sure that the default color depth in your xorg.conf file is set to 24 and not 16.


页首
 用户资料  
 
8 楼 
 文章标题 : Re: 如何退出图形界面回文本界面?
帖子发表于 : 2011-10-14 22:14 

注册: 2009-03-05 20:59
帖子: 29
送出感谢: 0 次
接收感谢: 0 次
菜鸟还是多用哟你图形界面吧


页首
 用户资料  
 
9 楼 
 文章标题 : Re: 如何退出图形界面回文本界面?
帖子发表于 : 2011-10-14 22:22 
头像

注册: 2008-04-14 23:29
帖子: 2114
地址: 曾也在NB大学呆过
送出感谢: 3
接收感谢: 10
LS你盗古墓啊


_________________
kelltan.me


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 9 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 4 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译